Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 130440 - xfce4-4.4.0_beta1 release
Summary: xfce4-4.4.0_beta1 release
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
: 139898 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-19 01:25 UTC by Michal Kurgan (RETIRED)
Modified: 2015-11-25 18:46 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xfce4-4.4.0_beta1 ebuilds (xfce4.4.0_beta1.tar.gz,13.97 KB, application/octet-stream)
2006-04-19 01:27 UTC, Michal Kurgan (RETIRED)
Details
New beta ebuild for xfce4.4 cpugraph panel plugin (xfce4-cpugraph-0.3.ebuild,431 bytes, text/plain)
2006-05-08 11:03 UTC, slynn@granite-mtn.net
Details
New beta ebuild for xfce4.4 netload panel plugin (xfce4-netload-0.4.ebuild,407 bytes, text/plain)
2006-05-08 11:04 UTC, slynn@granite-mtn.net
Details
New beta ebuild for xfce4.4 diskperf panel plugin (xfce4-diskperf-2.0.ebuild,392 bytes, text/plain)
2006-05-08 11:05 UTC, slynn@granite-mtn.net
Details
New beta ebuild for xfce4.4 diskperf panel plugin (xfce4-diskperf-2.0.ebuild,392 bytes, text/plain)
2006-05-08 11:05 UTC, slynn@granite-mtn.net
Details
all plugin ebuilds (xfce-extra.tar.gz,27.25 KB, application/x-gzip)
2006-05-08 23:27 UTC, Ben Ford
Details
download location update (xfce44.eclass.patch,507 bytes, patch)
2006-05-08 23:37 UTC, Ben Ford
Details | Diff
xfce44_beta2_ebuilds.tar.gz (xfce44_beta2_ebuilds.tar.gz,5.07 KB, application/octet-stream)
2006-07-10 11:41 UTC, David Danier
Details
xfce-extra/xfce4-dev-tools-4.3.90.2.ebuild (xfce4-dev-tools-4.3.90.2.ebuild,403 bytes, text/plain)
2006-07-13 01:30 UTC, David Danier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Kurgan (RETIRED) gentoo-dev 2006-04-19 01:25:15 UTC
I've created almost all ebuilds (no xfce4-dev-tools) for xfce-4.4.0_beta1.
They are in single archive, they are only eutils class based and to limit problems i set only ~x86 keyword as i use this architecture.
It can be base for future release.

Additional information:
- dependencies take form configure scripts
- no debug information yet included (no configure flags for them)
- limited documentation features, omited for most of packages

Also on my dev site: http://dev.gentoo.org/~moloh/ebuilds/
Comment 1 Michal Kurgan (RETIRED) gentoo-dev 2006-04-19 01:27:37 UTC
Created attachment 84939 [details]
xfce4-4.4.0_beta1 ebuilds

Archive with all needed xfce packages.

I use only one additional use flag "no-plugin" to disable plugin building ie. for thunar, rest are standard ones.
Comment 2 Michal Kurgan (RETIRED) gentoo-dev 2006-04-19 01:32:10 UTC
Additional problem:
xfce-base/orage - configure script have to be changed to permit use of sys-libs/db as current in gentoo (we have /usr/include/db4.1 and /usr/include/db4.2, and configure only "db4", no minor version is permited, i will send info about that to developers)
Comment 3 Daniel Ostrow (RETIRED) gentoo-dev 2006-04-19 12:17:46 UTC
E-Builds will be in the tree later tonight...I'm just ironing out the final bumps.

Thanks.
Comment 4 Michal Kurgan (RETIRED) gentoo-dev 2006-04-19 12:41:30 UTC
If You would use these ebuilds here are some things i already spoted as bugs.

Problem with xfce-base/orage. It have to depends on sys-libs/db-4.0*. Also, path "/usr" have to be given to configure script with library localization.
There is also problem with gtk icon cache, gtk-update-icon-cache should be called after some ebuilds (ie. mcs-plugins and mcs) as they install icons in /usr/share/icons/hicolor/ but cache isn't updated...

Shortly i will send an updated version to my dev site (only with xfce-base/orage correction).
Comment 5 Ben Ford 2006-04-20 00:42:17 UTC
the ebuilds in the tree don't work.  After unmasking all the xfce 4.3 stuff, this is what I get:  

pluto ~ # emerge -uDa world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-notes-0.10.0-r2)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-clipman-0.4.1-r2)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-windowlist-0.1.0-r2)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-minicmd-0.3.0-r1)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-systemload-0.3.6-r1)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-showdesktop-0.4.0-r2)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-netload-0.3.3)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-battery-0.3.0-r2)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-taskbar-0.2.2-r2)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-cpugraph-0.2.2-r2)
[ebuild     U ] x11-apps/xinit-1.0.2-r2 [1.0.2] 
[ebuild     U ] x11-apps/xdm-1.0.3-r1 [1.0.3] 
[ebuild     U ] media-libs/libmpeg3-1.5.2-r3 [1.5.2-r2] 
[ebuild     U ] x11-themes/gtk-engines-xfce-2.3.90.1 [2.2.8] USE="-debug%" 
[ebuild     U ] media-sound/alsa-utils-1.0.11 [1.0.11_rc5-r1] 
[ebuild     U ] media-libs/alsa-oss-1.0.11 [1.0.11_rc3] 
[ebuild     U ] xfce-base/libxfce4util-4.3.90.1 [4.2.3.2] 
[ebuild     U ] xfce-base/libxfce4mcs-4.3.90.1 [4.2.3] 
[ebuild     U ] xfce-base/libxfcegui4-4.3.90.1 [4.2.3] USE="startup-notification%" 
[ebuild     U ] xfce-base/xfce4-panel-4.3.90.1 [4.2.3] USE="startup-notification%" 
[ebuild     U ] xfce-base/xfce-mcs-manager-4.3.90.1 [4.2.3] 
[ebuild     U ] xfce-extra/xfce4-mixer-4.3.90.1 [4.2.3] 
[ebuild     U ] xfce-base/xfprint-4.3.90.1 [4.2.3] USE="cups% -lpr%" 
[ebuild     U ] xfce-base/xfce-mcs-plugins-4.3.90.1 [4.2.3] 
[ebuild     U ] xfce-extra/xfce4-icon-theme-4.3.90.1 [4.2.3] 
[ebuild     U ] xfce-extra/mousepad-0.2.4 [0.2.2-r1] 
[ebuild     U ] xfce-extra/exo-0.3.1.6_beta1 [0.3.0] 
[ebuild  N    ] xfce-extra/terminal-0.2.5.1_beta1  USE="dbus startup-notification -debug -xslt" 
[ebuild  N    ] gnome-extra/evolution-data-server-1.4.2.1  USE="ipv6 ssl -debug -doc -kerberos -krb4 -ldap -nntp" 
[ebuild  N    ] xfce-base/orage-4.3.90.1  USE="berkdb -debug" 
[ebuild     U ] xfce-base/xfdesktop-4.3.90.1 [4.2.3] USE="-exo% -panel-plugin% -thunar-vfs%" 
[ebuild     U ] xfce-base/xfce-utils-4.3.90.1 [4.2.3] USE="-doc%" 
[ebuild     U ] xfce-base/xfce4-session-4.3.90.1 [4.2.3] 
[ebuild     U ] xfce-extra/xfce4-appfinder-4.3.90.1 [4.2.3] 
[ebuild     U ] xfce-base/xfwm4-4.3.90.1 [4.2.3.2] USE="startup-notification% xcomposite%" 
[ebuild     U ] xfce-extra/xfwm4-themes-4.3.90.1 [4.2.3] 
[ebuild     U ] xfce-base/xfce4-4.3.90.1 [4.2.3.2] 
[ebuild  N    ] xfce-extra/xfce4-notes-0.10.0-r2  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-clipman-0.4.1-r2  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-windowlist-0.1.0-r2  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-minicmd-0.3.0-r1  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-systemload-0.3.6-r1  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-showdesktop-0.4.0-r2  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-netload-0.3.3  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-battery-0.3.0-r2  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-taskbar-0.2.2-r2  USE="-debug" 
[ebuild  N    ] xfce-extra/xfce4-cpugraph-0.2.2-r2  USE="-debug" 
[ebuild     U ] dev-util/catalyst-2.0_rc43 [2.0_rc42] 

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

pluto ~ # 
Comment 6 Andrea Ratto 2006-04-20 08:15:31 UTC
please make xfce-utils depend on xfce-mcs-manager.
It will not compile without. 
Comment 7 ~ba 2006-04-20 08:24:03 UTC
@Ben: You have to unmerge all panel plugins, because they will block the new panel version. I don't know if this is a bug in the ebuild or if they are really incompatible with the new version.

Why is the evolution data server a dependency of orage? Afaik you only need this if you want to use orage in combination with evolution (to see tasks/calendar entrys). So it's useless for non evolution users.

But anyway thanks you Michal for his work!
Comment 8 Michal Kurgan (RETIRED) gentoo-dev 2006-04-20 11:50:23 UTC
orage in case of using USE="berkdb" should have "sys-libs/db-4.0*" dependency, it can only use 4.0.* versions.
And why do You add gnome-evolution-server dependency into orage?
Comment 9 Ben Ford 2006-04-20 15:01:16 UTC
@Bastian:

I did unmerge all the panel plugins that it complained about.  Notice that it wants to install them at the same time that it's complaining about them.  (Look at the first few lines and at the last few lines.)

unmerging xfce4-toys and xfce4-extras did the trick.
Comment 10 Ben Ford 2006-04-20 15:23:37 UTC
It built in the wrong order.  xfce4-panel was built before libxfce4util, so the compile failed.

checking for pkg-config >= 0.9.0... 0.20
checking for libxfce4util-1.0 >= 4.3.90.1... found, but 4.2.3.2
*** The required package libxfce4util-1.0 was found on your system,
*** but the installed version (4.2.3.2) is too old.
Comment 11 Congtat Cia 2006-04-23 01:02:35 UTC
Does orage really need gnome-evolution-server which require so many gnome-related packages?
Comment 12 M. Edward Borasky 2006-04-26 06:51:14 UTC
(In reply to comment #11)
> Does orage really need gnome-evolution-server which require so many
> gnome-related packages?
> 

I've installed xfce-4.3.90.1 on my main test box and it's mostly working. It's a kitchen sink box though ... everything I've ever even considered using is usually loaded on it, and I only rebuild it when it crashes irretrievably or I run out of disk space on it. :) Once you get the desktop up, you can specify thunderbird as your mail reader, so it may not actually be using evolution unless that's your mail reader.

Comment 13 slynn@granite-mtn.net 2006-04-27 10:36:48 UTC
A couple of items.

1. The upgrade to test out 4.4 beta1 went very smoothly and I'm up and running fully.

2. gnome-extra/evolution-data-server is _not_ needed for orage!  I couldn't even find a place in configure etc.. for even linking into eds.  This should either not be a dependency or be a USE flag.  I built and run fine without it.

3. gnome-base/orbit is not needed for thunar.  I didn't bother to see if there was a configure option for this, but built and run thunar fine without it.

These two changes saved me compiling in about 10-15 gnome libs that were part of the reason I moved to xfce.  Please change the ebuilds.

All-in-all great work.  Thanks.
Comment 14 Nikhil Sethi 2006-05-01 15:41:29 UTC
(In reply to comment #13)

to add to points in #13, gtk-doc is also not required to get xfce4 running AFAIK.
Thanks for the ebuilds!
Comment 15 Ben Ford 2006-05-04 12:12:19 UTC
A lot of the panel plugins have also been updated.  You can get them from:  ftp://ftp.berlios.de/pub/xfce-goodies/panel-plugins/4.4

I looked at updating the ebuilds, but they appear to use some kind of xfce42 eclass (is that the right termininology?) that I don't know how to update.
Comment 16 slynn@granite-mtn.net 2006-05-08 11:01:58 UTC
Thanks for the plugin update!

After bit of quick hacking I have the following plugin ebuilds working:

1. cpugraph
2. netload
3. diskperf

Most others should follow the same procedure:

1. Change the inherit from xfce42 to xfce44.  New eclass already added into /usr/portage/eclass/xfce44.eclass for our building pleasure.

2. Replace the goodies_plugin line with two lines:

xfce44_plugin
xfce44_goodies

3. ebuild xxx digest; emerge -av xxx

I compiled the new ebuilds successfully, installed them in my panel, played around a bit with the configs and called it good.  Ebuilds attached, although please let me know if I should submit individual bugs, new bug, etc...

Consider these "works for me" ebuilds and let me know.

Comment 17 slynn@granite-mtn.net 2006-05-08 11:03:49 UTC
Created attachment 86431 [details]
New beta ebuild for xfce4.4 cpugraph panel plugin
Comment 18 slynn@granite-mtn.net 2006-05-08 11:04:33 UTC
Created attachment 86432 [details]
New beta ebuild for xfce4.4 netload panel plugin
Comment 19 slynn@granite-mtn.net 2006-05-08 11:05:16 UTC
Created attachment 86433 [details]
New beta ebuild for xfce4.4 diskperf panel plugin
Comment 20 slynn@granite-mtn.net 2006-05-08 11:05:51 UTC
Created attachment 86434 [details]
New beta ebuild for xfce4.4 diskperf panel plugin
Comment 21 Ben Ford 2006-05-08 23:27:55 UTC
Created attachment 86462 [details]
all plugin ebuilds

This is a tarball of all the plugins available for xfce4.4.  Most work, but a few have problems.

1:  Verve has a sandbox error.
2:  The name of the file is wrong in xfce4-fsguard.
3:  sensors isn't tested (I don't have lm-sensors).
4:  The filename is wrong for xmms2-client.

Everything else should be working.  Sorry for the "halfass" job, but I've never worked with eclasses before.
Comment 22 Ben Ford 2006-05-08 23:37:04 UTC
Created attachment 86463 [details, diff]
download location update

This updates the download location of the plugins to the new ftp site.
Comment 23 slynn@granite-mtn.net 2006-05-09 09:36:05 UTC
Thanks for filling in the blanks.

I have a couple notes on the plugins which I do not believe are from the ebuilds - the plugins are beta after all.

1. cpugraph seems to actually generate cpu traffic of 100% on my machine randomly and I have to kill the process off by hand.

2. diskperf doesn't seem to persist in the panel across logins.  Where does it go?  The shadow knows...

3. battery monitor doesn't seem to listen to the panel's setting with respect to size.  my panel grew to about 48pt from a forced 26 when I installed battery.

Anybody pushing xfce4.4 desktop and plugin related bugs upstream?  I can submit these if needs be.

Comment 24 Ben Ford 2006-05-10 00:25:09 UTC
(In reply to comment #23)
...
> 3. battery monitor doesn't seem to listen to the panel's setting with respect
> to size.  my panel grew to about 48pt from a forced 26 when I installed
> battery.

This is because the icon doesn't scale.  Turn off the icon and the applet resizes just fine.

The weather applet has issues too.  It doesn't persist across sessions and has other odd behaviour.  If you open the preferences window and then press the close button, the applet itself closes.

Bugs filed:
http://bugzilla.xfce.org/show_bug.cgi?id=1791
http://bugzilla.xfce.org/show_bug.cgi?id=1792
http://bugzilla.xfce.org/show_bug.cgi?id=1793
http://bugzilla.xfce.org/show_bug.cgi?id=1794
Comment 25 Ben Ford 2006-06-03 17:36:05 UTC
I don't have time to write an ebuild for it just now, but there's a 4.4 wavelan plugin here:  http://foo-projects.org/pipermail/xfce/2006-May/017353.html

I'm sure that it will make it to the "official" download site shortly.
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2006-07-10 09:50:28 UTC
*** Bug 139898 has been marked as a duplicate of this bug. ***
Comment 28 David Danier 2006-07-10 11:41:59 UTC
Created attachment 91382 [details]
xfce44_beta2_ebuilds.tar.gz

Updated ebuilds for XFCE4.4 Beta2

Changes:
 * version bumps
 * xfce4-panel missed xfce-base/xfce-mcs-manager-dep (otherwise portage will try to compile the panel before xfce-mcs-manager, which does not work)
 * exo now depends on dev-perl/URI

Compiled fine here.
Comment 29 David Danier 2006-07-10 12:06:21 UTC
Added a new Ebuild for Xarchiver in bug 112132.
This should probably become a new dependency for the xfce-base/xfce4-ebuild as Xarchiver is now part of Xfce.

I'm not sure how interwoven Xfce and Xarchiver are. It looks like Xarchiver has a thunar-plugin, so perhaps it should depend on thunar....ok, this discussion should be moved to the Xarchiver-bug. ;-)
Comment 30 Ben Ford 2006-07-10 17:59:16 UTC
Several of the ebuilds have the wrong download link.  They are trying to pull from http://www.xfce.org/archive/xfce-4.3.90.1/src/ instead of http://www.xfce.org/archive/xfce-4.3.90.2/src/

So far exo and Terminal have this problem.
Comment 31 Michal Kurgan (RETIRED) gentoo-dev 2006-07-10 20:32:43 UTC
ebuilds updated on my devsite...  if anyone is interested.
Comment 32 David Danier 2006-07-11 01:08:32 UTC
> Several of the ebuilds have the wrong download link.

Sorry, I forgot to mention this: The xfce44-eclass has the versions hardcoded in it....so this eclass needs to be patched by simply changing XFCE_BETA_VERSION and THUNAR_BETA_VERSION to the current versionnumbers.
Comment 33 David Danier 2006-07-13 01:30:08 UTC
Created attachment 91627 [details]
xfce-extra/xfce4-dev-tools-4.3.90.2.ebuild

Created xfce4-dev-tools ebuild. This seems to be needed by some packages depending on Xfce4 (for example: xfmedia build from SVN, see bug 140195).
Comment 34 Samuli Suominen gentoo-dev 2006-07-13 05:29:45 UTC
(In reply to comment #33)
> Created an attachment (id=91627) [edit]
> xfce-extra/xfce4-dev-tools-4.3.90.2.ebuild
> 
> Created xfce4-dev-tools ebuild. This seems to be needed by some packages
> depending on Xfce4 (for example: xfmedia build from SVN, see bug 140195).
> 

Correct, but nothing in Portage tree needs xfce-dev-tools.
Comment 35 David Danier 2006-07-13 05:51:10 UTC
(In reply to comment #34)
> Correct, but nothing in Portage tree needs xfce-dev-tools.

Yes, but:
 * "Gentoo is about choice". If anyone wants to compile some XFCE-packages himself he should be able to (...without needing to write own ebuilds for every dependency).
 * It's part of the XFCE 4.4 Beta2 Release.
 * It's simple and small, should be not much work to maintain (I think the only change will be the version-number, the rest is done by the xfce-eclass which is maintained anyway)
 * Nothing (outside XFCE) depends on XFCE, too...but XFCE is included. ;-)
Comment 36 M. Edward Borasky 2006-07-13 06:27:33 UTC
I've been running xfce 4.3.90.1 more or less since it appeared in the tree. There were a few minor annoyances in the themes, but overall it was behaving very well for beta software. xfce 4.3.90.2 came along and I installed it. It did horrible things to firefox and thunderbird and I ended up having to create a new home directory (and switch to Windowmaker) just to read email and browse the Internet. Uninstalling xfce 4.3.90.2 and reinstalling firefox and thunderbird did not fix it.

I haven't had the time to dig into it and see what exactly happened, but there is some bizarre interaction between the theme configuration of xfce 4.3.90.2 beta and the rendering pieces of firefox and thunderbird that "rendered" them unusable. Some of the symptoms:

1. Black backgrounds/black text in the tool tips on the XFCE panel
2. Black backgrounds/black text in firefox and thunderbird.
3. Message subjects in thunderbird showing only the first word until you mouse over them.
4. Miscellaneous things in both thunderbird and firefox not showing up until you mouse over them
5. Some things not showing up even if you do mouse over them.

Am I the only one that's seen this? I just recently updated to modular X and also installed "seamonkey", so it might not be XFCE 4.3.90.2 alone that's responsible.
Comment 37 Ben Ford 2006-07-13 10:39:01 UTC
That sounds more like the problem with xorg-server 1.1.x and nvidia-glx than XFCE.
Comment 38 Daniel Ostrow (RETIRED) gentoo-dev 2006-07-20 00:48:21 UTC
Cleanup of old bugs...ebuilds in the tree for a while now.

--Dan