Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 130051 - Unreal Gold: new package with ebuild
Summary: Unreal Gold: new package with ebuild
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Default Assignee for New Packages
Keywords: EBUILD
Depends on: 134156 139196
  Show dependency tree
Reported: 2006-04-15 04:55 UTC by patrick
Modified: 2019-12-09 03:43 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---

unreal-gold-226.ebuild (unreal-gold-226.ebuild,5.77 KB, text/plain)
2006-04-15 04:56 UTC, patrick
the non s3tc unreal-gold-226.ebuild (unreal-gold-nons3tc-226.ebuild,4.29 KB, text/plain)
2006-05-30 12:28 UTC, patrick
unreal-s3tc-textures.ebuild (unreal-gold-s3tc-textures.ebuild,1.67 KB, text/plain)
2006-05-30 12:30 UTC, patrick
unreal-gold-226.ebuild non s3tc version (unreal-gold-226.ebuild,4.62 KB, text/plain)
2006-06-29 13:06 UTC, patrick
unreal-gold-s3tctextures.ebuild (unreal-gold-s3tctextures.ebuild,1.57 KB, text/plain)
2006-06-29 13:22 UTC, patrick
unreal-gold-226.ebuild non s3tc version (unreal-gold-226.ebuild,4.53 KB, text/plain)
2006-06-29 13:28 UTC, patrick
unreal-gold-226.ebuild non s3tc version fixed (unreal-gold-226.ebuild,4.58 KB, text/plain)
2007-04-01 11:42 UTC, David H. Bronke
changed a 'cp' to the proper 'insinto/doins' (unreal-gold-226.ebuild,4.59 KB, text/plain)
2007-10-13 05:51 UTC, Brandon Captain
unreal-451.ebuild (unreal-451.ebuild,13.17 KB, text/plain)
2007-11-24 13:52 UTC, James Le Cuirot
unreal-451.ebuild (unreal-451.ebuild,13.65 KB, text/plain)
2008-05-08 12:50 UTC, James Le Cuirot
unreal-451.ebuild (unreal-451.ebuild,13.73 KB, text/plain)
2008-05-08 12:55 UTC, James Le Cuirot
unreal-451.ebuild (unreal-451.ebuild,14.12 KB, text/plain)
2008-09-06 09:04 UTC, James Le Cuirot
unreal-451.ebuild (unreal-451.ebuild,14.12 KB, text/plain)
2008-09-06 09:10 UTC, James Le Cuirot
unreal-451.ebuild - fixes issue from comment 48 (unreal-451.ebuild,14.29 KB, text/plain)
2010-07-09 02:15 UTC, Jared B.
games-fps/unreal-451.ebuild (unreal-451.ebuild,14.54 KB, text/plain)
2011-09-29 23:13 UTC, Jared B.
games-fps/unreal-451.ebuild (unreal-451.ebuild,14.54 KB, text/plain)
2012-09-15 04:25 UTC, Jared B.

Note You need to log in before you can comment on or make changes to this bug.
Description patrick 2006-04-15 04:55:38 UTC
I wrote an ebuild for Unreal Gold. It is complete except for the pkg_setup part, because I do not own a Unreal Tournament CD and consequently can't complete the cdrom_get_cds commando. The rest should work.
Comment 1 patrick 2006-04-15 04:56:28 UTC
Created attachment 84709 [details]

This is the ebuild.
Comment 2 patrick 2006-04-15 04:58:40 UTC
Forgot to say, the ebuild is partly based on the Unreal and Unreal Tournament ebuilds already present in portage.
Comment 3 patrick 2006-05-30 12:28:29 UTC
Created attachment 87903 [details]
the non s3tc unreal-gold-226.ebuild

I did a seperate ebuild for the s3tc textures, I think that is nicer.
Comment 4 patrick 2006-05-30 12:30:05 UTC
Created attachment 87904 [details]

The seperate s3tc textures ebuild.
Comment 5 patrick 2006-06-29 13:06:40 UTC
Created attachment 90463 [details]
unreal-gold-226.ebuild non s3tc version

Much more tidy version. This one should also actually, because I sorted the cdrom_set thingy out.
Comment 6 patrick 2006-06-29 13:08:06 UTC
Comment on attachment 90463 [details]
unreal-gold-226.ebuild non s3tc version

># Copyright 1999-2005 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>inherit eutils games
>DESCRIPTION="Futuristic FPS (a hack that runs on top of Unreal Tournament)"
>KEYWORDS="-* x86"
>UIDEPEND="!amd64? (
>		|| (
>			(
>				x11-libs/libXext
>				x11-libs/libX11
>				x11-libs/libXau
>				x11-libs/libXdmcp )
>			virtual/x11 )
>		opengl? ( virtual/opengl )
>		=media-libs/libsdl-1.2* )
>	amd64? (
>		app-emulation/emul-linux-x86-sdl
>		app-emulation/emul-linux-x86-baselibs
>		app-emulation/emul-linux-x86-xlibs )"
>RDEPEND="X? ( virtual/x11 ) 
>    opengl? ( virtual/opengl )"
>	dev-util/xdelta
>	sys-libs/lib-compat
>	app-arch/unzip"
>pkg_setup() {
>	export CDROM_SET_NAMES=("Unreal Tournament" "Unreal Tournament GOTY CD1")
>	cdrom_get_cds Maps/UT-Logo-Map.unr:MAPS/
>	games_pkg_setup
>src_unpack() {
>	unpack_makeself
>	unpack data.tar.gz
>	mkdir ut
>	cd ut
>	case ${CDROM_SET} in
>		0) unpack_makeself ;;
>		1) unpack_makeself ;;
>	esac ;
>	unpack
>	unpack data.tar.gz
>	unpack OpenGL.ini.tar.gz
>src_install() {
>	local dir=${GAMES_PREFIX_OPT}/unreal-gold
>	dodir "${dir}"
>	# the UT part
>	# System files
>	insinto "${dir}"/System
>	doins "${CDROM_ROOT}"/System/*.{int,u}
>	doins ut/
>	for x in ut/*.0; do
>		xdelta patch ${x} "${CDROM_ROOT}"/System/$(basename ${x} .0) ut/System/$(basename ${x} .0) ;
>	done
>	doins ut/System/*.{int,u,so,0,2}
>	# copying Sounds
>	insinto "${dir}"/Sounds
>	doins "${CDROM_ROOT}"/Sounds/*.uax
>	if use nls ; then
>		doins "${CDROM_ROOT}"/Sounds/*.{est,frt,itt}_uax
>	fi
>	# copying Textures
>	insinto "${dir}"/Textures
>	doins "${CDROM_ROOT}"/Textures/{AlfaFX.utx,Ancient.utx,BluffFX.utx,castle1.utx,ChizraEFX.utx,Crypt.utx,DMeffects.utx,DecayedS.utx,Detail.utx,Female1Skins.utx,Female2Skins.utx,FireEng.utx,GenEarth.utx,GenFX.utx,GenFluid.utx,GenIn.utx,GenTerra.utx,GenWarp.utx,GreatFire.utx,GreatFire2.utx,HubEffects.utx,ISVFX.utx,JWSky.utx,LavaFX.utx,Liquids.utx,Male1Skins.utx,Male2Skins.utx,Male3Skins.utx,MenuGr.utx,Mine.utx,NaliCast.utx,NaliFX.utx,Palettes.utx,PlayrShp.utx,Queen.utx,Render.utx,ShaneDay.utx,ShaneSky.utx,SkTrooperSkins.utx,Skaarj.utx,SkyBox.utx,SkyCity.utx,SpaceFX.utx,Starship.utx,TCrystal.utx,Terranius.utx,UWindowFonts.utx,XFX.utx} ;
>	# the Unreal part
>	export CDROM_NAME="Unreal Gold CD"
>	cdrom_get_cds MANUALS/Gold\ Manual\ addedum.doc
>	# Unreal System stuff
>	insinto "${dir}"/System
>	doins System/* || die "copy System data"
>	exeinto "${dir}"/System
>	doexe System/{ucc,unreal}-bin
>	if use nls ; then
>		cp "${CDROM_ROOT}"/System/*.{est,frt,itt,det} "${Ddir}"/System/ || die "copy language data" ;
>	fi
>	xdelta patch "${CDROM_ROOT}"/SYSTEM/UPak.u UPak.u
>	doins UPak.u
>	doins "${CDROM_ROOT}"/SYSTEM/UDSDemo.u
>	# copying Maps
>	insinto "${dir}"/Maps
>	doins "${CDROM_ROOT}"/MAPS/*
>	insinto "${dir}"/Maps/UPak
>	doins "${CDROM_ROOT}"/MAPS/UPak/*
>	# copying Help
>	insinto "${dir}"/Help
>	doins Help/*
>	# copying Music
>	insinto "${dir}"/Music
>	doins "${CDROM_ROOT}"/MUSIC/*
>	# repairing things
>	for f in "${D}/${dir}"/{Maps,Maps/UPak}/Dm*.unr ; do
>	mv ${f} ${f/Dm/DM-}
>	done
>	dosym Maps "${dir}"/maps
>	# copying Sounds
>	insinto "${dir}"/Sounds/
>	doins "${CDROM_ROOT}"/Sounds/*.uax || die "copy Sounds CD1"
>	insinto "${dir}"/Sounds/int
>	doins "${CDROM_ROOT}"/Sounds/int/* || die "copy Sounds CD1"
>	if use nls ; then
>		for x in {det,est,frt,itt}; do
>		insinto "${dir}"/Sounds/${x}
>		doins "${CDROM_ROOT}"/Sounds/${x}/* || die "copy Sounds CD1" ;
>	done
>	fi
>	# copying Textures from Unreal
>	insinto "${dir}"/Textures
>	doins "${CDROM_ROOT}"/Textures/{Credits,UGoldCredits,UPakFonts,Langs,Castle1}.utx
>	# the main executables
>	exeinto "${dir}"
>	doexe bin/Linux/x86/glibc-2.1/ucc
>	doexe bin/Linux/x86/glibc-2.1/unrealgold
>	# and the rest
>	# installing documentation/icon
>	mv icon.xpm unrealgold.xpm
>	insinto "${dir}"
>	doins unrealgold.xpm README
>	dodoc README || die "Could not dodoc README.linux"
>	doicon unrealgold.xpm || die "Could not copy pixmap"
>	games_make_wrapper unrealgold ./unrealgold "${dir}" "${dir}"
>	prepgamesdirs
Comment 7 patrick 2006-06-29 13:09:13 UTC
Wee, didn't intend that one, sorry. Just wanted to edit an attachment.
Comment 8 patrick 2006-06-29 13:22:58 UTC
Created attachment 90466 [details]

Cleaner ebuild.
Comment 9 patrick 2006-06-29 13:28:39 UTC
Created attachment 90469 [details]
unreal-gold-226.ebuild non s3tc version

Fixed an unpack problem, and removed the header.
Comment 10 Keszeg Alexandru 2006-10-28 18:00:38 UTC
I have installed unreal gold, but when i run the game i get:

$ unrealgold 
appError called:
ReadFile beyond EOF 0+4/0
Executing UObject::StaticShutdownAfterError
Signal: SIGIOT [iot trap]
Name subsystem shut down

I already have installed games-fps/unreal-tournament-goty-451 and that works fine
Comment 11 patrick 2006-10-29 08:17:06 UTC
@Keszeg Alexandru: Did you use my ebuild? And did emerge ask for the Unreal Gold CD?

EOF sounds like a broken CD....
Comment 12 David H. Bronke 2007-04-01 11:42:00 UTC
Created attachment 115145 [details]
unreal-gold-226.ebuild non s3tc version fixed

The ebuild referenced at which now installs correctly and automatically detects the CDs correctly. The ebuild was also cleaned up, with better error messages.
Comment 13 patrick 2007-04-01 17:52:38 UTC
I made this bug depend on the CDROM_SET_NAME bug, because this is needed to solve the CD madness in these ebuilds. For more explanation see this forum thread [url][/url].
Comment 14 Brandon Captain 2007-10-13 05:51:15 UTC
Created attachment 133287 [details]
changed a 'cp' to the proper 'insinto/doins'

unreal-gold wouldn't work for me until I changed the cp to a insinto/doins. thats how it should have been done anyhow.
Comment 15 James Le Cuirot gentoo-dev 2007-11-24 13:52:17 UTC
Created attachment 136886 [details]

Here's a totally new ebuild, which supports the original Unreal, Unreal Gold and Unreal Anthology. However, in all cases, Return To Na Pali is not installed at all. That can be installed separately. See bug #162097.

It runs on top of UT 451, hence the version number. Unreal's version is irrelevant. The game previously ran on top of UT 436 but I managed to get 451 to work. As such, the installers from are no longer used. Instead, I have created my own tarball of patches and files to be shared between this and RTNP. It also contains a README if you're curious. It's a couple of megs and I figured it may still change so rather than upload it here, I've uploaded it to Please DO NOT use that as the SRC_URI though, that's just my place for uploading random junk.

You should find that this version is much more reliable than previous ones. It may have just been me but the old version seemed to crash when loading saved games. That's fixed. All the alternative languages are supported. You can even reinstall the game without the CD by pointing CD_ROOT to /opt/unreal. There are other improvements too.
Comment 16 James Le Cuirot gentoo-dev 2007-11-24 13:53:20 UTC
Oh yeah, somebody please mark this bug as depending on bug #134156. I doubt it would work with the old UT ebuild.
Comment 17 Chris Gianelloni (RETIRED) gentoo-dev 2007-11-25 01:43:49 UTC
The only thing I am worried about is the legality of distributing your tarball.  We are talking commercial software here.
Comment 18 James Le Cuirot gentoo-dev 2007-11-25 11:54:31 UTC
I thought someone might bring that up. The xdp files are patches. No problem there, I think. The int/det/est/frt/itt files are just plain text localisation files and similar files were included in the installers. The only binary files taken directly from the game are UGCredits.unr and UGoldCredits.utx, which are the credits map and credits textures respectively. I don't think anyone is going to lose sleep over those, plus they've been included in one of the installers for years. If you're still uncomfortable, they can be removed, it just means the credits won't work in Return To Na Pali. The credits don't work in Unreal anyway because that map requires stuff that wasn't included with the original game.
Comment 19 Brandon Captain 2007-12-01 20:01:13 UTC
If nobody has tested this with the Anthology CD that comes with the collector's edition of UT3, I've got a friend trying to sell his CD for whatever he can get for it. email me if you're interested.

this isn't spam, it's all in the interest of this ebuild ;-)
Comment 20 James Le Cuirot gentoo-dev 2007-12-01 20:57:47 UTC
From what I gather, that Anthology is the same as the one I have, the one that's already been around for over a year now. So it already works.
Comment 21 Joshua Barney 2008-05-08 04:35:21 UTC
Any suggestions?  I'm using the latest unreal-tournament ebuild from bugzilla...

xdelta: expected from file (//opt/unreal-tournament/System/UMenu.u) of length 1904411 bytes
 * ERROR: games-fps/unreal-451 failed.
 * Call stack:
 *     , line   49:  Called src_unpack
 *             environment, line 2459:  Called die
 * The specific snippet of code:
 *       xdelta patch "u1-on-ut-${PVR}/UMenu.u-${PV}.xdp" "${ROOT}${UT_DIR}/System/UMenu.u" System/UMenu.u || die "xdelta patch UMenu.u";
 *  The die message:
 *   xdelta patch UMenu.u
Comment 22 James Le Cuirot gentoo-dev 2008-05-08 09:17:18 UTC
It seems UMenu.u from the original is different from the one in the Anthology. Le sigh. I thought I'd tested this with the original but I guess I didn't. My friend has it right now but I'll get him to send that file so that I can make an additional patch.
Comment 23 James Le Cuirot gentoo-dev 2008-05-08 12:50:25 UTC
Created attachment 152469 [details]

I looked into this carefully. The 436 patches update the original/GOTY UMenu.u files so that they match. However, for some reason, the resulting file still differs from the version distributed with Anthology. I have therefore created an additional patch for the 436 version to accompany the existing patch for the Anthology version. The u1-on-ut-451.tar.bz2 file has consequently changed so please download it again. The RTNP ebuild has also been updated accordingly.
Comment 24 James Le Cuirot gentoo-dev 2008-05-08 12:55:49 UTC
Created attachment 152475 [details]

Crap! I didn't properly handly the "unsupported" case.
Comment 25 Ben Leggett 2008-07-01 18:49:08 UTC
Just a quick note:

The ebuild fails if xdelta-3.x.x is used. It requires xdelta-1.x.x.
The ebuild should probably specify this.
Comment 26 karafeka 2008-09-01 19:30:18 UTC
Is there any change to suuport ut goty?

I emerged unreal-tournament-goty-451 (installs and plays fine).
Then I change unreal-tournament-goty-${PV}

in unreal-451.ebuild.

It emerges fine, and also shows intro movie, and unreal gold picture, but there is no menus. 

In terminal I get this errors UMenuMenuBar Transient.UMenuMenuBar0 (Function UMenu.UMenuMenuBar.DrawItem:00A4) Accessed None
UMenuStatusBar Transient.UMenuStatusBar0 (Function UMenu.UMenuStatusBar.Paint:00A3) Accessed None
UMenuStatusBar Transient.UMenuStatusBar0 (Function UWindow.UWindowWindow.DrawUpBevel:000C) Accessed None
UMenuStatusBar Transient.UMenuStatusBar0 (Function UWindow.UWindowWindow.DrawStretchedTextureSegment:018A) DrawTileClipped: Missing Texture
UMenuStatusBar Transient.UMenuStatusBar0 (Function UWindow.UWindowWindow.DrawUpBevel:007C) Accessed None
UMenuStatusBar Transient.UMenuStatusBar0 (Function UWindow.UWindowWindow.DrawUpBevel:00A0) Accessed None
UMenuStatusBar Transient.UMenuStatusBar0 (Function UWindow.UWindowWindow.DrawUpBevel:00C1) Accessed None
UMenuStatusBar Transient.UMenuStatusBar0 (Function UWindow.UWindowWindow.DrawUpBevel:00D6) Accessed None

Could I fix this? 

I remember using icculus install script long ago, but I can't find it anywhere on the net.

Comment 27 James Le Cuirot gentoo-dev 2008-09-01 19:36:16 UTC
You need to use the new UT ebuild from bug #134156. That one supports all the different versions of UT in a consistent way and the ebuild I posted here is designed to work with that one.
Comment 28 karafeka 2008-09-01 21:12:25 UTC
(In reply to comment #27)
> You need to use the new UT ebuild from bug #134156. That one supports all the
> different versions of UT in a consistent way and the ebuild I posted here is
> designed to work with that one.

Well, I don't know if we understand each other, but I have problem with unreal gold, not with ut. 

But I tried emerging unreal-tournament-451.ebuild from bug 134156, and this unreal-451, but is exactly the same. I noticed error mesage while emerging unreal-451:
Unsupported UMenu.u detected

How to fix this?

Comment 29 James Le Cuirot gentoo-dev 2008-09-02 01:15:25 UTC
I understand perfectly. (-: UT is needed because Unreal was never released for Linux. The old Unreal ebuilds used to copy everything needed from the UT CD but because the new UT ebuild is so complex, it didn't make sense to repeat all of that in this ebuild (which is also rather complex) so it symlinks the files instead.

UMenu.u is a file from UT. It needs some modificiations to work with Unreal so rather than symlink that file like the others, we have to patch it. As far as I've been able to tell, as long as you have at least version UT 436, there are only two official versions of it, the one from a patched installation of original/GOTY and the one from Anthology. You're telling me that you have GOTY, which should be fine, but where did you install it from when using my ebuild? Was it the CD or some previous installation? If it wasn't from the CD then please try that because we can't cater for modified versions. If it was from the CD then it looks like there may be some version I haven't accounted for. In that case, please tell me everything you can about the version you have and give me the result of "md5sum /opt/unreal-tournament/System/UMenu.u".
Comment 30 karafeka 2008-09-02 17:48:25 UTC
I installed from two cds. 

md5sum for Umenu.u on cd is:
bbec875a92f258bf01f07638fe29baff  SYSTEM/UMenu.u

I have goty version for sure, but don't know exactly which number.  Probably 451, beacuse when I try to emerge goty-436 it failes with:

ERROR: No matching delta for /var/tmp/portage/games-fps/unreal-tournament-goty-436/image///opt/unreal-tournament/System/Editor.u
when extracting textures from second cd.

goty-451 emerges fine (installing both cds), but there is menu issue with unreal-451.
And I really like to play unreal ;). 
Comment 31 James Le Cuirot gentoo-dev 2008-09-02 22:24:53 UTC
This is very strange indeed. I searched for that MD5 and found one instance of it at the thread about MD5 hashes so unless you have gone by the name of Obsidian in the past, you are not the only person in the world with this version.

It is not possible for you to have 451 on CD because 451 never had a retail release. Even the Anthology DVD only came with 436. The Linux 451 patch is actually not a patch but just a bunch of files you unpack. UMenu.u is not one of those files. What this means is that, at least as far as I was aware, from 436 onwards there are only two versions of UMenu.u, the one from 436 (either via patches or GOTY) and the one from Anthology.

What you are telling me is that there is a third version. You say it is GOTY. As far as I know, this came in two flavors, 432 and 436. I know you don't have 432 because the patching would have failed. With 436, we don't apply any patches, we simply replace files. I am therefore guessing that my UT ebuild gives you the message "UT version 436/440 (GOTY or patched) detected". Is that correct? If so then the question is, why is yours different to the others I've seen? A md5sum file listing of the CDs may give a clue so please provide those if you can.

I've been planning to give these ebuilds a trial run in the forums but it's important that this problem gets solved first.
Comment 32 James Le Cuirot gentoo-dev 2008-09-02 22:35:14 UTC
Looking back through bug #134156, it occurred to me that you might have the "Best of Infogrames" version. Any sign of that name? I don't have the md5sums for that version but I do have a file listing with files sizes. See the UT_GOTY_CD1 attachment from that bug report.
Comment 33 karafeka 2008-09-03 16:48:18 UTC
Well, I think I solved this.

1. emerged unreal-tournament-goty-451 (in gentoo portage) with opengl, S3tc and nls

2. downloaded unreal-gold-s3tctextures.ebuild and renamed it to unreal-gold-226 and put it in local portage.
3. emerged unreal-gold-226 which pulled in also unreal-226 as dependencie. It asked for unreal gold cd and ut goty second cd which both installed fine. 
4. modified UseS3TC from 0 to 1 in ~/.loki/unreal/System

4. $ unreal

Runs great.

There is Inforgrames logo on pictures in HELP directory on CD1, but there is no mention of "best of infogrames". 
I compared your list with my cd. As far I could tell, it's the same - number of files, dates, size etc.
If I rememeber correctly, there was message about GOTY detected, when emerging ut-451.

My copy is "second-hand" so maybe this is the reason why md5 is different for Umenu.u ;)
Comment 34 James Le Cuirot gentoo-dev 2008-09-03 16:53:32 UTC
It's good that you got it working but I'd like to see this ebuild working properly. There were a few problems with the old version anyway so it's worth getting this right. I'd be very grateful if you could e-mail me your UMenu.u so that I can make a patch for it.
Comment 35 James Le Cuirot gentoo-dev 2008-09-06 09:04:54 UTC
Created attachment 164692 [details]

Thanks for the file, I've sorted that now. When I first made the patch, I noticed the patch filesize was exactly the same as the Anthology patch. That seemed like too much of a coincidence so I delved a little deeper. Here's what I wrote in the README...

There is actually a third official version of UMenu.u, which comes with the "Best of Infogrames" version. Rather than patch from this version directly to the custom version, this patches to the Unreal Anthology version instead. The reason for this is because these two versions are identical except for the support URL. Evidently Epic used a hex editor to make this change because padding has been added to the URL to make the string the same length as it was before. This indirect method of patching saves 608KB.

I know the game already works for you now but I'd be very grateful if you could try this new version with my UT ebuild. Let me know how it goes.

To the devs, I have now uploaded the u1-on-ut tarball to my space on I am happy this to serve as a permanent location.
Comment 36 James Le Cuirot gentoo-dev 2008-09-06 09:10:19 UTC
Created attachment 164698 [details]

Gah. I keep typing Infrogrames instead of Infogrames.
Comment 37 karafeka 2008-09-06 16:46:24 UTC
Great, installs fine with your ut-451 from bug and this last unreal-451.
Menu is now gold, indeed :). 
I can play unreal, but ut gives me
Signal: SIGSEGV [segmentation fault]
But this isn't issue for me. 

Just one question. Unreal gold supposed to have Return to Napali, How to play this under linux ? Under UT menu is no reference to it. Is there any special command line ?
Comment 38 James Le Cuirot gentoo-dev 2008-09-06 17:13:49 UTC
Strange that one works and not the other. Try deleting ~/.loki/ut. Some old settings could be screwing it up.

For RTNP, check out bug #162097. It works with Gold, Antology and the standalone expansion.
Comment 39 karafeka 2008-09-06 19:02:32 UTC
(In reply to comment #38)
> Strange that one works and not the other. Try deleting ~/.loki/ut. Some old
> settings could be screwing it up.

No, I deleted those files when unemerging prevoius installation. 
Comment 40 James Le Cuirot gentoo-dev 2008-09-07 09:34:38 UTC
The only other suggestion I can think of is that you enable the openal USE flag for UT. Unreal forces OpenAL because it doesn't work well with the generic driver. That would explain why one works but the other doesn't.
Comment 41 karafeka 2008-09-08 17:11:49 UTC
Thanks, will try that. 

But regarding unreal, I'm facing a problem with level illumination (35th level).
Fog never goes away, so i cannot end this level.
I found some reference on internet, that this happens with OldSkool mod. 

Does anybody else experienced similiar problem under linux ?
Fastest way to try is with cheat.... go to console and type
$ open ExtremeDGen

That loads illumination map. 
Comment 42 James Le Cuirot gentoo-dev 2008-09-08 17:28:19 UTC
I haven't tried much of the game beyond the first couple of levels. I haven't got 3D acceleration for the moment but I'll try it as soon as I do. It might be possible to edit the level properties or even modify it with UnrealEd. From there, I'd create a patch. If it were that easy though, the OldSkool mod guys probably would have fixed it.
Comment 43 David H. Bronke 2008-12-09 16:45:00 UTC
When using paludis with userpriv, this ebuild fails trying to read the UnrealTournament.ini file from UT... that file should probably be made world-readable.

Here's the error I receive:

>>> Starting src_unpack
>>> Unpacking u1-on-ut-451.tar.bz2 to /var/tmp/paludis/games-fps-unreal-451/work
tar jxf /var/paludis/repositories/gentoo/distfiles/u1-on-ut-451.tar.bz2 --no-same-owner
sed: can't read //opt/unreal-tournament/System/UnrealTournament.ini: Permission denied

!!! ERROR in games-fps/unreal-451:
!!! In src_unpack at line 3608
!!! sed UnrealTournament.ini > Unreal.ini

!!! Call stack:
!!!    * src_unpack (/var/tmp/paludis/games-fps-unreal-451/temp/loadsaveenv:3608)
!!!    * ebuild_f_unpack (/usr/libexec/paludis/0/src_unpack.bash:42)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:477)
!!!    * main (/usr/libexec/paludis/ebuild.bash:492)

diefunc: making ebuild PID 20620 exit with error
die trap: exiting with error.

Install error:
  * In program paludis -i unreal-tournament unreal unreal-returntonapali:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'games-fps/unreal-451:0::local-portage':
  * Install error: Install failed for 'games-fps/unreal-451:0::local-portage'

Changing that file to a+r and the directories that contain it to a+rx fixes the issue, but then I get a similar error with //opt/unreal-tournament/ut, //opt/unreal-tournament/System/ut-bin, //opt/unreal-tournament/System/, and a few more in System; fixing the permission for everything in System/ in a similar fashion fixes the build.
Comment 44 Brandon Captain 2009-03-29 23:13:15 UTC
caibbor@helios ~ $ unrealgold
appError called:
ReadFile beyond EOF 0+4/0
Executing UObject::StaticShutdownAfterError
Signal: SIGIOT [iot trap]
Name subsystem shut down
Comment 45 Kai Krakow 2010-04-18 19:39:05 UTC
Is the download still available somewhere? (u1-on-ut-451.tar.bz2)
Comment 46 James Le Cuirot gentoo-dev 2010-04-18 19:57:02 UTC
It seems that my account on disappeared after a new server was installed. I need to pester bonsaikitten about it.
Comment 47 James Le Cuirot gentoo-dev 2010-04-18 20:48:37 UTC
Ask and ye shall receive. The URL is now working again. :)
Comment 48 Jared B. 2010-07-09 02:14:35 UTC
Final ebuild wouldn't install on my system.  Was dying with a security warning on this line:

	chmod 750 System/unreal-bin System/*.so System/*.so.* || die

Since this is linking against Unreal Tournament (literally), I think it didn't like trying to change permissions on the symlinked libraries.  Changing it to this fixed it:

	for x in `find -P System/ -type f \( -name "unreal-bin" -o -name "*.so" -o -name "*.so.*" \)` ; do
		chmod 750 "${x}" || die "chmod exec"

Otherwise, works great.  I'll attach a slightly revised ebuild containing this fix.
Comment 49 Jared B. 2010-07-09 02:15:59 UTC
Created attachment 238091 [details]
unreal-451.ebuild - fixes issue from comment 48
Comment 50 James Le Cuirot gentoo-dev 2010-07-09 07:46:27 UTC
Strange that I didn't see that before. I guess the sandbox has improved.
Comment 51 DavidH 2010-07-24 04:12:39 UTC
I'm getting a 503 for the tarball link:

But that appears to be because the server itself is offline.  I just posted on the forum:

.. and figured I'd drop a note here in case James has any bells he can ring regarding the server.

Cheers!  (can't wait to try out the new unreal ebuild)
Comment 52 James Le Cuirot gentoo-dev 2010-07-24 11:14:04 UTC
Someone's already contacted Patrick so it probably won't be down for much longer.
Comment 53 DavidH 2010-07-24 14:53:26 UTC
Latest ebuild + tarball worked great, with the exception that I had to temporarily downgrade xdelta (as mentioned in a previous comment).

Is there a decent way to allow the build to work with either xdelta 1.x or 3.x?   I hate when utils change their executable name across versions ('xdelta' vs. 'xdelta3'), but maybe they're not 100% compatible (I'm no xdelta expert).

Anyway, that was the only hiccup I encountered.  Thanks so much for the continued effort put into this.
Comment 54 DavidH 2010-07-24 14:56:58 UTC
(In reply to comment #53)
> Is there a decent way to allow the build to work with either xdelta 1.x or 3.x?
>   I hate when utils change their executable name across versions ('xdelta' vs.
> 'xdelta3'), but maybe they're not 100% compatible (I'm no xdelta expert).

Ah... xdelta is slotted, I didn't realize that.  So comment #25 is more accurate (the ebuild just needs better dependency reporting), though I guess my question might still be relevant: is there any reason not to make the ebuild work with either generation of xdelta?
Comment 55 No Name 2010-08-22 19:28:14 UTC

Who can link oder upload somewhere the u1-on-ut-451.tar.bz2 file??

And what is with the official Portage Unreal Version? It's still 226...

And what is with the s3tc-textures? Why unreal-451.ebuild doesent include it by use flag? Furthermore it would be very nice if you can make it compatible not only with unreal-tournament ebuild. why not unreal-tournament-goty as other choice?
Comment 56 James Le Cuirot gentoo-dev 2010-08-22 20:29:48 UTC
DNS is broken for for the time being. I gather you can add to your /etc/hosts file.

This ebuild goes together with the new UT ebuild from bug #134156. This handles all editions including GOTY so the GOTY would be removed.

This ebuild symlinks files from UT so if you install UT with S3TC then you'll get those textures in Unreal. Not all of the textures will have S3TC though because Unreal itself didn't have S3TC textures.

As for getting this stuff in the tree, I suspect the devs are uncomfortable about the complexity of these ebuilds. I've made a start on ripping much of this stuff out into a separate script but progress is slow as it's not one of my priorities. The good news is that the Portage tree is moving to git soon and I'm strongly considering becoming a dev myself once this happens.
Comment 57 No Name 2010-08-23 17:23:27 UTC
Hey :-)

Okay very good work! I have installed now unreal-tournament ebuild.
And direct Unreal-451 from here over it. But i will notice here that the unreal-451 ebuild has problem with cdrom names like "Unreal CD1" - i think the quotes are lost in the ebuild? Would be nice if you can fix this.

Furthermore I will notice here that the normal "unreal-tournament-451" ebuild doesen't has a S3tc USE-Flag oO? Can you add it? It's the second CD of the Goty Version, right?

Also can you tell me why the actually ebuild which here is uploaded not is available in Portage? Only Version unreal-226 which doesen't work right with unreal-tournament-451 ebuild...

In Addation it would be nice if the unreal-tournament-bonusmaps ebuild would work bzw. for Version 451 Version... Actually it is hard-masked and for Version 436. How I can use my addational Unreal-Tournament-Goty Stuff which is the difference to the normal unreal-tournament Pack without Goty.

To sum up. The Ebuild unreal-451 and unreal-tournament-451 works great togehter without errors, nice!

My requests are:

S3TC USE for unreal-tournament.
Eventually a USE like "goty" for it fot copying the extras of the Goty Version.
The unreal-451 Ebuild which is here uploaded please fixed by the new ip of and with quote support.
The unreal-451 Ebuild add to Portage.

My regards.
Comment 58 James Le Cuirot gentoo-dev 2010-08-23 18:39:22 UTC
If I understand what you mean about the quoting correctly, it is not a problem with this ebuild but eutils.eclass and would affect any ebuild requiring CD installation.

The UT ebuild in bug #134156 is not the one that is currently in the Portage tree. If you really used the Portage tree version, that's why you didn't see the S3TC flag but I'm surprised it even worked with the Unreal ebuild posted here.

As I already explained, these are not in the tree because the developers are probably reluctant. They haven't really commented either way. It may just be a lack of manpower. Hopefully I can become a dev and fix this situation.
Comment 59 No Name 2010-08-23 19:11:07 UTC

In was also this quotting problem and was fixed as you can see, or was it a other one?

And yes, all is working...

I didn't now that exist a other "better" unreal-tournament-451 ebuild also...

Is it right that I need now the unreal-451 ebuild from this bug and the unreal-tournament-451 Ebuild from the bug that you have linked me? With S3TC USE furthermore.

I have found this -> It is the ebuild from here or?

What's about putting your unreal-tournament-451 Ebuild with S3TC Support in this overlay also?

BTW: It's a little bit confusing that the user Ebuilds are in this point of better quality as the official Portages...

2 Question in addition:

Whats about the Goty extras? How I can get this? ut-bonusmaps is for Version 436 and masked also... Is existing also a Ebuild for this one which corporate to the other 2 Ebuilds (ut and unreal Version 451)?

What's about the Multiplay of unreal? I can see Server... Are they the same as unreal-tournament? because unreal running on the top of them? Or it's impossible to play over "unreal" as unreal-tournament over this servers?
Comment 60 DavidH 2010-08-23 19:30:22 UTC
I don't want to be a buzzkill here, but this conversation sounds better suited to the forums.

It also seems like we need a nice HOWTO on for installing UT and U1.
Comment 61 No Name 2010-08-23 22:13:44 UTC
A Third Question:

 * ERROR: games-fps/unreal-451 failed:
 *   cp System (det) - Maybe your CD doesn't include the de language files.
 * Call stack:
 *, line  54:  Called src_unpack
 *   environment, line 2747:  Called die
 * The specific snippet of code:
 *                   eval cp -f "${CDROM_ROOT}/${SYSTEM_DIR}"/${LOCALIZED_SYSTEM}.${lang}t System || die "cp System (${lang}t) - Maybe your CD doesn't include the ${lang} language files.";
 * If you need support, post the output of 'emerge --info =games-fps/unreal-451',
 * the complete build log and the output of 'emerge -pqv =games-fps/unreal-451'.
 * The complete build log is located at '/var/tmp/portage/games-fps/unreal-451/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/games-fps/unreal-451/temp/environment'.
 * S: '/var/tmp/portage/games-fps/unreal-451/work'

What's about the lang files? Did this mean I can have a unreal complettly in German? I have the unreal gold edition... where are this files?
Comment 62 James Le Cuirot gentoo-dev 2010-08-24 08:18:17 UTC
Like David says, you may want to move this to the forums or something. But to answer that question, you can play Unreal in German but I don't think the files were included in all editions. They were included in Anthology.
Comment 63 No Name 2010-09-26 12:30:25 UTC
Can anyone add it to sunrise overlay or so?

Tanks for!
Comment 64 Juho-Mikko Pellinen 2010-11-11 17:59:56 UTC
I just installed the newest ebuild and it emerged correctly after I installed dev-util/xdelta-1.1.4-r1 . Portage has xdelta-3.0v marked as stable so it gets installed by default, but it is not backwards compatible with 1.x-series.
Other than that, the installation went smoothly.
Comment 65 Jared B. 2011-05-29 05:33:13 UTC
Is this supposed to include the Return to Na Pali mission pack?  I would assume so since that's pretty much the main point of the Gold release, but I just tried to play it and couldn't figure out how.  The New Game option only starts the original campaign, and I can't find any extra binaries or obvious switches to the unreal binary to start the mission pack.

Am I missing something, or is this really not included?  If not, any reason why?  I'm using the unreal-451 ebuild that links against UT.

Comment 66 Jared B. 2011-05-29 06:11:58 UTC
Nevermind, I'm a dumbass.  Just found bug 162097.  If/when this gets updated again, it may be worth adding a note at the end to refer to the unreal-returntonapali ebuild, especially if the Gold version was installed.  Would save some time for the slow people like me.  :-)
Comment 67 Jared B. 2011-09-29 23:13:03 UTC
Created attachment 288295 [details]

Updated ebuild to support installing from path containing spaces and parentheses (eg., '/Unreal (Gold Edition)').  Required some funky escaped quotes in the eval statements.  Also added a suggestion about the unreal-returntonapali package, as mentioned in comment 66.
Comment 68 Jared B. 2012-09-15 04:25:43 UTC
Created attachment 323850 [details]

minor update: cdrom eclass now explicitly included, as required
Comment 69 Arfrever Frehtes Taifersar Arahesis 2019-12-09 03:43:28 UTC

commit 8b093e47371dceaf8e3daaa099a8c20cba1a6d0c
Author:     Aaron Bauman <>
AuthorDate: 2019-12-08 21:08:20 +0000
Commit:     Aaron Bauman <>
CommitDate: 2019-12-08 21:08:20 +0000

    games-fps/*: drop last-rited pkgs
    Signed-off-by: Aaron Bauman <>

commit 25ccd8cf8f654fefc66ef924b5558873e1e44dcf
Author:     Aaron Bauman <>
AuthorDate: 2019-12-08 21:28:28 +0000
Commit:     Aaron Bauman <>
CommitDate: 2019-12-08 21:28:28 +0000

    games-fps/unreal-tournament: drop vulnerable
    Signed-off-by: Aaron Bauman <>