Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 129730 - baselayout-1.12.0_pre17-r1 breaks many initlevel scripts
Summary: baselayout-1.12.0_pre17-r1 breaks many initlevel scripts
Status: RESOLVED DUPLICATE of bug 103275
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-12 12:15 UTC by Rumen Yotov
Modified: 2006-04-12 13:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rumen Yotov 2006-04-12 12:15:44 UTC
Hi,
Latest baselayout-1.12.0_pre17-r1 broke many initlevel scripts (links).
Listing follows:
...BEGIN...
1.boot-level.txt
lrwxrwxrwx 1 root root 21 2005-09-14 07:15 alsasound -> /etc/init.d/alsasound
lrwxrwxrwx 1 root root 36 2005-09-10 15:46 bootmisc -> /tmp/stage1root//etc/init.d/bootmisc
lrwxrwxrwx 1 root root 35 2005-09-10 15:46 checkfs -> /tmp/stage1root//etc/init.d/checkfs
lrwxrwxrwx 1 root root 37 2005-09-10 15:46 checkroot -> /tmp/stage1root//etc/init.d/checkroot
lrwxrwxrwx 1 root root 33 2005-09-10 15:46 clock -> /tmp/stage1root//etc/init.d/clock
lrwxrwxrwx 1 root root 39 2005-09-10 15:46 consolefont -> /tmp/stage1root//etc/init.d/consolefont
lrwxrwxrwx 1 root root 36 2005-09-10 15:46 hostname -> /tmp/stage1root//etc/init.d/hostname
lrwxrwxrwx 1 root root 35 2005-09-10 15:46 keymaps -> /tmp/stage1root//etc/init.d/keymaps
lrwxrwxrwx 1 root root 38 2005-09-10 15:46 localmount -> /tmp/stage1root//etc/init.d/localmount
lrwxrwxrwx 1 root root 35 2005-09-10 15:46 modules -> /tmp/stage1root//etc/init.d/modules
lrwxrwxrwx 1 root root 34 2005-09-10 15:46 net.lo -> /tmp/stage1root//etc/init.d/net.lo
lrwxrwxrwx 1 root root 37 2005-09-10 15:46 rmnologin -> /tmp/stage1root//etc/init.d/rmnologin
lrwxrwxrwx 1 root root 35 2005-09-10 15:46 urandom -> /tmp/stage1root//etc/init.d/urandom
2.default-level.txt:
...
lrwxrwxrwx 1 root root 33 2005-09-10 15:46 local -> /tmp/stage1root//etc/init.d/local
...
lrwxrwxrwx 1 root root 36 2005-09-10 15:46 netmount -> /tmp/stage1root//etc/init.d/netmount
...END...
Manually fixed erraneous links but it's really a problem (Bug).
Thanks.Rumen
emerge --info:
Gentoo Base System version 1.12.0_pre17
Portage 2.1_pre7-r5 (!/usr/portage/profiles/default-linux/x86/2006.0, gcc-4.0.3, glibc-2.4-r1, 2.6.16-gentoo-r1PaX i686)
=================================================================
System uname: 2.6.16-gentoo-r1PaX i686 AMD Athlon(tm) XP 2200+
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE=""
ALSA_CARDS="ens1371"
ARCH="x86"
AUTOCLEAN="yes"
BASH_ENV="/etc/spork/is/not/valid/profile.env"
CBUILD="i686-pc-linux-gnu"
CCACHE_DIR="/var/tmp/ccache"
CCACHE_SIZE="2G"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLORTERM=""
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/init.d /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/env.d"
CVS_RSH="ssh"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DCCC_PATH="/usr/lib/distcc/bin"
DISPLAY=":0.0"
DISTCC_LOG=""
DISTCC_VERBOSE="0"
DISTDIR="/var/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--verbose"
EMERGE_WARNING_DELAY="10"
FEATURES="autoconfig buildpkg ccache collision-protect confcache distlocks enotice gpg parallel-fetch sandbox sfperms userpriv usersandbox"
FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
FLTK_DOCDIR="/usr/share/doc/fltk-1.1.7/html"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://gentoo.ITDNet.net/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://mirror.datapipe.net/gentoo"
GPG_AGENT_INFO="/tmp/gpg-rPi4DY/S.gpg-agent:12195:1"
GS_LIB="/home/gentoo/.fonts"
GTK2_RC_FILES="/home/gentoo/.gtkrc-2.0"
GTK_RC_FILES="/etc/gtk/gtkrc:/home/gentoo/.gtkrc:/home/gentoo/.kde/share/config/gtkrc"
G_BROKEN_FILENAMES="1"
HOME="/root"
HUSHLOGIN="FALSE"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.16.1/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.0.3/info:/usr/share/info/emacs-21"
INPUT_DEVICES="keyboard mouse"
KDEDIRS="/usr"
KDE_FULL_SESSION="true"
KDE_MULTIHEAD="false"
KERNEL="linux"
KONSOLE_DCOP="DCOPRef(konsole-12286,konsole)"
KONSOLE_DCOP_SESSION="DCOPRef(konsole-12286,session-1)"
LADSPA_PATH="/usr/lib/ladspa"
LANG="bg_BG.UTF8"
LC_ALL="en_US.UTF8"
LC_MESSAGES="en"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LINGUAS="en bg pt"
LOGNAME="root"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.qt=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.flac=01;35:*.mp3=01;35:*.mpc=00;36:*.ogg=00;36:*.wav=00;36:*.mid=00;36:*.midi=00;36:*.au=00;36:*.flac=00;36:*.aac=00;36:"
MAKEOPTS="-j2"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.16.1/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.0.3/man:/usr/qt/3/doc/man"
MOZILLA_FIVE_HOME="/usr/lib/mozilla"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/sbin:/bin:/usr/sbin:/usr/bin"
PKGDIR="/var/portage/packages"
PORTAGE_ARCHLIST="ppc s390 amd64 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa x86"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_CALLER="emerge"
PORTAGE_ELOG_CLASSES="info warn error log"
PORTAGE_ELOG_MAILFROM="portage@qrypto.org"
PORTAGE_ELOG_MAILURI="gentoo@mach.qrypto.org localhost"
PORTAGE_ELOG_SYSTEM="save mail"
PORTAGE_GID="250"
PORTAGE_GPG_DIR="/etc/portage/gpg"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_MASTER_PID="25491"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_TMPFS="/dev/shm"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/ecatmur /usr/portage/local/layman/kolab2 /usr/portage/local/layman/webapps-experimental"
PORT_ENOTICE_DIR="/var/enotice/"
PORT_LOGDIR="/var/log/portage"
PRELINK_PATH=""
PRELINK_PATH_MASK="/usr/lib/gstreamer-0.10:/usr/lib/gstreamer-0.8:/usr/lib/klibc"
PWD="/root"
PYTHONDOCS="/usr/share/doc/python-docs-2.4.2/html"
PYTHONPATH="/usr/lib/portage/pym"
QMAILIDHOST="connectioncable-084.headoff.net"
QMAIL_CONTROLDIR="/var/qmail/control"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
RPMDIR="/usr/portage/rpm"
RUBYOPT="-rauto_gem"
SEARCH_DIRS_MASK="/usr/lib/openoffice"
SESSION_MANAGER="local/mach:/tmp/.ICE-unix/12234"
SHELL="/bin/bash"
SHLVL="6"
SSH_AGENT_PID="11815"
SSH_AUTH_SOCK="/tmp/ssh-aNcyP11814/agent.11814"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="xterm"
TMAKEPATH="/usr/lib/tmake/linux-g++"
USE="x86 3dnow X X509 a52 aac acl acpi alsa apache2 avi bash-completion berkdb bitmap-fonts caps cdb cdr cli crypt ctype cups curl dba dri dvd dvdr eds encode esd evo exif expat fastbuild ffmpeg flac foomaticdb force-cgi-redirect freetype ftp gd gif gnutls gstreamer gtk gtk2 gtkhtml hal iconv imap imlib ipv6 isdnlog ithreads javascript jpeg kdexdeltas lcms libg++ libwww mad maildir matroska memlimit mikmod mime mmx motif mp3 mpeg ncurses nls nptl nvidia ogg opengl oss pam pcre pdflib perl png posix ppds pppd prelude python quicktime readline sdl session simplexml skey soap sockets speex spell spl sse ssl svg symlink tcpd theora threads tokenizer transcode truetype truetype-fonts type1-fonts udev unicode usb vorbis win32codecs xine xml xsl xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en linguas_bg linguas_pt userland_GNU video_cards_vesa video_cards_fbdev video_cards_nv video_cards_nvidia"
USER="root"
USERLAND="GNU"
USE_EXPAND="DVB_CARDS ELIBC FCDSL_CARDS FRITZCAPI_CARDS INPUT_DEVICES KERNEL LINGUAS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN=""
USE_ORDER="env:pkg:conf:defaults"
VIDEO_CARDS="vesa fbdev nv nvidia"
WINDOWID="27262981"
XARGS="xargs -r"
XAUTHORITY="/root/.xauthTqyGew"
XCURSOR_THEME="default"
XDG_CONFIG_DIRS="/usr/kde/3.5/etc/xdg"
XDG_DATA_DIRS="/usr/kde/3.5/share:/usr/share"
_="/usr/bin/emerge"
Comment 1 SpanKY gentoo-dev 2006-04-12 13:51:22 UTC

*** This bug has been marked as a duplicate of 103275 ***