Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 127591 - x11-misc/xkeyboard-config-0.7-r2 requires XML::Parser, but it is not pulled in as a dependancy.
Summary: x11-misc/xkeyboard-config-0.7-r2 requires XML::Parser, but it is not pulled ...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 127741 129009 143783 151222 153640 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-25 20:21 UTC by stupendoussteve
Modified: 2013-12-19 15:15 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stupendoussteve 2006-03-25 20:21:42 UTC
Portage 2.1_pre7 (default-linux/x86/no-nptl, gcc-3.4.6, glibc-2.3.6-r3, 2.6.15-gentoo-r7-ladonis i686)
=================================================================
System uname: 2.6.15-gentoo-r7-ladonis i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.mirrors.tds.net/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="x86 X apm avi berkdb bitmap-fonts bzip2 cli cpudetection crypt ctype dba dri eds emboss encode expat fastbuild foomaticdb force-cgi-redirect fortran ftp gd gdbm gif gpm gstreamer gtk gtk2 hal imlib ipv6 jpeg kde libg++ libwww mad memlimit mikmod motif mp3 mpeg ncurses nls ogg oss pam pcre pdflib perl png posix python qt quicktime readline sdl session simplexml soap sockets spell spl sse sse2 ssl tcpd tokenizer truetype truetype-fonts type1-fonts vorbis xml xmms xscreensaver xsl xv zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 stupendoussteve 2006-03-25 20:29:47 UTC
Extremely odd behavior. I manually merged XML-Parser, and then removed it. Now when I run the emerge xorg-x11 process again, it pulls in XML-Parser which is was not doing before. Any clue on this situation? I thought I was reporting a valid bug but it seems to have somehow been resolved itself. It did stay even after a sync.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-03-26 00:31:54 UTC
run perl-cleaner after upgrading perl...

RDEPEND="x11-apps/xkbcomp
        !x11-misc/xkbdata"
DEPEND="${RDEPEND}
        dev-perl/XML-Parser"
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-03-27 05:39:20 UTC
*** Bug 127741 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-04-06 03:32:35 UTC
*** Bug 129009 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-08-13 07:20:18 UTC
*** Bug 143783 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-10-13 13:31:45 UTC
*** Bug 151222 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-10-31 23:00:45 UTC
*** Bug 153640 has been marked as a duplicate of this bug. ***
Comment 8 Jeroen Roovers gentoo-dev 2013-12-19 15:15:35 UTC

*** This bug has been marked as a duplicate of bug 41124 ***