Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 126945 - fluxbox-0.9.15 fails nls es_ES
Summary: fluxbox-0.9.15 fails nls es_ES
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Commonbox Team
URL:
Whiteboard:
Keywords:
Depends on: 144133
Blocks:
  Show dependency tree
 
Reported: 2006-03-20 05:28 UTC by emil karlson
Modified: 2007-03-24 17:53 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
es_ES/Translation.m (Translation.m,2.25 KB, text/plain)
2006-03-25 11:16 UTC, emil karlson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description emil karlson 2006-03-20 05:28:48 UTC
USE="nls" emerge fluxbox I get:

make[4]: Entering directory `/usr/local/tmp/portage/fluxbox-0.9.15/work/fluxbox-0.9.15/nls/da_DK'
make[4]: Leaving directory `/usr/local/tmp/portage/fluxbox-0.9.15/work/fluxbox-0.9.15/nls/da_DK'
Making all in es_ES
make[4]: Entering directory `/usr/local/tmp/portage/fluxbox-0.9.15/work/fluxbox-0.9.15/nls/es_ES'
Translation.m:5: invalid line
Translation.m:6: invalid line
Translation.m:7: invalid line
Translation.m:8: invalid line
Translation.m:9: invalid line
Translation.m:10: invalid line

the "invalid line" repeats until memory runs out.

USE="-nls" emerge fluxbox   works


Portage 2.1_pre6-r5 (default-linux/x86/2006.0, gcc-3.4.4, glibc-2.4-r1, 2.6.16-rc6-mm1 i686)
=================================================================
System uname: 2.6.16-rc6-mm1 i686 mobile AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ ftp://trumpetti.atm.tut.fi/gentoo/ http://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.du.se/pub/os/gentoo http://ftp.du.se/pub/os/gentoo http://ds.thn.htu.se/linux/gentoo http://mirror.pudas.net/gentoo ftp://mirror.pudas.net/gentoo"
LANG="en_US.utf8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/usr/local/tmp/"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/omat"
SYNC="rsync://trumpetti.atm.tut.fi/gentoo-portage"
USE="x86 3dnow 3dnowext 7zip X a52 aac acpi alsa apm asf avi bash-completion berkdb bitmap-fonts boundschecking browserplugin bzip2 bzlib c++ cdda cdr cdrom codecs corba crypt css curl dbcp dhcp directfb divx4linux dlloader dri dvd dvdread eds emboss encode escreen fbcon fbdev ffmpeg firefox flac flood foomaticdb fortran freetype gd gdb gif gimp glibc glut glx gnuplot gpm gstreamer gtk gtk2 http iconv idn ieee1394 imagemagick imlib input_devices_evdev input_devices_keyboard ipv6 java javascript jpeg jpeg2k kdeenablefinal latex lcd lcms libg++ libwww lm_sensors logrotate lua lzo matroska md5sum mime mmx mmxext mng mod motif mozsvg mp3 mpeg mpeg2 mpeg4 mplayer multitarget ncurses nls no-old-linux no-opts no-suexec nptl nptlonly nsplugin objc octave ogg opengl openssh openssl pam pango pdf pdflib perl png print python qt quicktime readline real reiser4 samba scp screen sdl sensord shout skins snmp speex sse ssl svg svga symlink sysfs tcltk tcp tetex text theora threads tiff transcode truetype truetype-fonts type1-fonts udev unicode urandom usb userlocales utf8 v4l vcd video_cards_ati vorbis win32codecs wma wma123 wxwindows xft xgetdefault xml xml2 xosd xv xvid xvmc zip zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Ciaran McCreesh 2006-03-20 08:02:32 UTC
Hrm. This is interesting, since USE=nls works here. Is anyone else having this problem?
Comment 2 Jouni Muttilainen 2006-03-20 13:20:56 UTC
reproduced with following config and compiles fine with USE="-nls"


Portage 2.1_pre6-r4 (default-linux/x86/2006.0, gcc-4.0.3-20060209, glibc-2.4-r1, 2.6.15-no4 i686)
=================================================================
System uname: 2.6.15-no4 i686 AMD Athlon(tm)
Gentoo Base System version 1.12.0_pre16
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.91.0.6
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe -ftracer -fweb -frename-registers"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe -ftracer -fweb -frename-registers -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ ftp://trumpetti.atm.tut.fi/gentoo/ http://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.du.se/pub/os/gentoo http://ftp.du.se/pub/os/gentoo http://ds.thn.htu.se/linux/gentoo http://mirror.pudas.net/gentoo ftp://mirror.pudas.net/gentoo"
LANG="fi_FI.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--enable-new-dtags -Wl,-Bdirect -Wl,-hashvals -Wl,-zdynsort"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlays/conrad"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X a52 aac aalib alsa apm audiofile avi bash-completion bitmap-fonts bzip2 cdparanoia cdr cli crypt css ctype cups dba dri dvd dvdr dvdread eds emboss encode expat fastbuild ffmpeg flac foomaticdb force-cgi-redirect ftp gd gdbm gif glibc-omitfp glut gpm gtk2 imagemagick imlib ipv6 jpeg jpeg2k kde libcaca libg++ libwww logitech-mouse mad memlimit mikmod mmx mmxext motif mp3 mpeg mplayer musepack musicbrainz ncurses nls nptl nptlonly nvidia ogg opengl oss pam pcre pdf pdflib perl png posix python qt quicktime readline sdl session simplexml soap sockets spell spl sql sse sse2 ssl subversion svg tcpd tiff tokenizer truetype truetype-fonts type1-fonts udev unicode vcd vorbis win32codecs xml xsl xv xvid zlib elibc_glibc input_devices_evdev input_devices_keyboard kernel_linux userland_GNU video_cards_nvidia"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, LINGUAS, MAKEOPTS
Comment 3 Mathias Gumz 2006-03-25 05:53:36 UTC
please attach the Translation.m file. And / Or call "gencat fluxbox.cat Translation.m" yourself and report back the output.

i find it a bit strange that it works on the other catalogfiles but not on es_ES.
Comment 4 emil karlson 2006-03-25 11:16:22 UTC
Created attachment 83099 [details]
es_ES/Translation.m

The gencat just fails just like the emerge, control group da_DK worked fine.
Comment 5 emil karlson 2006-03-25 11:42:29 UTC
Mind you that 

>=sys-libs/glibc-2.4 (/usr/bin/gencat)

on all effected systems

works fine on older glibc.
Comment 6 Ciaran McCreesh 2006-03-25 12:18:16 UTC
Ok. Could you please check whether any other files are affected? You can do this with MAKEOPTS="-k" and careful reading. AFAICS the file's fine, but if there're others failing it might be easier to spot a pattern.

I'd also be interested to hear whether anyone with glibc 2.3 is affected, or whether anyone with 2.4 (and USE=nls) isn't.

('Fraid I won't be around much until mid next week either -- I'm not ignoring you, I'm just going to be in the middle of nowhere.)
Comment 7 emil karlson 2006-03-26 13:51:45 UTC
"make -k" doesn't really help since make crashes, when memory runs dry.

The bug was reproduced on glibc-2.3.5-r2 failed on es_ES exactly like the original bug.

Did remove some locales from nls/Makefile.am && automake && autoconf && ./configure --enable-nls, but didn't get any wiser, make clean all just fails on all the locales tested beyond es_ES up to ru_RU.

also gencat fails in similar fashion.
Comment 8 Sami Näätänen 2006-04-08 17:34:34 UTC
All right I looked this a litle bit and found out that it has something to do about the codesets used in the translations. And thus maybe the used glibc.

For example the lv_LV uses codeset 'ISO-8859-13' and the infamous es_ES uses codeset of 'ISO-8859-15'.
--------------------------------------------------
`head -n 1 */Translation.m` inside the nls dir

==> be_BY/Translation.m <==
$ codeset=CP1251

==> bg_BG/Translation.m <==
$ codeset=ISO-8859-1

==> cs_CZ/Translation.m <==
$ codeset=ISO-8859-2

==> C/Translation.m <==
$ codeset=ISO-8859-1

==> da_DK/Translation.m <==
$ codeset=ISO-8859-1

==> de_DE/Translation.m <==
$ codeset=ISO-8859-15

==> el_GR/Translation.m <==
$ codeset=utf8

==> es_ES/Translation.m <==
$ codeset=ISO-8859-1

==> et_EE/Translation.m <==
$ codeset=ISO-8859-1

==> fr_FR/Translation.m <==
$ codeset=ISO-8859-15

==> it_IT/Translation.m <==
$ codeset=ISO-8859-1

==> ja_JP/Translation.m <==
$ codeset=eucJP

==> ko_KR/Translation.m <==
$ codeset=UTF-8

==> lv_LV/Translation.m <==
$ codeset=ISO-8859-13

==> nb_NO/Translation.m <==
$ codeset=UTF-8

==> nl_NL/Translation.m <==
$ codeset=ISO-8859-15

==> no_NO/Translation.m <==
$ codeset=ISO-8859-1

==> pl_PL/Translation.m <==
$ codeset=ISO-8859-2

==> pt_BR/Translation.m <==
$ codeset=ISO-8859-1

==> pt_PT/Translation.m <==
$ codeset=ISO-8859-1

==> ru_RU/Translation.m <==
$ codeset=KOI8-R

==> sl_SI/Translation.m <==
$ codeset=ISO-8859-2

==> sv_SE/Translation.m <==
$ codeset=ISO-8859-1

==> tr_TR/Translation.m <==
$ codeset=ISO-8859-1

==> uk_UA/Translation.m <==
$ codeset=KOI8-U

==> vi_VN/Translation.m <==
$ codeset=UTF-8

==> zh_CN/Translation.m <==
$ codeset=ISO-8859-1
--------------------------------------------------


Using these codesets will work: utf8, eucJP, ISO-8859-1 and ISO-8859-2
And using these don't: KOI8-U, KOI8-R, ISO-8859-15, ISO-8859-13 and CP1251

--------------------------------------------------
my emerge --info
--------------------------------------------------
Portage 2.1_pre7-r4 (default-linux/x86/2005.0, gcc-3.4.6, glibc-2.4-r1, 2.6.16.1 i686)
=================================================================
System uname: 2.6.16.1 i686 Intel(R) Pentium(R) 4 CPU 2.53GHz
Gentoo Base System version 1.12.0_pre17
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/init.d /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_GB.utf8"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/.portagelocal"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac acpi alsa apache2 avi bash-completion berkdb bitmap-fonts bzip2 cdparanoia cdr cgi crypt css ctype cups curl curlwrappers dedicated directfb doc dri dts dv dvb dvd dvdr dvdread edl eds encode examples ffmpeg fftw flac foomaticdb ftp gcj gdbm gif gimp gimpprint gphoto2 gpm gstreamer gtk gtk2 icq imagemagick imap imlib ipv6 isdnlog jack jack-tmpfs java javascript jce joystick jpeg kde key-screen libg++ libwww live lm_sensors logitech-mouse mad maildir maya-shaderlibrary mikmod mime mmap mmx mmxext motif mouse mozdevelop mozsvg mp3 mpeg mpi mplayer msn multi-tty mysql mythtv ncurses nls nocd nptl nptlonly nsplugin nvidia ogg oggvorbis ogre opengl oss pam pdflib perl physfs png posix postgres pppd python readline real rtc sdl search-screen sharedmem skey sockets spell sql sse sse2 ssl subtitles subversion sysfs tcpd tga theora threads truetype truetype-fonts type1 type1-fonts unicode userlocales utf8 v4l v4l2 vcd vhosts videos vorbis win32codecs xml2 xpm xprint xv xvid xvmc zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nvidia video_cards_v4l"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS


Comment 9 Sami Näätänen 2006-04-08 17:42:37 UTC
And to really nail it down the same happens if I try to remerge fluxbox-0.9.14-r1.
So something wrong with the gencat (glibc-2.4)
Comment 10 Perttu Luukko 2006-06-22 04:59:36 UTC
I can reproduce this with fluxbox 0.9.14 thru 1.0_rc1, and if memory serves I've had the same problem even with older versions -- I've been building fluxbox with -nls in package.use for a while now. Btw, this is probably unrelated, but everyone experiencing this bug so far seems to be Finnish :)


Portage 2.1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r9 i686)
=================================================================
System uname: 2.6.16-gentoo-r9 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/X11/xkb /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
DISTDIR="/mnt/1/portage/distfiles"
FEATURES="autoconfig ccache collision-protect confcache distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict suidctl"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ http://www.ibiblio.org/gentoo"
LANG="en_GB.UTF-8"
LINGUAS="en fi"
MAKEOPTS="-j2"
PKGDIR="/mnt/1/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=180 --exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://trumpetti.atm.tut.fi/gentoo-portage"
USE="x86 16bit 3dnow 3dnowext 7zip X a52 aac aalib abook alsa anthy ao aotuv apm asf asm avi bash-completion berkdb bitmap-fonts browserplugin bzip2 cairo cap caps ccache cdda cddb cdio cdparanoia cdrom cjk clamav cli clock-screen cracklib crypt crypto_openssl css cups curl curlwrappers dbus devmap dhcp directfb dri dts dvd dvdr dvdread dvi emboss encode enscript exif fam fbcon fbsplash ffmpeg firefox flac foomaticdb fortran ftp fuse gdbm gif gimp gimpprint glep gmp gnuplot gnutls gpgme gpm gs gsl gstreamer gtk gtk2 gvim gzip hal http icecast iconv ieee1394 image imagemagick imap imlib imlib2 immqt-bc iproute2 ipv6 irc irssi isdnlog jabber javascript john joystick jpeg jpeg2k kdeenablefinal key-screen latex libclamav libg++ libwww lj logitech-mouse lzo lzw mad maildir mailwrapper matroska mbox mccp md5sum mikmod mime mmap mmx mmxext mng motif mouse mozdevelop moznocompose moznoirc moznomail mozsvg mp3 mpeg mpeg2 mplayer mppe-mppc musepack ncurses net nethack nforce2 nls nntp nodrm nowin nptl nsplugin ntfs ntlm nvidia ogg opengl openssl pam pam_console pcre pdf pdflib perl physfs pic png posix povray ppds pppd print procmail python pyx qt quicktime rar readline reflection reiserfs rss rtc scenarios scp sdl search-screen session sftp sftplogging silc slang smime sndfile sockets socks5 sox speex spell spl srv sse ssl subject-rewrite subp subtitles subversion svg svgz sysfs t1lib tcpd tetex theora threads tidy tiff timidity truetype truetype-fonts type1-fonts udev unicode usb userlocales v4l v4l2 vcd vcdimager vim vim-pager vim-with-x vorbis win32codecs wmf wxwindows x264 xcomposite xft xlockrc xml xml2 xorg xosd xpm xv xvid zip zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux linguas_en linguas_fi userland_GNU video_cards_nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS
Comment 11 Daniel E. Bruce 2006-06-26 07:37:03 UTC
I have this exact same problem when trying to emerge fluxbox-1.0_rc1, but it doesn't repeat until memory runs out for me.
Trying with MAKEOPTS="-k" makes it fail on the following four languages: es_ES, et_EE, fr_FR and de_DE.

Portage 2.1.1_pre1-r2 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r7 i686)
=================================================================
System uname: 2.6.16-gentoo-r7 i686 AMD Athlon(TM) XP 1800+
Gentoo Base System version 1.6.15
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5, 2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -mmmx -msse -m3dnow -mfpmath=sse -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf"
CXXFLAGS="-march=athlon-xp -O2 -mmmx -msse -m3dnow -mfpmath=sse -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig candy ccache distlocks metadata-transfer sandbox sfperms strict usersandbox"
GENTOO_MIRRORS="http://mirror.gentoo.no/ ftp://ftp.du.se/pub/os/gentoo http://ftp.du.se/pub/os/gentoo http://ds.thn.htu.se/linux/gentoo http://mirror.pudas.net/gentoo ftp://mirror.pudas.net/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/cubic/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac aim alsa apm artworkextra avi berkdb bitmap-fonts bzip2 cdr cli crypt cups dga dri eds emboss encode esd foomaticdb fortran gdbm gif gpm gtk gtk2 hal imlib ipv6 isdnlog java jpeg libg++ libwww lm_sensors mad matroska mikmod mmx mmxext mng mp3 mpeg msn ncurses nls nptl nvidia ogg oggvorbis opengl oscar oss pam pcre pdflib perl php png pppd python quicktime readline reflection sdl session spell spl sse ssl tcltk tcpd truetype truetype-fonts type1-fonts udev unicode uselocale vim-with-x vorbis win32codecs x86 xml xml2 xmms xorg xv xvim zlib elibc_glibc kernel_linux userland_GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 12 Perttu Luukko 2006-07-22 03:30:27 UTC
The changelog for the recently released fluxbox-1.0_rc2 says:

 * Fix nls (Simon)
  - file location was wrong. nls wouldn't have worked, why did no-one say?

Perhaps this takes care of it then? We'll see. There's already a bump request at Bug 139711.
Comment 13 Mathias Gumz 2006-07-22 06:17:14 UTC
no, that bug had nothing to do with the gencat problem. gencat problem is inside glibc, the bug simon fixed was a file-to-use-from-fluxbox-at-runtime-is-named-differently.
Comment 14 Perttu Luukko 2006-08-01 01:08:38 UTC
True -- fluxbox-1.0_rc2 fails to build with USE="nls" just the same.
And just when I started to get my hopes up...
Comment 15 Sami Näätänen 2006-08-16 04:30:31 UTC
Now I think I found out something. Accidentally of course. :)

I earlier reported the codesets that were used in those failing translation files. Now I found out that those used codesets which my kernel did not have compiled in or as modules. Now I try to add those and see what happens.
Comment 16 Sami Näätänen 2006-08-16 10:06:24 UTC
(In reply to comment #15)
> Now I think I found out something. Accidentally of course. :)
> 
> I earlier reported the codesets that were used in those failing translation
> files. Now I found out that those used codesets which my kernel did not have
> compiled in or as modules. Now I try to add those and see what happens.
> 

And I was totally wrong. It of course had nothing to do with that.

But I diged a litle bit more and I found out that iconv dies on this kind of situation.

--file--
$ codeset=ISO-8859-15

something
--end-of-file--

iconv -f ISO-8859-15 -t ISO-8859-15 file

So iconv doens't work if the destionation and source codesets are the same FOR CERTAIN CODESETS, which is the important part here.

So in my opinion this is not fluxbox's or gencat's fault, but iconv's fault.

I have now tested these codesets:

work:
utf-8 eucJP ISO-8859-1

doesn't work:
ISO-8859-13 ISO-8859-15 CP1250 CP1251 KOI8-U

one can use the example --file-- for testing.
Simply converting to UTF-8 works always regardless of the from codeset.
Well all of the codesets should after all support those low char values in the --file--.

If converting to the from codeset it will barf with next line.
iconv: illegal input sequence at position 0
Comment 17 Sami Näätänen 2006-08-16 10:34:58 UTC
I made bug https://bugs.gentoo.org/show_bug.cgi?id=144133 against the iconv of glibc-2.4-r3

Comment 18 Sami Näätänen 2006-08-19 06:04:34 UTC
Sorry I was wrong gencat is the reason, because I didn't realize that the generated-*.m files are already in place in the archive.

Never the less iconv is still broken.
Comment 19 Jim Ramsay (lack) (RETIRED) gentoo-dev 2007-03-23 19:11:58 UTC
I am unable to replicate this with glibc-2.5 and fluxbox-1.0rc3

Can someone please re-test this and see if the problem has just gone away?
Comment 20 emil karlson 2007-03-23 22:57:31 UTC
(In reply to comment #19)
> I am unable to replicate this with glibc-2.5 and fluxbox-1.0rc3
> 
> Can someone please re-test this and see if the problem has just gone away?
> 

Seems to work for me as well.
Comment 21 Jim Ramsay (lack) (RETIRED) gentoo-dev 2007-03-24 17:53:27 UTC
I am closing this, assuming that either fluxbox-1.0_rc3 or glibc-2.5 fixes this issue.

If this is not the case, please reopen.