Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 126424 - llvm2-2.01.09 will not compile on PPC (G3 in any case)
Summary: llvm2-2.01.09 will not compile on PPC (G3 in any case)
Status: RESOLVED DUPLICATE of bug 120511
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-16 07:12 UTC by Mike Hammill
Modified: 2006-03-16 08:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Hammill 2006-03-16 07:12:36 UTC
Have used lvm2 successfully on a Apple G4.  Would now like to use on a G3.  Using LiveCD 2005.1-r1 in a chroot environment after installing via standard stage3.  Do: emerge lvm2 and it bombs on a linker error in:
/var/tmp/portage/lvm2-2.01.09/work/LVM2.2.01.09/tools

Here is the important part:
(chroot) livecd tools # cd /var/tmp/portage/lvm2-2.01.09/work/LVM2.2.01.09/tools
(chroot) livecd tools # make
powerpc-unknown-linux-gnu-gcc -o lvm.static archiver.o dumpconfig.o formats.o lvchange.o lvcreate.o lvdisplay.o lvextend.o lvmchange.o lvmcmdline.o lvmdiskscan.o lvreduce.o lvremove.o lvrename.o lvresize.o lvscan.o polldaemon.o pvchange.o pvcreate.o pvdisplay.o pvmove.o pvremove.o pvscan.o reporter.o segtypes.o toollib.o vgcfgbackup.o vgcfgrestore.o vgchange.o vgck.o vgcreate.o vgconvert.o vgdisplay.o vgexport.o vgextend.o vgimport.o vgmerge.o vgmknodes.o vgreduce.o vgremove.o vgrename.o vgscan.o vgsplit.o lvm-static.o -static -Wl,--export-dynamic -L../lib -L/usr/lib -llvm -ldevmapper \
        -lreadline -ldl -lncurses  -rdynamic
/usr/lib/libdevmapper.a(pool.o): In function `_align_chunk':
pool.c:(.text+0x134): multiple definition of `_align_chunk'
../lib/liblvm.a(pool.o):pool.c:(.text+0x128): first defined here
/usr/lib/libdevmapper.a(pool.o): In function `_new_chunk':
pool.c:(.text+0x158): multiple definition of `_new_chunk'
../lib/liblvm.a(pool.o):pool.c:(.text+0x14c): first defined here
/usr/lib/gcc/powerpc-unknown-linux-gnu/3.4.4/../../../../powerpc-unknown-linux-gnu/bin/ld: Warning: size of symbol `_new_chunk' changed from 212 in ../lib/liblvm.a(pool.o) to 224 in /usr/lib/libdevmapper.a(pool.o)
../lib/liblvm.a(sharedlib.o): In function `load_shared_library':
sharedlib.c:(.text+0xdc): warning: Using 'dlopen' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/libreadline.a(complete.o): In function `rl_username_completion_function':
complete.c:(.text+0x2710): warning: Using 'getpwent' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/libreadline.a(tilde.o): In function `tilde_expand_word':
tilde.c:(.text+0x27c): warning: Using 'getpwnam' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/libreadline.a(shell.o): In function `sh_get_home_dir':
shell.c:(.text+0x160): warning: Using 'getpwuid' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/libreadline.a(complete.o): In function `rl_username_completion_function':
complete.c:(.text+0x2700): warning: Using 'setpwent' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
complete.c:(.text+0x27ec): warning: Using 'endpwent' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
collect2: ld returned 1 exit status
make: *** [lvm.static] Error 1

Other possibly useful info:
(chroot) livecd tools # emerge --info
Portage 2.0.54 (default-linux/ppc/ppc32/2006.0/G3, gcc-3.4.4, glibc-2.3.5-r3, 2.6.12-gentoo-r6-ppc32 ppc)
=================================================================
System uname: 2.6.12-gentoo-r6-ppc32 ppc 740/750
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=G3 -mtune=G3 -fno-strict-aliasing -pipe -fomit-frame-pointer"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=G3 -mtune=G3 -fno-strict-aliasing -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.rhnet.is/pub/gentoo/ http://mirror.gentoo.no/ http://ftp.du.se/pub/os/gentoo http://ds.thn.htu.se/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="ppc X alsa apache2 apm arts berkdb bitmap-fonts bonobo bzip2 cdr cli crypt ctype cups dba dri dvd eds emboss encode esd expat fastbuild foomaticdb force-cgi-redirect fortran ftp gd gdbm gif gnome gpm gstreamer gtk gtk2 gtkhtml imlib ipv6 jpeg kde ldap libg++ libwww mad memlimit mikmod motif mozilla mp3 mpeg ncurses nls nptl ogg opengl pam pcre pdflib perl png posix python qt quicktime readline ruby sdl session simplexml soap sockets spell spl ssl tcpd tokenizer truetype truetype-fonts type1-fonts udev unicode vorbis xml xmms xsl xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS

I was able to build evms, however.  I _guess_ as a work around I could try to use the LVM-created volumes I have under evms, but I don't know exactly how.  Any tips would be appreciated.  On the other hand, a fix for LVM2 would be great.  I tried USE="static" emerge lvm2, but that made no difference.  I have not tried upgrading to the latest gcc; seems like a long shot that that is the problem.

/Mike
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-03-16 08:14:18 UTC

*** This bug has been marked as a duplicate of 120511 ***