Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 125824 - OpenOffice.org 2.0.2 fails to compile with JDK 1.5
Summary: OpenOffice.org 2.0.2 fails to compile with JDK 1.5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords: REGRESSION
: 125858 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-11 05:48 UTC by Benjamin Gaillard
Modified: 2006-03-22 12:21 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xt-20051206.diff (xt-20051206.diff,1.87 KB, patch)
2006-03-11 12:30 UTC, Alon Bar-Lev
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Gaillard 2006-03-11 05:48:36 UTC
I got the following errors when trying to emerge app-office/openoffice-2.0.2 (final version):

------------------------------------------------------------------------------

compile:
compiling and jarring
Created dir: /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/stage/xt
Compiling 380 source files to /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/stage/xt
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/expr/PatternList.java:129: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
                for (Enumeration enum =
                                 ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/expr/PatternList.java:130: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
                         nameRules.elements();  enum.hasMoreElements(); ) {
                                                ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/expr/PatternList.java:131: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
                    append((Vector)enum.nextElement(), ppb, obj);
                                   ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/tr/AppendAction.java:19: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
        for (Enumeration enum = sequence.elements();
                         ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/tr/AppendAction.java:20: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
             enum.hasMoreElements();)
             ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/tr/AppendAction.java:21: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
            ((Action)enum.nextElement()).invoke(context, sourceNode, result);
                     ^
6 errors

BUILD FAILED
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/build.xml:305: Compile failed; see the compiler error output for details.

Total time: 1 second
dmake:  Error code 1, while making 'ANTBUILD'
'---* tg_merge.mk *---'
dmake:  Error code 255, while making './unxlngi6.pro/misc/build/so_built_xt'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt
make: *** [stamp/build] Erreur 1

!!! ERROR: app-office/openoffice-2.0.2 failed.
Call stack:
  ebuild.sh, line 1933:   Called dyn_compile
  ebuild.sh, line 971:   Called src_compile

!!! Build failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

------------------------------------------------------------------------------

OpenOffice.org is supposed to build with JDK 1.5 since version 2.0.1...
This bug apparently appeared with OpenOffice.org 2.0.2rc3 and was corrected in rc4; that is what I've seen searching for an existing bug report, but I haven't tested and I'm not sure at all.

I have dev-java/sun-jdk-1.5.0.06-r2 installed and I use the following USE flags to emerge app-office/openoffice-2.0.2:
cairo firefox gtk java kde mozilla xml2 -binfilter -curl -eds -gnome -ldap

Note that the problems shows up on two different machines (Athlon and P4), so I don't think my "emerge --info" is relevant here. Please ask me if this is necessary.
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2006-03-11 06:49:21 UTC
That's why jdk 1.5 is still masked.
Comment 2 Benjamin Gaillard 2006-03-11 07:40:12 UTC
But there wasn't any problem with OpenOffice.org 2.0.1 and (apparently) 2.0.2-rc4.
I my opinion, this bug should be assigned to the OpenOffice.org team, not to the Java team since this problem is entirely related to OpenOffice.org and has nothing to do with Java itself...
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-03-11 12:22:03 UTC
*** Bug 125858 has been marked as a duplicate of this bug. ***
Comment 4 Alon Bar-Lev gentoo-dev 2006-03-11 12:30:19 UTC
Created attachment 81939 [details, diff]
xt-20051206.diff

The problem is with:
http://go-oo.org/packages/xt/xt-20051206-src-only.zip

This file has enum issue with jdk 1.5.

I could not find how to patch it... It seems that it is not unpacked... But do
compiled...

A simple solution is to put a patched version on a gentoo mirror... but maybe you know how to patch it before compilation.
Comment 5 Alon Bar-Lev gentoo-dev 2006-03-11 23:25:58 UTC
OK...
Workaround, worked for me.

1. Downloda http://go-oo.org/packages/xt/xt-20051206-src-only.zip
2. Extract, patch it using the attached patch.
3. Zip the result, put it in distfiles.
4. Redigest openoffice-2.0.2 ebuild.

Please reassign to openoffice developer... Maybe he can fix the ebuild... I just don't know what is extracting this zip file.
Comment 6 Hanno Zysik (geki) 2006-03-14 01:51:08 UTC
JFYI, fixed on ooo-build HEAD
patches/src680/use-system-xt.diff should be updated
Comment 7 Andreas Proschofsky (RETIRED) gentoo-dev 2006-03-15 05:09:37 UTC
This should be fixed now, thanks hanno for the pointer
Comment 8 Sheldon Hearn 2006-03-15 20:42:37 UTC
Andreas, you said "should be fixed".  Did you test the fix right the way through a USE=java build with jdk 1.5?

I still get the release 1.5 errors about enum being a reserved keyword.

When the build fails, the md5sum of /var/tmp/portage/.../patches/src680/use-system-xt.diff is different from the md5sum of /usr/portage/.../files/2.0.2/use-system-xt.diff.

So I don't think the ebuild has the intended impact of copying the patch from ${FILESDIR}/${PV} into ${S}/patches/src680.

I'll have to grab a transcript of my next build.  Please reopen the bug and leave it open until the fix has been tested.
Comment 9 Benjamin Gaillard 2006-03-16 02:22:17 UTC
It's now working for me: the problem has gone away after an emerge --sync. Thanks!
Comment 10 Paul de Vrieze (RETIRED) gentoo-dev 2006-03-16 10:46:28 UTC
I can confirm it worked. I did my own build with 1.5 and it built.
Comment 11 François Bissey 2006-03-16 16:26:18 UTC
Is this fix specific to the sun-jdk? I tried to compile OOo-2.0.2 with
the IBM-jdk-1.5.0 (on a ppc machine, so not sun-jdk available) and it did fails
with the following mesage:

Making: ../../unxlngppc.pro/slo/com_sun_star_comp_beans_LocalOfficeWindow.obj
gcc -fsigned-char -fmessage-length=0 -c -I.  -I. -I../inc -I../../inc -I../../unx/inc -I../../unxlngppc.pro/inc -I. -I/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/solver/680/unxlngppc.pro/inc/dont_use_stl -I/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/solver/680/unxlngppc.pro/inc/external -I/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/solver/680/unxlngppc.pro/inc -I/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/solenv/unxlngppc/inc -I/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/solenv/inc -I/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/res -I/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/solver/680/unxlngppc.pro/inc/dont_use_stl -I/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/solenv/inc/Xp31 -I/opt/ibm-jdk-bin-1.5.0/include -I/opt/ibm-jdk-bin-1.5.0/include/linux -I/opt/ibm-jdk-bin-1.5.0/include/native_threads/include -I/usr/include     -I. -I../../res -I. -O2 -fno-strict-aliasing   -fsigned-char -pipe -O2 -mcpu=7450 -pipe -maltivec -mabi=altivec -mpowerpc-gfxopt -fsigned-char -frename-registers -fweb -fno-strict-aliasing -fno-strict-aliasing -fPIC -DLINUX -DUNX -DVCL -DGCC -DC300 -DPOWERPC -DCVER=C300 -D_USE_NAMESPACE -DNPTL -DGLIBC=2 -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400 -DPOWERPC -DPPC -DHAVE_GCC_VISIBILITY_FEATURE -D__DMAKE -DUNIX -DCPPU_ENV=gcc3 -DGXX_INCLUDE_PATH=/usr/lib/gcc/powerpc-unknown-linux-gnu/3.4.5/include/g++-v3 -DSUPD=680 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DEXCEPTIONS_ON -DCUI -DSOLAR_JAVA -DOOB680=OOB680   -DSHAREDLIB -D_DLL_  -DMULTITHREAD  -o ../../unxlngppc.pro/slo/com_sun_star_comp_beans_LocalOfficeWindow.o com_sun_star_comp_beans_LocalOfficeWindow.c
In file included from com_sun_star_comp_beans_LocalOfficeWindow.c:45:
/opt/ibm-jdk-bin-1.5.0/include/jawt.h:302: error: syntax error before "jboolean"
dmake:  Error code 1, while making '../../unxlngppc.pro/slo/com_sun_star_comp_beans_LocalOfficeWindow.obj'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/bean/native/unix
make: *** [stamp/build] Error 1
Comment 12 Josh Nichols (RETIRED) gentoo-dev 2006-03-16 20:59:12 UTC
(In reply to comment #11)
> Is this fix specific to the sun-jdk? I tried to compile OOo-2.0.2 with
> the IBM-jdk-1.5.0 (on a ppc machine, so not sun-jdk available) and it did fails
> with the following mesage:
> 
SNIP
That's a different issue. See bug #126105
Comment 13 Sheldon Hearn 2006-03-22 12:21:38 UTC
As promised, here's my build failure:

cd ./unxlngi6.pro/misc/build/xt-20051206/ && dmake    && touch so_built_xt
-------------
/usr/bin/ant -Dprj=../../../.. -Dprjname=xt -Ddebug=off -Doptimize=on  -Dtarget=
compile -Dsolar.update=on -Dout=../../../../unxlngi6.pro -Dinpath=unxlngi6.pro -
Dproext=".pro"  -Dsolar.bin=/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0
.2/build/OOO_2_0_2/solver/680/unxlngi6.pro/bin -Dsolar.jar=/var/tmp/portage/open
office-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/solver/680/unxlngi6.pro/bin -D
solar.doc=/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2
/solver/680/unxlngi6.pro/doc  -Dcommon.jar=/var/tmp/portage/openoffice-2.0.2/wor
k/ooo-build-2.0.2/build/OOO_2_0_2/solver/680/unxlngi6.pro/bin -Dcommon.doc=  -f
build.xml  -emacs
Buildfile: build.xml

_check:

init:
Created dir: /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_
0_2/xt/unxlngi6.pro/misc/build/xt-20051206/lib
top: /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/u
nxlngi6.pro/misc/build/xt-20051206
dist: /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/
unxlngi6.pro/misc/build/xt-20051206/dist
javadocUptodate: ${javadocUptodate}
unzip.done: ${unzip.done}

compile:
compiling and jarring
Created dir: /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_
0_2/xt/unxlngi6.pro/misc/build/xt-20051206/stage/xt
Compiling 380 source files to /var/tmp/portage/openoffice-2.0.2/work/ooo-build-2
.0.2/build/OOO_2_0_2/xt/unxlngi6.pro/misc/build/xt-20051206/stage/xt
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlng
i6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/expr/PatternList.java:1
29: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
                for (Enumeration enum =
                                 ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlng
i6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/expr/PatternList.java:1
30: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
                         nameRules.elements();  enum.hasMoreElements(); ) {
                                                ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlng
i6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/expr/PatternList.java:1
31: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
                    append((Vector)enum.nextElement(), ppb, obj);
                                   ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlng
i6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/tr/AppendAction.java:19
: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
        for (Enumeration enum = sequence.elements();
                         ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlng
i6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/tr/AppendAction.java:20
: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
             enum.hasMoreElements();)
             ^
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlng
i6.pro/misc/build/xt-20051206/src/xt/java/com/jclark/xsl/tr/AppendAction.java:21
: as of release 1.5, 'enum' is a keyword, and may not be used as an identifier
(try -source 1.4 or lower to use 'enum' as an identifier)
            ((Action)enum.nextElement()).invoke(context, sourceNode, result);
                     ^
6 errors

BUILD FAILED
/var/tmp/portage/openoffice-2.0.2/work/ooo-build-2.0.2/build/OOO_2_0_2/xt/unxlng
i6.pro/misc/build/xt-20051206/build.xml:305: Compile failed; see the compiler er
ror output for details.

Total time: 1 second
dmake:  Error code 1, while making 'ANTBUILD'
'---* tg_merge.mk *---'
dmake:  Error code 255, while making './unxlngi6.pro/misc/build/so_built_xt'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making /var/tmp/portage/openoffice-2.0.2/work/
ooo-build-2.0.2/build/OOO_2_0_2/xt
make: *** [stamp/build] Error 1

!!! ERROR: app-office/openoffice-2.0.2 failed.
!!! Function src_compile, Line 222, Exitcode 2
!!! Build failed
!!! If you need support, post the topmost build error, NOT this status message.

And here's my emerge --info:

Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.5-r2, 2.6.15-suspend2-r8 i686)
=================================================================
System uname: 2.6.15-suspend2-r8 i686 Intel(R) Pentium(R) M processor 2.13GHz
Gentoo Base System version 1.12.0_pre16
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium4m -mtune=pentium4m -mfpmath=sse -ffast-math -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4m -mtune=pentium4m -mfpmath=sse -ffast-math -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="en_ZA en_GB en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/axl"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aac acpi alsa apm arts audiofile avi berkdb bitmap-fonts bzip2 cddb cdr crypt cups curl dbus dlloader dri dv dvd dvdr emboss encode ethereal exif expat fam ffmpeg flac foomaticdb fortran gd gdbm gif glut gmp gpm gstreamer gtk gtk2 hal idn imagemagick imlib ipv6 java jpeg kde kdeenablefinal lcms ldap libg++ libwww mad mhash mikmod mmx mng motif mp3 mpeg mysql ncurses nls nptl nsplugin ogg oggvorbis opengl oss pam pcre pdflib perl pic png postgres python qt quicktime readline ruby samba sdl speex spell sqlite sse sse2 ssl tcltk tcpd threads tiff truetype truetype-fonts type1-fonts udev usb userlocales vorbis wifi win32codecs xcomposite xine xml xml2 xmms xv xvid zlib linguas_en_ZA linguas_en_GB linguas_en_US userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS