Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 125531 - xterm wants to install on an X-less box
Summary: xterm wants to install on an X-less box
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Other
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-03-08 14:09 UTC by Rob Hudson
Modified: 2006-03-08 15:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rob Hudson 2006-03-08 14:09:51 UTC
I run a webserver and do not want to install X.  Not long ago, I was doing my normal maintenance updates and xterm shows up on the list of packages to be installed.  I ran "emerge -uDvp --tree world" and see that there are no dependencies that are requiring xterm.

Also, I did the following:

# equery depends x11-term/xterm
[ Searching for packages depending on x11-term/xterm... ]

# grep x11 /var/lib/portage/world

# esearch -c -F -nc x11 | grep '^..I'

This tells me:
- I don't have anything that depends on xterm.
- I don't have anything in my world file related to x11.
- I don't have anything currently installed related to x11.

But xterm is still trying to get installed.  Is this a Gentoo bug?
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-03-08 14:56:05 UTC
So package.mask it and find out what depends on it. We can't guess. 
Comment 2 Rob Hudson 2006-03-08 15:18:10 UTC
I didn't think of package.mask.  I thought one of the other methods would show if xterm was a dependency of something...

netpbm (which I installed for Gallery) is requiring it.  If I unmerge netpbm xterm (and Xorg) go away when I do "emerge -uDvp world".

Should netpbm not require X libs?
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-03-08 15:21:18 UTC
(In reply to comment #2)
> Should netpbm not require X libs?

It doesn't. We really need to know your use flags, reopen with emerge -pv netpbm output and emerge --info.

Comment 4 Rob Hudson 2006-03-08 15:30:14 UTC
(In reply to comment #3)
> reopen with emerge -pv netpbm output and emerge --info.

# emerge -vp netpbm

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] media-libs/giflib-4.1.4  -X -rle 591 kB 
[ebuild  N    ] media-libs/urt-3.1b-r1  -X +gif -gs -tiff 992 kB 
[ebuild  N    ] media-libs/jbigkit-1.6-r1  396 kB 
[ebuild  N    ] x11-base/opengl-update-2.2.1  38 kB 
[ebuild  N    ] media-libs/freetype-2.1.9-r1  -bindist -doc +zlib 969 kB 
[ebuild  N    ] media-libs/fontconfig-2.2.3  732 kB 
[ebuild  N    ] x11-apps/ttmkfdir-3.0.9-r3  19 kB 
[ebuild  N    ] x11-base/xorg-x11-6.8.2-r6  -3dfx -3dnow +bitmap-fonts -cjk -debug -dlloader -dmx -doc -font-server -insecure-drivers -ipv6 -minimal -mmx +nls -nocxx +opengl +pam -sdk -sse -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 45,134 kB 
[ebuild  N    ] media-libs/jasper-1.701.0  +jpeg +opengl 1,329 kB 
[ebuild  N    ] media-libs/netpbm-10.30-r1  +jpeg +png +svga -tiff +zlib 2,542 kB 
[ebuild  N    ] app-arch/rpm2targz-9.0-r3  2 kB 
[ebuild  N    ] sys-apps/utempter-  20 kB 
[ebuild  N    ] x11-terms/xterm-207  -Xaw3d -doc -toolbar -truetype -unicode 727 kB 

Total size of downloads: 53,498 kB

# emerge --info    
Portage 2.0.54 (default-linux/x86/2006.0, gcc-3.3.6, glibc-2.3.5-r2, 2.6.9-gentoo-r13 i686)
System uname: 2.6.9-gentoo-r13 i686 AMD Athlon(tm) processor
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control /var/run/dspam /var/spool/dspam"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer -pipe"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="x86 alsa apache2 apm arts avi berkdb bitmap-fonts bzip2 crypt cups eds emboss encode esd expat foomaticdb fortran gd gdbm gif gnome gpm gstreamer gtk gtk2 idn imap imlib jpeg kde libg++ libwww mad mikmod motif mp3 mpeg mysql ncurses nls nptl ogg opengl oss pam pcre perl php png python quicktime readline ruby spell sqlite ssl svga tcpd truetype-fonts type1-fonts udev vorbis xml xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"

Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-03-08 15:33:16 UTC
Remove opengl from your use flags. Also, gnome, gtk, gtk2, kde and a bunch of others will pull in X stuff for sure with other ebuilds. 
Comment 6 Rob Hudson 2006-03-08 15:45:17 UTC
Removing gnome, gtk, gtk2, opengl, and kde from use flags did the trick.  Thanks.