Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 12541 - Xfree and/or xchat and/or theme engine memory leak
Summary: Xfree and/or xchat and/or theme engine memory leak
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2002-12-21 18:42 UTC by ganfset
Modified: 2003-09-27 13:31 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description ganfset 2002-12-21 18:42:13 UTC
I don't know if this is a memory leak of Xfree, xchat or theme engine.

** What I see exactly :

- X process eat all memory (a "top" could show me more than 90% of memory)

- the longer I use the more X eat memory (it takes not memory at startup but
little by little)

- I can accelerate the process switching tabs on my xchat window (like an
hundred switch could make X take 10% more memory (seen by "top"))

- when I stand to long (ie more than 6-10 h) playing with my system and xchat, X
take nearly all memory and kernel begin to kill some process to recover memory.
This make me sure I do not speak about cache memory or something like that

- killing or closing xchat make X process come down to the usual 5% of memory

- some gtk theme (aqualightblue and geramik) make X use memory faster than some
others so it is linked with theme engines

** What I use :

- gentoo 1.4_rc1, last xfree, xchat, gnome .... not in ~x86, nothing unmasked
between thoses things

- system with 512Mo ram and 1Go swap, nothing more than a desktop, xchat,
evolution and some light apps (juste after lauching all things I have more than
60% free memory)

- some gtk theme engines (I tried themes based on pixmap-engine and the one with
geramik-engine : same thing happen), at this time I use Geramik (0.08-r1)

** What I think :

- somewhere xchat indirectly ask memory for a new graphical object when I switch
tab, but do not free it (do not throw the object) when it is no more displayed
... OR do not reuse the object when reswitch to that tab later (and reask
memory, recreating the objects)

Please ask if I did not explain correctly something (as my english is a little
bad) or if it lacks of some information

Comment 1 Martin Schlemmer (RETIRED) gentoo-dev 2002-12-26 13:21:12 UTC
You need to be more version specific ....  What theme engine do you use ?
What is the output of 'emerge info' ?
Comment 2 ganfset 2002-12-26 14:22:45 UTC
ok, sorry.

emerge info is :
Portage 2.0.46-r2 (default-x86-1.4, gcc-3.2.1, glibc-2.3.1-r2)
System uname: 2.4.19-gentoo-r10 i686 AMD Athlon(TM) XP 1800+
USE="x86 motif 3dnow aalib acpi afs alsa apache2 apm arts avi berkdb bonobo cdr
cjk crypt cups dga directfb doc dvd encode esd evo fbcon flash gb gd gdbm ggi
ggz gif gnome gphoto2 gpm gps gtk -gtk2 gtkhtml guile icc icc-pgo imap imlib
innodb ipv6 java jpeg kde kerberos lcms ldap leim libg++ libgda libwww maildir
mbox mikmod mmx mozilla mozsvg moznoxft mozcalendar mozaccess mozinterfaceinfo
mozp3p mozxmlterm mpeg mule mysql nas ncurses nls oav oci8 odbc oggvorbis opengl
oss pam pcmcia pda pdflib perl pic plotutils png pnp postgres python qt qtmt
quicktime readline ruby samba sasl scanner sdl slang slp snmp socks5 spell sse
ssl svga tcltk tcpd tetex tiff truetype wmf X xface xml xml2 xmms xv zeo zlib"
CFLAGS="-mcpu=athlon-xp -march=athlon-xp -O3 -pipe"
CXXFLAGS="-mcpu=athlon-xp -march=athlon-xp -O3 -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config
/usr/kde/2/share/config /usr/kde/3/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"

version of xchat is 1.8.10-r1
version of gtk

this is done with settings on geramik theme (geramik engine)
same result with Aqualightblue theme and some others pixamp engine themes (some
eat memory faster than others)

version of gtk-engines-geramik is 0.08-r1
version of gtk-engines-pixmap is 0.12
Comment 3 Mark Duckworth 2003-02-02 11:35:50 UTC
This happens to me, but only after my latest emerge -u world which included KDE (unused) and xchat, used!  I have a suspicion that if I unemerge the latest xchat everything will be fine, but for me too the X process starts sucking up all the RAM.  Twice in a row!  
Comment 4 Mark Duckworth 2003-02-02 11:38:31 UTC
My mistake, This happens to me too but I am using xchat-2 for gtk-2 so the version didn't change even though a new xchat did emerge.  I did however leave the latest version of mozilla running whereas I used to run phoenix.  Perhaps that could be the culprit.
Comment 5 foser (RETIRED) gentoo-dev 2003-02-02 12:16:17 UTC
we have another report about the old geramik theme leaking memory, you should be able to upgrade right now (masked ~).

As for xchat, are you using the 'transparancy' option ? it's a memhog, disable it.
Comment 6 Mark Duckworth 2003-02-07 15:41:47 UTC
This is becoming a HUGE problem for me.  I can run all programs, close them down and just leave X running and the X process will slowly consume memory.  Opening and closing gtk programs expedites the process.  I don't have the geramik theme installed.  Xchat is not using the transparency option and hell, shouldn't it release the memory if it was hogging it anyway?  I have 512 megs of ram in my system and this is horrible.  Both of my systems at work and at home are having problems after the most recent emerge -u's and the latest xfree upgrade didn't help anything.  Surely someone else must be having this problem yet this bug has no activity.
Comment 7 ganfset 2003-02-07 16:01:47 UTC
I do not use xchat transparency either.
I avoid the problem removing all xchat theme and having a "default" gtk style.

I'm thinking about a thing : I use nvidia graphic card with nvidia drivers
Comment 8 Mark Duckworth 2003-02-09 02:30:02 UTC
It's gaim.  I tested each and every program I use on my system by singling out a single program and not running it after a complete system failure.  Sure enough when I got to gaim and instead used gaim-cvs my systems at work and at home (both nvidia) suddenly were just fine.  DEFINATELY GAIM!  the problem probably is with 0.59.8 but it could be other versions.  How a memory leak in something gaim does affects the X process is beyond me, but, Martin, I'm willing to bet you run gaim and if you upgrade or use another im client your problems will be solved.  Note: for me the problem still exists even if I close the offensive program (gaim) so you have to start up X fresh and make sure *not* to run gaim.  Gaim cvs is gtk2 and looks much cooler anyway ;-)
Comment 9 Joe Seeder 2003-04-25 16:05:44 UTC
hey i have memory leak to X while i'm using Xfree 3.2.0 , it takes about 1.5h to getoff 100MB from my RAM, and/or swap (if i enable it), i have no gaim, so it is not gaims leak
Comment 10 Michele Noberasco (RETIRED) gentoo-dev 2003-05-05 09:23:54 UTC
I'm experiencing it also, just using X slows eats up my memory... 
Comment 11 Michele Noberasco (RETIRED) gentoo-dev 2003-05-05 09:26:55 UTC
er... I meant SLOWLY eats up my memory 
Comment 12 Seemant Kulleen (RETIRED) gentoo-dev 2003-05-30 04:00:39 UTC
what video cards, what release of xfree and what kernels?
Comment 13 foser (RETIRED) gentoo-dev 2003-05-30 05:24:51 UTC
i say it's the GTK+ pixmaps themes, try a newer geramik (which is pixmap based as well afaik). 
Comment 14 Michele Noberasco (RETIRED) gentoo-dev 2003-09-27 10:55:30 UTC
Is this bug still active?

I no longer have problems, but updated so many packages that it is impossible
to tell what was causing this. Neverthless, all is OK now.

Maybe it is the case to close this bug...
Comment 15 Seemant Kulleen (RETIRED) gentoo-dev 2003-09-27 13:31:08 UTC