Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 124012 - audacious-itouch-0.1.ebuild
Summary: audacious-itouch-0.1.ebuild
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://nedudu.hu/?page_id=11
Whiteboard:
Keywords: EBUILD
: 129610 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-24 15:29 UTC by Gergan Penkov
Modified: 2010-09-01 14:29 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
audacious-itouch-0.1-autotools.patch (audacious-itouch-0.1-autotools.patch,281 bytes, patch)
2006-02-24 15:30 UTC, Gergan Penkov
Details | Diff
audacious-itouch-0.1.ebuild (audacious-itouch-0.1.ebuild,1.09 KB, text/plain)
2006-02-24 15:30 UTC, Gergan Penkov
Details
itouch-control-0.1.1.ebuild (itouch-control-0.1.1.ebuild,672 bytes, text/plain)
2007-03-04 13:09 UTC, Chris Mayo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gergan Penkov 2006-02-24 15:29:18 UTC
Essentially the bmp-itouch pkg ported to audacious, I'll post an ebuild, but I'm not completely sure if it is the right one. 
The problem is that in fact this is the same pkg as bmp-itouch with changed configure-scripts, but there is a missing po/Makefile.in, which exists in bmp-itouch. 
There is po/Makefile.in.in - that's why I've added po/Makefile.in to the configure.ac and eautoreconf to the original bmp-itouch build and it works, but as I said I'm not sure if this is the right thing to do.
Without the changes the configure will die, because of the missing po/Makefile.in.
Comment 1 Gergan Penkov 2006-02-24 15:30:04 UTC
Created attachment 80649 [details, diff]
audacious-itouch-0.1-autotools.patch

the patch
Comment 2 Gergan Penkov 2006-02-24 15:30:31 UTC
Created attachment 80650 [details]
audacious-itouch-0.1.ebuild

and the ebuild
Comment 3 Andrew Dorney 2006-03-19 17:15:46 UTC
Works just fine (with patch) on AMD64. Thanks for the ebuild. :)

~~ Andrew D.
Comment 4 Rafal Boniecki 2006-03-27 06:58:03 UTC
Works fine here as well (x86_32).
Plugin has some stability problems (it just closes along with audacious after clicking ok in its settings window).
Comment 5 Gergan Penkov 2006-03-27 07:18:15 UTC
(In reply to comment #4)
> Works fine here as well (x86_32).
> Plugin has some stability problems (it just closes along with audacious after
> clicking ok in its settings window).
> 

well, I should have said it earlier, but as I used the itouch-plugins for a long time, thought that everybody have already experienced this.
for me neither xmms-itouch, bmp-itouch nor audacious-itouch worked in gnome, all other de, wm, which i have tested do not have this problem.
Comment 6 John Dough 2006-04-11 10:56:13 UTC
*** Bug 129610 has been marked as a duplicate of this bug. ***
Comment 7 John Dough 2006-05-07 21:40:07 UTC
request bumped
Comment 8 Andrew Dorney 2006-05-07 21:45:25 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Works fine here as well (x86_32).
> > Plugin has some stability problems (it just closes along with audacious after
> > clicking ok in its settings window).
> > 
> 
> well, I should have said it earlier, but as I used the itouch-plugins for a
> long time, thought that everybody have already experienced this.
> for me neither xmms-itouch, bmp-itouch nor audacious-itouch worked in gnome,
> all other de, wm, which i have tested do not have this problem.
> 

I'm not entirely sure that this works with the new audacious-1.0.0-r1 ebuild (I use Fluxbox, so your Gnome issue shouldn't be a prob). It's crashing for me every time I enable it with the new audacious. Gergan, what version of Audacious do you run?

~~ Andrew D.
Comment 9 Gergan Penkov 2006-05-07 22:54:42 UTC
Well I'm running audacious from svn and don't have any problems, the other thing is that I use xfce4. I thought that the problem is predominantly with gnome as mediakey-deamon or whatever is this called in gnome, somehow conflicts with this plug-in, but as you say that you are using fluxbox - it looks like the problem is somewhere else...
Comment 10 John Dough 2006-06-12 20:28:46 UTC
request bumped again
Comment 11 Tony Vroon gentoo-dev 2006-06-16 05:31:45 UTC
(In reply to comment #10)
> request bumped again

Please stop wasting time by replying to a bug when you have nothing to say. This is counterproductive.

Note that this package currently stands no change of getting merged as it is incorrectly packaged (it doesn't compile without help, this is an upstream problem) and is unstable in Gnome, which I happen to use.
Comment 12 Gergan Penkov 2006-07-27 06:00:44 UTC
I think this could be resolved as wontfix or invalid as it does not work with the current svn and will not work in future as some of the API it uses is marked as bad (or was this way some time ago, I just forgot to comment).
Comment 13 Chris Mayo 2007-03-04 13:09:02 UTC
Created attachment 112048 [details]
itouch-control-0.1.1.ebuild

Here's somebody else's attempt at the same thing. This one compiles without modification and is running fine for me on amd64 and Gnome.

I have been running it with Audacious 1.3 and put in a DEPEND for that, but the README says any 1.x.
Comment 14 Tony Vroon gentoo-dev 2010-09-01 14:29:02 UTC
The link no longer points at a download page.
I believe this plugin to be discontinued.