Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 1240 - xmms-1.2.7-r1 build breaks on compilation of plover.cpp
Summary: xmms-1.2.7-r1 build breaks on compilation of plover.cpp
Status: RESOLVED DUPLICATE of bug 1238
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Daniel Robbins (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-03-19 10:58 UTC by Avi Schwartz
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Avi Schwartz 2002-03-19 10:58:01 UTC
c++ -DHAVE_CONFIG_H -I. -I. -I.. -I. -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -D_REENTRANT
-I/usr/X11R6/include -I/usr/include/avifile -I/usr/include/SDL -D_REENTRANT
-mcpu=i686 -march=i686 -O3 -pipe -Wall -Wpointer-arith -finline-functions
-ffast-math -fomit-frame-pointer -funroll-all-loops
-DDATA_DIR=\"/usr/share/xmms\" -DPLUGIN_DIR=\"/usr/lib/xmms\"
-DPLUGINSUBS=\"Output\",\"Input\",\"Effect\",\"General\",\"Visualization\"
-DLOCALEDIR=\"/usr/share/locale\" -DI386_ASSEM -I../intl    -mcpu=i686
-march=i686 -O3 -pipe -c plover.cpp
plover.cpp:17: StreamInfo.h: No such file or directory
plover.cpp:19: playerwidget.h: No such file or directory
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -D_REENTRANT
-I/usr/X11R6/include -I/usr/include/avifile -I/usr/include/SDL -D_REENTRANT
-mcpu=i686 -march=i686 -O3 -pipe -Wall -Wpointer-arith -finline-functions
-ffast-math -fomit-frame-pointer -funroll-all-loops
-DDATA_DIR=\"/usr/share/xmms\" -DPLUGIN_DIR=\"/usr/lib/xmms\"
-DPLUGINSUBS=\"Output\",\"Input\",\"Effect\",\"General\",\"Visualization\"
-DLOCALEDIR=\"/usr/share/locale\" -DI386_ASSEM -I../intl    -mcpu=i686
-march=i686 -O3 -pipe -Wall -Wpointer-arith -finline-functions -ffast-math
-fomit-frame-pointer -funroll-all-loops -c pluginenum.c
In file included from /usr/include/avifile/avifile.h:15,
                 from plover.cpp:15:
/usr/include/avifile/image.h: In method `col::col(unsigned char, unsigned char,
unsigned char)':
/usr/include/avifile/image.h:16: warning: member initializers for `unsigned char
col::b'
/usr/include/avifile/image.h:16: warning:   and `unsigned char col::g'
/usr/include/avifile/image.h:18: warning:   will be re-ordered to match
declaration order
/usr/include/avifile/image.h:16: warning: member initializers for `unsigned char
col::g'
/usr/include/avifile/image.h:16: warning:   and `unsigned char col::r'
/usr/include/avifile/image.h:18: warning:   will be re-ordered to match
declaration order
/usr/include/avifile/image.h: In method `BitmapInfo::BitmapInfo(const
BITMAPINFOHEADER &)':
/usr/include/avifile/image.h:52: warning: comparison between signed and unsigned
/usr/include/avifile/image.h: In method `BitmapInfo::BitmapInfo(const BitmapInfo
&)':
/usr/include/avifile/image.h:58: warning: comparison between signed and unsigned
/usr/include/avifile/image.h: In method `BitmapInfo::BitmapInfo(const BitmapInfo
*)':
/usr/include/avifile/image.h:65: warning: comparison between signed and unsigned
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -D_REENTRANT
-I/usr/X11R6/include -I/usr/include/avifile -I/usr/include/SDL -D_REENTRANT
-mcpu=i686 -march=i686 -O3 -pipe -Wall -Wpointer-arith -finline-functions
-ffast-math -fomit-frame-pointer -funroll-all-loops
-DDATA_DIR=\"/usr/share/xmms\" -DPLUGIN_DIR=\"/usr/lib/xmms\"
-DPLUGINSUBS=\"Output\",\"Input\",\"Effect\",\"General\",\"Visualization\"
-DLOCALEDIR=\"/usr/share/locale\" -DI386_ASSEM -I../intl    -mcpu=i686
-march=i686 -O3 -pipe -Wall -Wpointer-arith -finline-functions -ffast-math
-fomit-frame-pointer -funroll-all-loops -c playlist.c
In file included from /usr/include/avifile/videodecoder.h:20,
                 from /usr/include/avifile/avifile.h:16,
                 from plover.cpp:15:
/usr/include/avifile/infotypes.h: In method `CodecInfo::CodecInfo(int *, const
char *, const char *, const char *, CodecInfo::Kind, GUID * = 0, const
vector<AttributeInfo,allocator<AttributeInfo> > & =
vector<AttributeInfo,allocator<AttributeInfo> >((&allocator<AttributeInfo>())),
const vector<AttributeInfo,allocator<AttributeInfo> > & =
vector<AttributeInfo,allocator<AttributeInfo> >((&allocator<AttributeInfo>())))':
/usr/include/avifile/infotypes.h:36: warning: member initializers for `int
CodecInfo::fourcc'
/usr/include/avifile/infotypes.h:38: warning:   and `class string CodecInfo::text'
/usr/include/avifile/infotypes.h:51: warning:   will be re-ordered to match
declaration order
/usr/include/avifile/infotypes.h:39: warning: member initializers for `class
string CodecInfo::about'
/usr/include/avifile/infotypes.h:40: warning:   and `class string CodecInfo::dll'
/usr/include/avifile/infotypes.h:51: warning:   will be re-ordered to match
declaration order
/usr/include/avifile/infotypes.h:40: warning: member initializers for `class
string CodecInfo::dll'
/usr/include/avifile/infotypes.h:42: warning:   and `enum CodecInfo::Kind
CodecInfo::kind'
/usr/include/avifile/infotypes.h:51: warning:   will be re-ordered to match
declaration order
plover.cpp: At top level:
plover.cpp:22: parse error before `{'
plover.cpp:30: parse error before `('
plover.cpp: In function `bool open_file(const char *)':
plover.cpp:41: invalid use of `this' in non-member function
plover.cpp:43: invalid use of `this' in non-member function
plover.cpp:44: `xDisplay' undeclared (first use this function)
plover.cpp:44: (Each undeclared identifier is reported only once
plover.cpp:44: for each function it appears in.)
plover.cpp:48: invalid use of `this' in non-member function
plover.cpp:48: invalid use of `this' in non-member function
plover.cpp:51: implicit declaration of function `int CreateAviPlayer2(...)'
plover.cpp:55: invalid use of `this' in non-member function
plover.cpp:58: invalid use of `this' in non-member function
plover.cpp:61: `player' undeclared (first use this function)
plover.cpp:62: invalid use of `this' in non-member function
plover.cpp:62: `fullscreen' undeclared (first use this function)
plover.cpp:63: invalid use of `this' in non-member function
plover.cpp:65: invalid use of `this' in non-member function
plover.cpp:65: `maximized' undeclared (first use this function)
plover.cpp:66: invalid use of `this' in non-member function
plover.cpp:68: invalid use of `this' in non-member function
plover.cpp:69: invalid use of `this' in non-member function
plover.cpp:71: invalid use of `this' in non-member function
plover.cpp:72: invalid use of `this' in non-member function
plover.cpp:74: invalid use of `this' in non-member function
plover.cpp:74: invalid use of `this' in non-member function
plover.cpp:75: invalid use of `this' in non-member function
plover.cpp:79: invalid use of `this' in non-member function
plover.cpp: At top level:
plover.cpp:84: syntax error before `*'
plover.cpp: In function `void close_file()':
plover.cpp:90: invalid use of `this' in non-member function
plover.cpp:91: invalid use of `this' in non-member function
plover.cpp:92: invalid use of `this' in non-member function
plover.cpp:94: invalid use of `this' in non-member function
plover.cpp:94: invalid use of `this' in non-member function
plover.cpp:95: invalid use of `this' in non-member function
plover.cpp: At top level:
plover.cpp:99: destructors must be member functions
plover.cpp: In function `void XMMSAviPlayer()':
plover.cpp:100: invalid use of `this' in non-member function
plover.cpp: At top level:
plover.cpp:104: virtual outside class declaration
plover.cpp: In function `void PW_middle_button()':
plover.cpp:108: invalid use of `this' in non-member function
plover.cpp:108: `scaled' undeclared (first use this function)
plover.cpp:109: invalid use of `this' in non-member function
plover.cpp:110: invalid use of `this' in non-member function
plover.cpp:112: invalid use of `this' in non-member function
plover.cpp:112: invalid use of `this' in non-member function
plover.cpp:113: invalid use of `this' in non-member function
plover.cpp:113: invalid use of `this' in non-member function
plover.cpp:115: invalid use of `this' in non-member function
plover.cpp:115: invalid use of `this' in non-member function
plover.cpp:116: invalid use of `this' in non-member function
plover.cpp:116: invalid use of `this' in non-member function
plover.cpp:118: invalid use of `this' in non-member function
plover.cpp:118: invalid use of `this' in non-member function
plover.cpp:119: invalid use of `this' in non-member function
plover.cpp:119: invalid use of `this' in non-member function
plover.cpp:121: invalid use of `this' in non-member function
plover.cpp:121: invalid use of `this' in non-member function
plover.cpp:121: invalid use of `this' in non-member function
plover.cpp: At top level:
plover.cpp:125: virtual outside class declaration
plover.cpp: In function `void PW_menu_slot()':
plover.cpp:126: invalid use of `this' in non-member function
plover.cpp:127: invalid use of `this' in non-member function
plover.cpp:129: invalid use of `this' in non-member function
plover.cpp:131: invalid use of `this' in non-member function
plover.cpp: At top level:
plover.cpp:134: virtual outside class declaration
plover.cpp:135: virtual outside class declaration
plover.cpp:136: virtual outside class declaration
plover.cpp:137: virtual outside class declaration
plover.cpp:138: virtual outside class declaration
plover.cpp:139: virtual outside class declaration
plover.cpp:140: virtual outside class declaration
plover.cpp: In function `void PW_key_func(int, int)':
plover.cpp:145: invalid use of `this' in non-member function
plover.cpp:146: invalid use of `this' in non-member function
plover.cpp:152: invalid use of `this' in non-member function
plover.cpp:153: invalid use of `this' in non-member function
plover.cpp: At top level:
plover.cpp:164: virtual outside class declaration
plover.cpp: In function `void PW_resize(int, int)':
plover.cpp:167: invalid use of `this' in non-member function
plover.cpp:168: invalid use of `this' in non-member function
plover.cpp:169: invalid use of `this' in non-member function
plover.cpp:170: invalid use of `this' in non-member function
plover.cpp: At top level:
plover.cpp:172: virtual outside class declaration
plover.cpp: In function `void PW_refresh()':
plover.cpp:173: invalid use of `this' in non-member function
plover.cpp: At top level:
plover.cpp:175: virtual outside class declaration
plover.cpp:177: parse error before `private'
plover.cpp:179: %
Comment 1 Avi Schwartz 2002-03-19 10:59:44 UTC

*** This bug has been marked as a duplicate of 1238 ***