i've got the following problem: i've masked the latest python release in /etc/portage/packages.mask with:
because one application i have doesn't work with it ...
but when updating sys-apps/dbus, which requires >=dev-lang/python-2.4 i get the following error message:
!!! All ebuilds that could satisfy ">=dev-lang/python-2.4" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-2.4.2-r1 (masked by: package.mask)
- dev-lang/python-2.4.2 (masked by: package.mask)
this is correct, but i have python-2.4.1 installed, so portage shouldn't be required to update it ...
2.4.1 doesn't exist anymore, so you have effectively masked >2.3.5-r2.
Not a bug, kindly read http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3
not quite correct: /var/db/pkg/dev-lang/python-2.4.1-r1/python-2.4.1-r1.ebuild
you're right, not a bug, but a feature request ...
of course i could add the 2.4.1-r1 ebuild to my portage overlay, but i'd prefer a cleaner solution
Don't reopen this bug unless you've completely read and understood the document linked above. Bugzilla is not a support forum for self-inflicted problems, use forums.gentoo.org, IRC or mailing lists.
jakub, sorry for having a suggestion, how to improve portage ... will do the quick hack with my local overlay then ...
note, that you invalidly marked then bug invalid, since i reopened the bug after reading the document (about one or two years ago). also i think, one can formulate bugzilla comments in friendly way without SCREAMING