Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 121097 - cracklib-2.8.5 fails to compile
Summary: cracklib-2.8.5 fails to compile
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2006-01-31 13:49 UTC by Jonathan Hansen
Modified: 2006-02-09 18:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Log of emerge run and cracklib error (emerge.log,30.63 KB, text/plain)
2006-02-07 11:18 UTC, Jonathan Hansen
Requested scanelf log (scanelf.log,487.65 KB, text/plain)
2006-02-08 08:56 UTC, Jonathan Hansen
Log of requested emerge run (cracklib.log,128.26 KB, text/plain)
2006-02-09 10:24 UTC, Jonathan Hansen

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Hansen 2006-01-31 13:49:09 UTC
I get the following message when atempting to run the latest version of the cracklib e-build from portage. I tried to look for other bugs relating to this but am afraid I am new to this whole thing... appoligies if a duplicate.

make[2]: Entering directory `/var/tmp/portage/cracklib-2.8.5/work/cracklib-2.8.5'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/var/tmp/portage/cracklib-2.8.5/work/cracklib-2.8.5'
make[1]: Leaving directory `/var/tmp/portage/cracklib-2.8.5/work/cracklib-2.8.5'
Generating cracklib dicts ... cracklib-packer: error while loading shared libraries: RTLD_NEXT used in code not dynamically loaded
/var/tmp/portage/cracklib-2.8.5/image//usr/sbin/cracklib-format: line 12: 10426 Done                    gzip -cdf $*
     10427                       | tr '[A-Z]' '[a-z]'
     10428                       | tr -cd '\012[a-z][0-9]'
     10429 Broken pipe             | sort
     10430 Broken pipe             | uniq
     10433 Broken pipe             | grep -v '^#'
     10434 Broken pipe             | grep -v '^$'
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-01-31 13:56:44 UTC
emerge --info, please...
Comment 2 Jonathan Hansen 2006-01-31 14:30:18 UTC
Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2, 2.6.12-gentoo-r6 i686)
System uname: 2.6.12-gentoo-r6 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=pentium4"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="x86 X alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bzip2 crypt cups eds emboss encode esd exif expat fam ffmpeg foomaticdb fortran gdbm gif glut gnome gpm gstreamer gtk gtk2 idn imlib ipv6 java jpeg junit kde lcms libg++ libwww mad mhash mikmod mng motif mp3 mpeg mysql ncurses nls nvidia ogg oggvorbis opengl oss pam pcre pdflib perl php png python qt quicktime readline sdl spell ssl tcpd tiff truetype truetype-fonts type1-fonts udev vorbis xml2 xmms xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Comment 3 Jonathan Hansen 2006-02-06 18:15:46 UTC
Provided requested info
Comment 4 SpanKY gentoo-dev 2006-02-07 06:16:17 UTC
post the full `emerge cracklib` log as an attachment
Comment 5 Jonathan Hansen 2006-02-07 11:18:53 UTC
Created attachment 79147 [details]
Log of emerge run and cracklib error
Comment 6 SpanKY gentoo-dev 2006-02-07 19:22:04 UTC
something isnt quite right on your machine that's for sure ...

this is wrong in the output:
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/../../../../i686-pc-linux-gnu/bin/ld: warning: creating a DT_TEXTREL in object.

can you try running:
scanelf -Tt \

and posting the output as an attachment please
Comment 7 Jonathan Hansen 2006-02-08 08:56:01 UTC
Created attachment 79237 [details]
Requested scanelf log
Comment 8 SpanKY gentoo-dev 2006-02-08 18:49:16 UTC
what about this:
scanelf -n \

also, what does this should:
ls /usr/lib/libc.*

finally, run this command and post the log as an attachment:
LDFLAGS='-Wl,--verbose' emerge cracklib >& log
Comment 9 Jonathan Hansen 2006-02-09 10:23:57 UTC
gentoo tmp # scanelf -n \
> /var/tmp/portage/cracklib-2.8.5/work/cracklib-2.8.5/lib/.libs/
ET_DYN  /var/tmp/portage/cracklib-2.8.5/work/cracklib-2.8.5/lib/.libs/ 

gentoo tmp # ls /usr/lib/libc.*

Comment 10 Jonathan Hansen 2006-02-09 10:24:42 UTC
Created attachment 79345 [details]
Log of requested emerge run
Comment 11 SpanKY gentoo-dev 2006-02-09 10:55:04 UTC
as i suspected, you're missing /usr/lib/

do this to fix your system:
cd /usr/lib
ln -s /lib/
emerge glibc
Comment 12 Jonathan Hansen 2006-02-09 11:49:43 UTC
I could not compile glibc with the suggested link in place but removing it solved the problem, I was able to compile glibc and then cracklib.

Should glibc be a dependancy for cracklib then?

Thanks a bunch!
Comment 13 SpanKY gentoo-dev 2006-02-09 18:00:24 UTC
glibc should have installed a file for you, no idea why it wasnt installed and/or gone

adding glibc to cracklib's DEPEND would have been useless as every system has glibc already installed