Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 118211 - emerge shouldn't block on "part of the transaccion" operations
Summary: emerge shouldn't block on "part of the transaccion" operations
Status: RESOLVED DUPLICATE of bug 79606
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-07 11:39 UTC by Carlo Marcelo Arenas Belon
Modified: 2006-01-07 11:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo Marcelo Arenas Belon 2006-01-07 11:39:26 UTC
emerge should be able to resolve this block, as it is going to upgrade xpdf to >=3.01-r3 anyway clearing it, and so the future emerge unmerge for "=xpdf-3.01-r3" which is part of the emerge -U operation should made the currently required manual `emerge unmerge xpdf` not to be needed.

# emerge -DNvup ">=xpdf-3.01-r5"

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r4)
[ebuild  N    ] app-text/poppler-0.4.3-r4  -cairo +jpeg +zlib 806 kB 
[ebuild     U ] app-text/xpdf-3.01-r5 [3.01-r3] +X 0 kB
Comment 1 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-01-07 11:41:31 UTC

*** This bug has been marked as a duplicate of 79606 ***