Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 117360 - transcode-0.6.14-r2 build error
Summary: transcode-0.6.14-r2 build error
Status: RESOLVED DUPLICATE of bug 116181
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-01 09:39 UTC by alfredtaipei
Modified: 2006-01-01 10:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alfredtaipei 2006-01-01 09:39:47 UTC
I have encounter error when building transcode-0.6.14-r2:

export_ffmpeg.c: In function `export_ffmpeg_init':
export_ffmpeg.c:677: error: structure has no member named `frame_rate'
export_ffmpeg.c:678: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:681: error: structure has no member named `frame_rate'
export_ffmpeg.c:682: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:685: error: structure has no member named `frame_rate'
export_ffmpeg.c:686: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:689: error: structure has no member named `frame_rate'
export_ffmpeg.c:690: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:693: error: structure has no member named `frame_rate'
export_ffmpeg.c:694: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:697: error: structure has no member named `frame_rate'
export_ffmpeg.c:698: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:701: error: structure has no member named `frame_rate'
export_ffmpeg.c:702: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:705: error: structure has no member named `frame_rate'
export_ffmpeg.c:706: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:712: error: structure has no member named `frame_rate'
export_ffmpeg.c:713: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:717: error: structure has no member named `frame_rate'
export_ffmpeg.c:718: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:735: error: structure has no member named `frame_rate'
export_ffmpeg.c:736: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:739: error: structure has no member named `frame_rate'
export_ffmpeg.c:740: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:743: error: structure has no member named `frame_rate'
export_ffmpeg.c:744: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:747: error: structure has no member named `frame_rate'
export_ffmpeg.c:748: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:751: error: structure has no member named `frame_rate'
export_ffmpeg.c:752: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:755: error: structure has no member named `frame_rate'
export_ffmpeg.c:756: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:759: error: structure has no member named `frame_rate'
export_ffmpeg.c:760: error: structure has no member named `frame_rate_base'
export_ffmpeg.c:763: error: structure has no member named `frame_rate'
export_ffmpeg.c:764: error: structure has no member named `frame_rate_base'
make[2]: *** [export_ffmpeg.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/transcode-0.6.14-r2/work/transcode-0.6.14/export'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/transcode-0.6.14-r2/work/transcode-0.6.14'
make: *** [all] Error 2

!!! ERROR: media-video/transcode-0.6.14-r2 failed.
!!! Function src_compile, Line 128, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.

<b>emerge --info</b>
Portage 2.0.53 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2, 2.6.14-gentoo-r5 i686)
=================================================================
System uname: 2.6.14-gentoo-r5 i686 AMD Athlon(tm) XP 2000+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/fax /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://mirror.gentoo.gr.jp http://gentoo.gg3.net/ ftp://gg3.net/pub/linux/gentoo/ ftp://ftp.ecc.u-tokyo.ac.jp/GENTOO http://gentoo.channelx.biz/ http://ftp.gentoo.or.kr/ http://ftp.isu.edu.tw/pub/Linux/Gentoo ftp://ftp.isu.edu.tw/pub/Linux/Gentoo ftp://mirror.averse.net/pub/gentoo http://mirror.averse.net/pub/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X Xaw3d a52 aac aalib accessibility acl acpi adabas adns aim alsa apache2 apm arts audiofile avi bash-completion bcmath berkdb bidi bindist birdstep bitmap-fonts blas bluetooth bmp bonobo bzip2 calendar caps cdb cdparanoia chasen cjk cpdflib crypt cscope ctype cups curl curlwrappers db2 dba dbase dbm dbmaker dbus dbx dedicated dga diet dio directfb divx4linux dlloader doc dts dv dvb dvd dvdr dvdread eds emacs emacs-w3 emboss empress empress-bcs encode esd esoob ethereal evo examples exif expat fam fame fastcgi fbcon ffmpeg fftw filepro firebird flac flash flatfile foomaticdb fortran freewnn frontbase ftp gb gcj gd gdbm geoip ggi gif ginac glut gmp gnome gnustep gnutls gphoto2 gpm gps gstreamer gtk gtk2 gtkhtml hal hardened hardenedphp howl hyperwave-api icc iconv icq idn ieee1394 imagemagick imap imlib immqt-bc informix ingres inifile innodb interbase iodbc ipv6 jabber jack java javascript jikes joystick jpeg junit kde kdeenablefinal kdexdeltas kerberos krb4 ladcca lapack lcd lcms ldap leim lesstif libcaca libg++ libgda libwww lirc lm_sensors lzo m17n-lib mad maildir mailwrapper matroska matrox mbox mcal mcve memlimit mhash migemo mikmod milter mime ming mjpeg mmap mmx mmxext mng mnogosearch mono motif mozcalendar mozilla mozsvg mp3 mpeg mpi mplayer msession msn msql mule mysql mysqli mythtv nas ncurses neXt netcdf network nhc98 nis nls nocd nptl nsplugin oci8 odbc offensive ofx ogg oggvorbis openal opengl oracle oracle7 osc oscar oss ovrimos pam pcntl pcre pda pdflib perl pfpro php pic plotutils png portaudio posix postgres ppds prelude profile pvm python qdbm qt quicktime radius readline real recode ruby samba sapdb sasl scanner sdl session sharedext sharedmem shorten simplexml skey slang slp smartcard sndfile snmp soap sockets socks5 solid sox speex spell spl sqlite sse ssl svg svga sybase sybase-ct symlink sysvipc szip tcltk tcpd tetex theora threads tidy tiff tokenizer truetype truetype-fonts type1-fonts udev unichrome unicode usb utf8 v4l v4l2 vcd vhosts videos vim-with-x vorbis wddx wifi win32codecs wmf wxwindows xface xine xinerama xml xml2 xmlrpc xmms xosd xpm xprint xsl xv xvid yahoo yaz yv12 zeo zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY

<b>emerge -pv transcode</b>

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] media-video/transcode-0.6.14-r2  +3dnow +X +a52 (-altivec) +dv +dvdread +encode +fame +gtk +imagemagick +jpeg +lzo +mjpeg +mmx +mpeg +network +ogg +pvm +quicktime +sdl +sse -sse2 +theora +truetype +v4l +vorbis +xml2 +xvid 0 kB
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-01-01 10:32:16 UTC

*** This bug has been marked as a duplicate of 116181 ***