Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 116473 - openoffice-2.0.1 crashes with CJK
Summary: openoffice-2.0.1 crashes with CJK
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Office Team
: 119535 (view as bug list)
Depends on:
Reported: 2005-12-23 02:52 UTC by whitecat05408
Modified: 2006-01-23 12:40 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

A test file (test.doc,20.00 KB, application/msword)
2005-12-25 15:44 UTC, Yang Dehua

Note You need to log in before you can comment on or make changes to this bug.
Description whitecat05408 2005-12-23 02:52:37 UTC
openoffice-2.0.1 crashed suddenly when I used Japanese IME. There is no problem in the environment that doesn't use Japanese IME.
If that helps, openoffice- didn't crash.

Installed versions:

Portage 2.1_pre1 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r3, 2.6.14-gentoo-r5 i686)
System uname: 2.6.14-gentoo-r5 i686 Intel(R) Pentium(R) M processor 1.80GHz
Gentoo Base System version 1.12.0_pre12
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
CFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
USE="x86 X aac aalib acpi alsa anthy arts audiofile avi berkdb bitmap-fonts 
bonobo bzip2 cdr cjk crypt cups curl dbus directfb dvd eds emacs emboss encode 
esd estraier exif expat fam fbcon ffmpeg flac foomaticdb fortran gcj gd gdbm gif 
gimpprint glut gmp gnome gpm gtk gtk2 gtkhtml guile i8x0 idn imagemagick imlib 
immqt-bc ipv6 jpeg kde lcms libg++ libwww lua mad migemo mikmod ming mng mono 
motif mozilla mp3 mpeg mysql ncurses nls objc ogg oggvorbis openal opengl oss 
pam pcre pdflib perl pic png postgres ppds python qt quicktime readline ruby sdl 
sox spell sqlite ssl svga tcltk tcpd tiff truetype truetype-fonts type1-fonts 
udev uim unicode usb vorbis xine xml xml2 xmms xpm xprint xv xvid zlib 
elibc_glibc kernel_linux linguas_ja userland_GNU"
Comment 1 Andreas Proschofsky (RETIRED) gentoo-dev 2005-12-23 06:30:09 UTC
Sorry if sounding stupid, but what is "Japanese IME"?
Comment 2 Paul de Vrieze (RETIRED) gentoo-dev 2005-12-23 08:01:01 UTC
IME is an input method editor. It allows one to input amongst others, asian characters on a west keyboard (or any keyboard with a limited amount of keys for that matter).

To try to solve this, it is necessary to know though which IME was used.
Comment 3 whitecat05408 2005-12-23 08:48:03 UTC
> Sorry if sounding stupid, but what is "Japanese IME"?
"Japanese IME" is Japanese Language Input Method Editor. I'm using UIM. 
When more appropriate, it is a multilingual input method library.

Similarly, it crashed when multibyte character ( Japanese, Chinese and Korean language ) was displayed.
For example, 
When I paste multibyte character.
when I open the document including multibyte character.

Input-Method-Editor might be unrelated.
Comment 4 Yang Dehua 2005-12-24 05:02:19 UTC
same here on my ppc64 system running gentoo linux(32bit userland). Openoffice-2.01 crashed when I opened an CJK document or tried to imput Chinese by scim. 
Comment 5 Andreas Proschofsky (RETIRED) gentoo-dev 2005-12-25 10:48:38 UTC
Could someone of you please attach a CJK document to reproduce this bug? Also which desktop environment are you using?
Comment 6 Paul de Vrieze (RETIRED) gentoo-dev 2005-12-25 13:57:55 UTC
Do you have the proper font for displaying that text? What kind of font is it (truetype, pcf, pfb (Postscript type 1))? Do other applications show it. Can you select a Japanese font in openoffice that has the proper encoding?
Comment 7 Yang Dehua 2005-12-25 15:44:47 UTC
Created attachment 75530 [details]
A test file 

Here is a test file(test.doc). You can just open it in oowriter2 and see what happens.
I am using Gnome-2.12 running on gentoo ppc64 linux with 32-bit unserland(chroot). I just reverted to openoffice-, and it worked fine in the same environment where version 2.0.1 crashed.The fonts used were Arphicfonts(true type),and I also tried SimSun true type font, it made no diffenrence for the crashing.
BTW, I emerged openoffice with USE="-java", and it got errors after about one hour of emerging if I enabled the java USE variable. The my jdk was ibm-jdk-bin-1.5_beta1(I tried 1.4.2_03 too, the same result). 

Comment 8 Congtat Cia 2005-12-25 20:01:44 UTC
I am trapped in this bug, too. No related to jdk-1.4/1.5.
Comment 9 Congtat Cia 2005-12-25 20:40:34 UTC
openoffice-bin-2.0.1 works fine without any Chinese read/input issue.

Comment 10 Yang Dehua 2005-12-27 03:56:37 UTC
But no ppc version yet.
Comment 11 Andreas Proschofsky (RETIRED) gentoo-dev 2006-01-22 03:41:18 UTC
Just adjusting the title of the bug...
Comment 12 Andreas Proschofsky (RETIRED) gentoo-dev 2006-01-22 04:35:29 UTC
*** Bug 119535 has been marked as a duplicate of this bug. ***
Comment 13 Andreas Proschofsky (RETIRED) gentoo-dev 2006-01-22 12:26:56 UTC
I've just put an update for openoffice-2.0.1 in the tree, which aims to solve this, looks like one particular patch broke CJK support. Unfortunately it only partly solves the problem for me, the test.doc here in the bug works fine now, while the doc from bug #119535 still crashes OOo for me. Can't tell if input works, so it would be great, if you could "emerge sync", rebuild OOo and try again.

If you are not sure, if you've got the fixed version after the sync (the mirrors take some time to all get it), check the ChangeLog, it should say something about a CJK-fix.
Comment 14 Congtat Cia 2006-01-22 23:50:19 UTC
The new version works here, no more crashes now.
Comment 15 Andreas Proschofsky (RETIRED) gentoo-dev 2006-01-23 12:40:46 UTC
Original bug seems to be gone now, so closing.