Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 115333 - "ALL" must be uppercase to enable "all bugs" search
Summary: "ALL" must be uppercase to enable "all bugs" search
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: Bugzilla (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Jeffrey Forman (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-12 11:26 UTC by Denilson Sá
Modified: 2011-10-30 23:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denilson Sá 2005-12-12 11:26:44 UTC
At homepage, there is this note:
"Note: When searching for duplicate bugs, prefix search with 'ALL'"
But the note does not make clear that "ALL" must be written uppercase.

Reproducible: Always
Steps to Reproduce:
1. Type something, like "all kqemu"
2. Zarro Boogs found.
3. Now type "ALL kqemu"
4. Lots os bugs are listed.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-12-12 11:29:43 UTC
You are joking, right? How "MORE OBVIOUS" should we make it?
Comment 2 Denilson Sá 2005-12-12 11:42:53 UTC
No, I'm not joking. Bug report system is not a good place to jokes.

If you use bugzilla for months or years, you of course know ALL must be 
uppercase. But for the casual bug reporter, or anyone who never used bugzilla 
before, it is not obvious. (I just submitted a duplicated bug some minutes ago 
just because I used "all", instead of "ALL")

How to make it more obvious? Easy:

Note: When searching for duplicate bugs, prefix search with 'ALL' (in uppercase)
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-12-12 12:07:06 UTC
(In reply to comment #2)
> No, I'm not joking. 

That's really sad then, I was hoping for the better of the two alternatives... ;p

> (I just submitted a duplicated bug some minutes ago 
> just because I used "all", instead of "ALL")

Yes, the uppercase and quotation marks are there just for fun, because WE LIKE
CAPS AND 'QUOTES'...
Comment 4 Denilson Sá 2005-12-12 12:39:57 UTC
Again, it is not stated anywhere (or anywhere near the search box) that search 
is case INsensitive. I still think a little notice telling the user explicitly 
to use uppercase would be useful, and maybe can result in less duplicate bugs.

After all, I see no reason to not add that explicit notice about uppercase.

[joking]YOU LIKE UPPERCASE, but the user likes lowercase.[/joking]
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-12-12 13:09:32 UTC
(In reply to comment #4)
> Again, it is not stated anywhere (or anywhere near the search box) that search 
> is case INsensitive.

http://bugs.gentoo.org/quicksearch.html

<snip>
This is case-insensitive search.
    *  table ,  Table  and  TABLE  are all the same.
</snip>

Guess where did I find this - YEEEES, great surprise! It's the 'Help' link just
next to the search box. 

I guess this has been enough, please read basic help before filing bugs.

CLOSED.
Comment 6 Denilson Sá 2005-12-12 15:54:18 UTC
Ok, then, sorry for bothering you.