Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 114742 - mysql-4.1.15-r1 init script ruinning single and multiple "replicate-wild-ignore-table" entries in my.cnf
Summary: mysql-4.1.15-r1 init script ruinning single and multiple "replicate-wild-igno...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux MySQL bugs team
Depends on: 114621
  Show dependency tree
Reported: 2005-12-07 05:50 UTC by Rodrigo Severo
Modified: 2005-12-08 04:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Severo 2005-12-07 05:50:20 UTC
I have just upgraded from dev-db/mysql-4.1.14 to dev-db/mysql-4.1.15-r1 (should
I've tried dev-db/mysql-4.1.15-r30?). I need mysql-4.1.15 because of some
upstream issues supposelly fixed in version 4.1.15.

I have problems with the new init script. The start function is trying to parse
my.cnf. The "replicate-wild-ignore-table" entries aren't parsed well. I have
identified two issues:

1. I have entries like "replicate-wild-ignore-table = some_database.%". The init
script is changing "some_database.%" to "some_database.\%". So mysql tries to
ignore tables named "\%" instead of "%". In resume, mysql doesn't ignores all
tables inside "some_database" as desired.

2. I have two "replicate-wild-ignore-table" entries but the new init script is
ignoring my second "replicate-wild-ignore-table" entry.
Comment 1 Francesco R. (RETIRED) gentoo-dev 2005-12-07 15:25:40 UTC
please give a try to the attachments to bug #114621 .

if something fail, please send the output of:
#DEBUG=4 /etc/init.d/mysql stop start stop

Thanks for your report
Comment 2 Rodrigo Severo 2005-12-08 04:55:44 UTC
(In reply to comment #1)
> please give a try to the attachments to bug #114621.

Just did. The issue mentioned in this bug seems to be fixed with the attachments
of bug #114621. Both start and stop worked fine. These scripts are now on use on
one of my servers regulary.

If any problem arrise, I'll let you know.