Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 114399 - sandbox violation with gtkhtml-1.1.10-r1
Summary: sandbox violation with gtkhtml-1.1.10-r1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2005-12-03 17:03 UTC by Vladimir G. Ivanovic
Modified: 2006-12-26 15:24 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---

Patch for 1.1.10-r1 sandbox violation (gtkhtml-1.1.10-sandbox.patch,579 bytes, patch)
2006-06-26 05:28 UTC, Jan Holecek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir G. Ivanovic 2005-12-03 17:03:44 UTC
>>> Completed installing gtkhtml-1.1.10-r1 into

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-extra_-_gtkhtml-1.1.10-r1-19861.log"

open_wr:   /usr/share/gnome/html/gtkhtml/

Reproducible: Always
Steps to Reproduce:
1. emerge gtkhtml

Actual Results:  
Emerge aborted with a sandbox violation.

Expected Results:  
Build & install the latest gtkhtml package.
Comment 1 Bob Johnson 2005-12-06 10:29:26 UTC
(In reply to comment #0)

It's architecture-independent. On my x86 system I get:

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-extra_-_gtkhtml-1.1.10-r1-30694.log"

open_wr:   /usr/share/gnome/html/gtkhtml/

Same problem, different file.
Comment 2 Bill Binder 2005-12-07 14:05:28 UTC
(In reply to comment #1)


This seems to be an interaction with libgtkhtml. There is an ebuild for
libgtkhtml, but the gtkhtml ebuild builds an an old version of libgtkhtml all by

At the above access violation, I had:
- gtkhtml-1.1.10-r1 shown as installed (from the last time it completed ok)
- libgtkhtml-2.6.3 shown as installed
- /var/tmp/portage contained the failed build of gtkhtml

I tried the following things:
- emerge -e gtkhtml [failed as before]
- uninstalled libgtkhtml
- emerge gtkhtml [failed as before]
- removed the /var/tmp/portage/gtkhtml* directory
- emerge gtkhtml [this worked]
- emerge =gnome-extra/libgtkhtml-2.6.3 [the version that Gimp wants]
- emerge gtkhtml [failed as before]

The steps to make it all work:
- unmerge gtkhtml and libgtkhtml
- remove any old build from /var/tmp/portage
- emerge gtkhtml
- emerge libgtkhtml
Comment 3 Manuel McLure 2005-12-09 11:01:28 UTC
(In reply to comment #2)
> This seems to be an interaction with libgtkhtml. There is an ebuild for
> libgtkhtml, but the gtkhtml ebuild builds an an old version of libgtkhtml all by
> itself.

Actually, I'm seeing the same problem without having libgtkhtml installed, since
I have gimp built with -gtkhtml (I run a mostly KDE system.) It's the only thing
that fails to compile in a "make -e world" (to upgrade to gcc-3.4) and it's
being pulled in by gnucash.

Comment 4 Jesse Adelman 2005-12-12 20:38:27 UTC
Solution in comment #2 worked for me. Thanks.
Comment 5 Vasilis Lourdas 2005-12-15 14:50:12 UTC
(In reply to comment #2)
> The steps to make it all work:
> - unmerge gtkhtml and libgtkhtml
> - remove any old build from /var/tmp/portage
> - emerge gtkhtml
> - emerge libgtkhtml

It also worked for me! Thanks!

This bug must be architecture-independent (mine is x86).
Comment 6 Bill Binder 2005-12-18 07:10:20 UTC
(In reply to comment #3)
> Actually, I'm seeing the same problem without having libgtkhtml installed, ...

Yep, I agree, absence or presence of libgtkhtml makes no difference.

It looks like emerge gtkhtml fails if gtkhtml is already installed.

- genlop says it worked back in September when I upgraded to gcc 3.3.6
- the ebuild of gtkhtml back then was the same one as now
- the s/w build seems to work, its the install that fails

The ebuild for gtkhtml mentions a patch for gcc34 - is it possible this is causing the problem?? (now I'm actually using gcc 3.4.4 this patch is doing something?)

I suspect unmerging gtkhtml before kicking off an emerge -e world would work, but I'm not about to do that again for a while :-)

Comment 7 David Grant 2006-05-14 19:53:40 UTC
libgtkhtml doesn't seem to exist anymore. I'm getting this problem when I re-emerge gtkhtml-1.1.10-r1
Comment 8 Neal McConachie 2006-05-22 12:35:50 UTC
Same problem here, but for:
open_wr:   /usr/share/gnome/html/gtkhtml/

(doing an emerge -e world)
Comment 9 Arnaud Launay 2006-06-01 03:32:36 UTC
If you're afraid of losing gtkhtml, just build a binary package before any testing:
quickpkg =gnome-extra/gtkhtml-1.1.10-r1

BTW, same problem here:
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-extra_-_gtkhtml-1.1.10-r1-24062.log"
unlink:    /usr/share/gnome/html/gtkhtml/r27.html
Comment 10 Arnaud Launay 2006-06-01 08:49:58 UTC
This works:
emerge -C =gtkhtml-1.1.10-r1
emerge =gtkhtml-1.1.10-r1

Not quite what I like when I emerge -e world, but...
Comment 11 Vladimir G. Ivanovic 2006-06-01 10:04:39 UTC
Since the current version of gtkhtml is 3.10.1, and that installs correctly, is there any reason we shouldn't close this bug?
Comment 12 Arnaud Launay 2006-06-01 10:18:08 UTC
Yes, one: it's unfortunately still in use by gnucash
Comment 13 foser (RETIRED) gentoo-dev 2006-06-02 04:32:08 UTC
so has anyone figured where the .new file comes from (gets generated ?)
Comment 14 Jan Holecek 2006-06-26 05:28:26 UTC
Created attachment 90179 [details, diff]
Patch for 1.1.10-r1 sandbox violation

The sandbox is violated by gtkdoc-fixxref which is executed during installation process on some directory /usr/share... As I understand it it fixes references in files that get replaced by those from the sandbox in the end anyway. It should be run on a directory in the source tree or in the sandbox. That's what my patch does.

I guess the --html-dir argument should better be something else. I do not concern more, though. I have a -r2 in my portage overlay which applies this patch and it works fine.
Comment 15 Martin Wegner 2006-07-04 10:32:12 UTC
Patch from comment #14 WORKSFORME

$ emerge info
Portage 2.1.1_pre1-r5 (default-linux/x86/2006.0, gcc-4.1.1/vanilla, glibc-2.4-r3, 2.6.16-suspend2-r7-mw i686)
System uname: 2.6.16-suspend2-r7-mw i686 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.1
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
dev-lang/python:     2.2.3-r6, 2.3.5, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r2
dev-util/confcache:  0.4.2-r1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: [Not Present]
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
CFLAGS="-march=athlon-xp -O3 -pipe -mmmx -msse -msse2 -m3dnow -ftracer"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon-xp -O3 -pipe -mmmx -msse -msse2 -m3dnow -ftracer"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 3dnow 3dnowext X Xaw3d aac aalib acl alsa apache2 apm audiofile avi bash-completion berkdb bitmap-fonts bonobo browserplugin bzip2 bzlib cdparanoia cdr cli composite crypt crypto_openssl cups curl dba dbus dedicated dga directfb divx4linux doc dri dvd dvdr eds emboss encode escreen exif expat fam fbcon ffmpeg firefox flac foomaticdb ftp gd gdbm gif gimpprint glut gnome gstreamer gtk gtk2 gtkhtml hal i8x0 idn imagemagick imap imlib insecure-savers ipv6 isdnlog jabber java jpeg jpeg2k lcms libcaca libg++ libwww mad mbox mhash mmx mmxext mng mono motif mozdevelop mozilla mozsvg mp3 mpeg mysql nautilus ncurses nls no-htdocs nptl nptlonly nsplugin nvidia offensive ogg oggvorbis openal opengl openssl oscar oss pam pcre pdflib pear perl php png postfix pppd python qt3 qt4 quicktime readline real reflection rtc ruby samba sdl session silverxp slang spell spl sse sse2 ssl stencil-buffer svg svga tcltk tcpd tetex theora tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales vim-with-x visualization vorbis win32codecs wmf xanim xine xml xmms xorg xprint xsl xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux userland_GNU video_cards_nvidia"
Comment 16 Horst Schirmeier 2006-10-25 03:23:36 UTC
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-extra_-_gtkhtml-1.1.10-r1-20601.log"

unlink:    /usr/share/gnome/html/gtkhtml/gtkhtml.html

Patch #90179 (comment #14) works for me, too (thanks, Jan!). Gnome Desktop Team, is this going to find its way into Portage someday?
Comment 17 Saleem Abdulrasool (RETIRED) gentoo-dev 2006-12-26 15:24:20 UTC
This is no longer in the tree, please migrate to gnome-2.x