Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 113709 - xen build fails with unrecognized gcc option
Summary: xen build fails with unrecognized gcc option
Status: RESOLVED DUPLICATE of bug 113639
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-27 07:16 UTC by Ingo Felger
Modified: 2005-11-27 07:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Felger 2005-11-27 07:16:47 UTC
The current XEN package fails to compile on a fresh x86 system (emerge --update
--deep finds nothing to do), the compiler chokes on an unknown -W option, see below.

GCC is 3.3.6 - latest available, says emerge --search


Reproducible: Always
Steps to Reproduce:
1. unmask xen in package.keywords
2. emerge xen


Actual Results:  
SIHX01 src # emerge xen
Calculating dependencies ...done!
>>> emerge (1 of 1) app-emulation/xen-3.0.0_pre20051122 to /
..
make[2]: Entering directory
`/var/tmp/portage/xen-3.0.0_pre20051122/work/xen-unstable-20051122/xen/tools'
gcc -Wall -Werror -Wstrict-prototypes -O2 -fomit-frame-pointer
-Wdeclaration-after-statement -o symbols symbols.c
cc1: error: unrecognized option `-Wdeclaration-after-statement'
make[2]: *** [symbols] Error 1


Expected Results:  
Compile ;)

Portage 2.0.51.22-r3 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2,
2.6.14.3 i686)
=================================================================
System uname: 2.6.14.3 i686 Intel(R) Pentium(R) M processor 1.73GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ "
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 acl acpi apm arts avi berkdb bitmap-fonts bzip2 crypt cups curl eds
emboss encode expat foomaticdb fortran gdbm gif gpm gstreamer gtk2 imlib ipv6
java jpeg ldap libg++ libwww mad mikmod mp3 mpeg ncurses nls ogg oggvorbis
opengl pam pdflib perl png posix python quicktime readline sdl spell ssl sybase
sybase-ct tcpd threads truetype truetype-fonts type1-fonts udev unicode usb
vorbis xml2 xmms xsl xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-11-27 07:19:02 UTC

*** This bug has been marked as a duplicate of 113639 ***