Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 113223 - Bad page rendering with certain themes on amd64. 1.07-1.5-rc3-r1
Summary: Bad page rendering with certain themes on amd64. 1.07-1.5-rc3-r1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
: 113226 (view as bug list)
Depends on:
Reported: 2005-11-21 19:44 UTC by John
Modified: 2006-10-25 08:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description John 2005-11-21 19:44:45 UTC loads as depicted in the screenshot linked to below, however
in Opera which is 32bit renders the page correctly. [The second link.]

The gtk-theme in use with Firefox is called black-knight, and the KDE colour
scheme is called cleanstik-black.  As an aside the same rendering issues occur
with Konqueror 3.4.3.

I tried using mozilla-firefox-bin on my 64bit system and the pages rendered
correctly with no other tweaks by myself.

Reproducible: Always
Steps to Reproduce:
Comment 1 Tres 'RiverRat' Melton 2005-11-21 21:55:06 UTC
*** Bug 113226 has been marked as a duplicate of this bug. ***
Comment 2 Alex Howells (RETIRED) gentoo-dev 2005-11-22 00:11:05 UTC
Not to be rude, but I really don't see how this is a bug with Gentoo.  I think
you'll find it's most likely a problem with the website :-/  May I suggest you
either use a browser that 'just works' or address this problem with them?
Comment 3 Alex Howells (RETIRED) gentoo-dev 2005-11-22 00:17:04 UTC
Assigned to the wrong people, woopsie.

As an aside, can you please supply more information so I can try and reproduce?
Output of emerge --info would be helpful, so I can see what kinda flags you're
using at the moment ... What version is the 32bit Firefox which gives you trouble?  
Comment 4 Jory A. Pratt 2005-11-22 06:36:27 UTC
page renders fine in 1.5rc3 if you feel this is a true problem use your report
broken webpage under help to file a bug with please.
Comment 5 John 2005-11-23 11:11:52 UTC
Jory you have to apply a dark theme like black-knight and be running the 64bit
native version before the problem manifests.  I tried the same thing with Ubuntu
and got the same results as the first screenshot.  The version in use in the
first screenshot happens to be 1.0.7.  On Ubuntu I am also using 1.0.7 64bit
version and the issue persists.  However running 1.0.7 32bit with the same theme
the page loads just like it loads with Opera.  Firefox-1.5rc3 32bit also renders
the page properly when I run it on my laptop which is 32bit and not 64bit
[Ubuntu]  This is not a website issue.  

I reported it here first because I had not had the chance to test it on another
64bit system and I had noticed that when running the 32bit version of the
browser in Gentoo the problem was no longer there.  Now that I know the same
issue occurs on another 64bit OS I will go ahead and report it upstream.

Here is my emerge info anyway:

Portage 2.0.53_rc7 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r3,
2.6.13-gentoo-r4 x86_64)
System uname: 2.6.13-gentoo-r4 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.0_pre10
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20-r1
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe"
FEATURES="PORT_LOGDIR autoconfig ccache distlocks sandbox sfperms strict"
PORTDIR_OVERLAY="/usr/local/fluidportage/trunk /usr/local/portage"
USE="amd64 X a52 aac aalib alsa audiofile avi bash-completion berkdb
bitmap-fonts bonobo bzip2 ccache cdr crypt cups curl directfb dts dvd dvdr
dvdread eds emboss encode esd exif expat fam ffmpeg flac foomaticdb fortran
freetype gdbm gif glut gpm gstreamer gtk gtk2 hal howl idn imagemagick imlib
ipv6 java jpeg kde kdeenablefinal lcms lzw lzw-tiff mad matroska mng motif
mozilla mp3 mpeg ncurses nls nptl nptlonly ogg opengl pam pcre pdflib perl pic
png postgres python qt quicktime readline ruby sdl spell sqlite ssl svg tcpd
theora tiff truetype truetype-fonts type1-fonts udev usb userlocales vorbis xine
xml xml2 xpm xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Comment 6 Jory A. Pratt 2005-11-23 11:17:55 UTC
Now that you have clarified I will dig alot deeper into the problem. Please CC
me on the mozilla bug you open, or I can open it if you do not.
Comment 7 Jory A. Pratt 2005-11-23 11:23:50 UTC
Add'ng respective archs and herd so all can follow.
Comment 8 Simon Stelling (RETIRED) gentoo-dev 2006-08-25 07:28:18 UTC
This looks like a candidate for UPSTREAM to me. Anybody disagree?
Comment 9 John 2006-08-25 13:11:02 UTC
The relevant mozilla bug number is [url=]317601[/url]
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-10-25 08:02:26 UTC
(In reply to comment #8)
> This looks like a candidate for UPSTREAM to me. Anybody disagree?

Doesn't look like anyone's opposed -> UPSTREAM.