Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 112875 - dev-ruby/radrails (new ebuild)
Summary: dev-ruby/radrails (new ebuild)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Highest enhancement (vote)
Assignee: Default Assignee for New Packages
Keywords: EBUILD
Depends on:
Reported: 2005-11-17 21:32 UTC by Roman Le Négrate
Modified: 2006-12-19 16:07 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---

dev-util/radrails-bin ebuild (radrails-bin-0.6.1.ebuild,614 bytes, text/plain)
2006-03-29 14:44 UTC, gutter
radrails startup file (radrails,34 bytes, text/plain)
2006-03-29 14:44 UTC, gutter

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Le Négrate 2005-11-17 21:32:44 UTC
It would be nice to see a fastly growing RubyOnRails IDE: RadRails in the
portage tree :-).
Thank you.
Comment 1 James Laver 2006-03-08 13:51:30 UTC
Not that i'm against making an ebuild for this, but have you tried RDT for eclipse?

Radrails is based on it, after all
Comment 2 Alexandru Toma 2006-03-08 14:33:23 UTC
RadRails is not based on RDT. Rather, it _integrates_ it... there's a difference. I don't think RDT would be suited for Rails development. It is aimed primarily at Ruby development since it is, after all, a Ruby IDE (not a Rails IDE).

Anyway... I don't think there's a RDT ebuild in portage either.
Comment 3 James Laver 2006-03-08 15:22:00 UTC
My point with that was that eclipse IS in the portage tree, and going from there to getting RDT working is a snap, with the eclipse update manager.

Getting any other eclipse plugin working might be a different matter, but RDT went flawless here. (/me makes a mental note to stop trying to install C++ dev tool for eclipse)

I'll look into creating an ebuild for it. It was fairly easy to install though. i just 
tar -zxvf radrails*.tar.gz /opt
echo "/opt/radrails/radrails" > /usr/bin/radrails
chmod 755 /usr/bin/radrails

I couldn't get a symlink to work in there for some unknown reason, *shrug*

I'll look at putting together an ebuild for it.
Comment 4 Alexandru Toma 2006-03-08 16:03:37 UTC
That would be great. I would have tried to write an ebuild myself sooner or later but at the moment I really don't have the time.
Comment 5 gutter 2006-03-29 13:01:25 UTC
(In reply to comment #2)
> Anyway... I don't think there's a RDT ebuild in portage either.

I just created one, see bug: 127847
Comment 6 gutter 2006-03-29 14:44:21 UTC
Created attachment 83400 [details]
dev-util/radrails-bin ebuild
Comment 7 gutter 2006-03-29 14:44:54 UTC
Created attachment 83401 [details]
radrails startup file
Comment 8 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2006-10-06 03:29:13 UTC
Maybe java herd has interested in this
Comment 9 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2006-10-07 04:13:09 UTC
Well, -bin ebuilds are against our java packaging policy...
Comment 10 gutter 2006-10-07 04:32:38 UTC
(In reply to comment #9)
> Well, -bin ebuilds are against our java packaging policy...

Ok, so i think the bug could be closed.
Comment 11 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2006-10-07 12:42:49 UTC
Not possible to make a source-based ebuild?
Comment 12 gutter 2006-10-07 13:17:48 UTC
(In reply to comment #11)
> Not possible to make a source-based ebuild?

The source code is available only by CVS.

I can try to make a CVS ebuild. 

Do you think can be useful?
Comment 13 James Laver 2006-10-08 23:40:15 UTC
A -bin ebuild is going to be ridiculous and highly un-gentoo, so essentially the best thing to do would be to make the CVS ebuild. I'm not on a gentoo right now so I don't have my kit setup to write an ebuild ( not even the vim template :( ), but I'll be happy to test one when i've put together a gentoo on the new baselayout.
Comment 14 James Laver 2006-12-05 06:32:52 UTC
Call it necromancy of a very old bug, but I was contacted earlier today by someone asking me to write an ebuild for this.

However, when I went to the radrails site to check out source, I noticed that it's now updateable through the eclipse update manager:

Add RDT and RadRails to the update manager and select both, then proceed and install.

    * RDT:
    * RadRails:
    * Subclipse (optional):

If there's still demand I could work on a cvs ebuild but otherwise, it's already installable if you have eclipse.
Comment 15 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2006-12-19 16:07:36 UTC
No response so far so I assume people are happy with eclipse update manager. Please reopen if you think otherwise.