Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 111833 - Xorg lockup using a dual-head or Twinview configuration with TV-Out and a single GeForce 4 Ti4200 board
Summary: Xorg lockup using a dual-head or Twinview configuration with TV-Out and a sin...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: X11 External Driver Maintainers
Depends on:
Reported: 2005-11-07 18:03 UTC by Pascal Emond
Modified: 2007-03-03 18:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Copy of the Xorg.conf used (xorg.conf.copy,10.90 KB, text/plain)
2005-11-07 18:04 UTC, Pascal Emond
Output of the lspci command (lspci.output,1.15 KB, text/plain)
2005-11-07 18:05 UTC, Pascal Emond

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal Emond 2005-11-07 18:03:57 UTC
When using a dual-head or twinview configuration on a single GeForce 4 Ti4200
board, X11 starts up properly and no error messages are given; both the main CRT
and TV function properly as independent displays. However, VT-Switching, manual
restart of X (CTRL+ALT+BS), or ending a GNOME session always result in a blank
screen on both displays, complete lockup of all input. Only a hard reset on the
computer works.

Reproducible: Always
Steps to Reproduce:
1. Use the latest stable packages for xorg-x11, gentoo-sources, nvidia-kernel
and nvidia-glx
2. Configure Xorg to use either a TwinView configuration or two separate
displays, one of which uses TV-Out.
3. Once X has successfully displayed a login screen, change to virtual console,
use CTRL+ALT+Backspace or exit a GNOME session (after logging in).

Actual Results:  
Complete lockup of system. Only a hard reset makes it usable again.

Expected Results:  
Either shut down properly, display the proper virtual console or exit cleanly of
the current gnome environment.

Using the following ebuild versions: xorg-x11-6.8.2-r4,
gentoo-sources-2.6.13-r5, nvidia-kernel-1.0.6629-r6, nvidia-glx-1.0.6629-r4.
Also happens with latest unstable nvidia-kernel and nvidia-glx versions.
Disabling any framebuffer support, switching from kernel AGPGART to internal
NV-AGP have also been tried to no avail. This issue only seems to appear on
GeForce 4 Ti4200 boards, though some other GeForce 4 variants may be affected.
From information found online, this may be a new issue related to newer linux
kernels and/or nvidia modules. Board is ASUS make, not sure exact name. Uses
GeForce 4 Ti4200 chipset, 128 Mb RAM.
Comment 1 Pascal Emond 2005-11-07 18:04:35 UTC
Created attachment 72419 [details]
Copy of the Xorg.conf used
Comment 2 Pascal Emond 2005-11-07 18:05:33 UTC
Created attachment 72420 [details]
Output of the lspci command

As this may be AGP-related, a readout of lspci is attached.
Comment 3 Joshua Baergen (RETIRED) gentoo-dev 2005-11-08 10:52:44 UTC
Has this ever worked for you?
Comment 4 Pascal Emond 2005-11-12 08:26:39 UTC
(In reply to comment #3)
> Has this ever worked for you?

Well, I've installed Gentoo only recently, so I've had the problem since day
one, yes. The only thing I can say is that I used SuSE 8.0 Professional a few
years ago and never had X crash using TwinView. Then again, it was under XFree86
and a 2.4 kernel, but I *was* using the official closed nVidia drivers. Which is
to say, the card isn't defective, and TV-Out works perfectly under Windows 2000
with the nVidia drivers.
Comment 5 Marijn Schouten (RETIRED) gentoo-dev 2007-03-03 18:39:42 UTC
xorg-x11-7.1 is the oldest in the tree atm.