Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 111441 - x11-terms/eterm-0.9.3-r4 won't start
Summary: x11-terms/eterm-0.9.3-r4 won't start
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: SpanKY
: 111443 (view as bug list)
Depends on:
Reported: 2005-11-03 21:23 UTC by jreed
Modified: 2006-06-11 09:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description jreed 2005-11-03 21:23:06 UTC
Using my home ~x86 Athlon-XP box, I've tried to emerge Eterm with little
success. Have a look at the details.

Reproducible: Always
Steps to Reproduce:
1. emerge eterm
2. From a console, Eterm <ENTER>

Actual Results:  
Eterm receives a terminal signal and fails to start.

Eterm --debug 4 >& log

[1131081727]     pixmap.c | 1386: search_path(): Checking for file
[1131081727]     pixmap.c | 1399: search_path(): Unable to access
/home/jeff/.Eterm/pix/bar_horizontal_1.png -- No such file or directory
[1131081727]     pixmap.c | 1386: search_path(): Checking for file
[1131081727]     pixmap.c | 1391: search_path(): Stat returned mode 0x00100644,
S_ISDIR() == 0
[1131081727]     pixmap.c |  439: reset_simage(): reset_simage(0x805a298,
[1131081727]     pixmap.c | 1439: load_image(): Found image 0x80592c0.
[1131081727]       conf.c |  870: spifconf_parse_line(): Parsing line #236 of
file theme.cfg
[1131081727]     pixmap.c |  261: set_pixmap_scale(): scale_pixmap("100")
[1131081727]     pixmap.c |  342: set_pixmap_scale(): Returning 4, *pmap == { op
[0], w [100], h [100], x [50], y [50] }
[1131081727]       conf.c |  870: spifconf_parse_line(): Parsing line #237 of
file theme.cfg
[1131081727]       conf.c |  870: spifconf_parse_line(): Parsing line #238 of
file theme.cfg
[1131081727]       conf.c |  870: spifconf_parse_line(): Parsing line #239 of
file theme.cfg
[1131081727]       conf.c |  870: spifconf_parse_line(): Parsing line #240 of
file theme.cfg
Eterm:  Error:  Received terminal signal SIGILL (4)
[1131081727]    command.c |  200: privileges(): [21280]: Before
privileges(REVERT): [ 1000, 100 ]  [ 1000, 100 ]
[1131081727]    command.c |  220: privileges(): [21280]: After
privileges(REVERT): [ 1000, 100 ]  [ 1000, 100 ]
Eterm:  Error:  Attempting to dump a stack trace....

Expected Results:  
Eterm should open a new terminal window.

Portage 2.0.53_rc7 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r3,
2.6.14-gentoo i686)
System uname: 2.6.14-gentoo i686 AMD Athlon(tm) XP 2100+
Gentoo Base System version 1.12.0_pre9
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=athlon-xp"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
USE="X aac aim alsa apm arts avi bash-completion berkdb bitmap-fonts bzip2
calendar cdr crypt cups curl divx4linux dvd dvdr dvdread emacs emboss encode
flac foomaticdb fortran ftp gd gdbm ggi gif gnutls gpm gtk gtk2 hal icq
imagemagick imap imlib ipv6 jabber jack java javascript joystick jpeg kde
kerberos krb4 ldap libg++ libwww mad mikmod mime mmx motif mozilla mp3 mpeg msn
ncurses nls nsplugin nvidia ogg oggvorbis opengl oscar pam pdflib perl php png
posix ppds python qt quicktime readline ruby sasl scanner sdl simplexml slp sox
spell sse ssl svg symlink tcltk tcpd tiff truetype truetype-fonts type1-fonts
udev unicode usb v4l vcd vorbis wifi win32codecs x86 xine xml xml2 xmms xpm xv
yahoo zlib userland_GNU kernel_linux elibc_glibc"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-11-04 00:35:27 UTC
*** Bug 111443 has been marked as a duplicate of this bug. ***
Comment 2 SpanKY gentoo-dev 2005-11-04 06:13:38 UTC
do you have some theme file in place ?  `rm -r ~/.Eterm` and try again

are you using modular X ?
Comment 3 SpanKY gentoo-dev 2006-06-11 08:09:03 UTC
get back to me
Comment 4 Jeff 2006-06-11 09:55:28 UTC
(In reply to comment #3)
> get back to me

This thread is old news - sorry I haven't touched it in a while. I originally filed this under my old email/alias. I don't know that I would mark it 'resolved' since I'm still not 100% what caused this. Eterm has worked fine for me since then.