Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 110583 - New Package: dev-perl/asterisk-perl
Summary: New Package: dev-perl/asterisk-perl
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://packages.gentoo.org/packages/?...
Whiteboard:
Keywords: EBUILD, InVCS
: 132640 153530 (view as bug list)
Depends on:
Blocks: 129966
  Show dependency tree
 
Reported: 2005-10-26 16:31 UTC by Jorge Cisneros
Modified: 2012-11-01 23:11 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for asterisk-perl-0.09 (asterisk-perl-0.09.ebuild,818 bytes, text/plain)
2006-09-28 18:46 UTC, Wade Fitzpatrick
Details
slightly different ebuild for asterisk-perl-0.09 (asterisk-perl-0.09.ebuild,848 bytes, text/plain)
2006-10-31 03:33 UTC, Vieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Cisneros 2005-10-26 16:31:03 UTC
In the new rsycn, the ebuild for asterisk-perl do not exist, this component is
basic for asterisk.

Reproducible: Always
Steps to Reproduce:

1.- emerge -vp asterisk-perl


Actual Results:  
Calculating dependencies
emerge: there are no ebuilds to satisfy "asterisk-perl".

Expected Results:  
emerge -vp asterisk-perl

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] dev-perl/asterisk-perl-0.08  0 kB
Comment 1 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-10-26 17:25:57 UTC
http://www.gentoo.org/cgi-bin/viewcvs.cgi/dev-perl/asterisk-perl/asterisk-perl-
0.08.ebuild?rev=1.4&view=log
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-04-05 02:01:54 UTC
http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-perl/asterisk-perl/?hideattic=0

Removed due to licensing issues.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-05-07 21:44:20 UTC
*** Bug 132640 has been marked as a duplicate of this bug. ***
Comment 4 Wade Fitzpatrick 2006-09-28 18:46:45 UTC
Created attachment 98351 [details]
ebuild for asterisk-perl-0.09

asterisk-perl-0.09 now includes the perl "Artistic License"

Can somebody add this ebuild back into portage please?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-10-31 03:06:34 UTC
*** Bug 153530 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-10-31 03:09:13 UTC
Reopening now...
Comment 7 Vieri 2006-10-31 03:33:37 UTC
Created attachment 100870 [details]
slightly different ebuild for asterisk-perl-0.09

The built_with_use condition must be re-adapted to the latest perl ebuild.

I'm suggesting another ebuild but I'm sure someone can do better.
Comment 8 Vieri 2008-05-10 09:33:51 UTC
asterisk-perl-0.10 is out.
Only requires renaming the ebuild.
Comment 9 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-05-17 21:43:08 UTC
Vieri, if you are still interested in this package, think about add it to the sunrise overlay [1]. Otherwise, I can proxy you to the voip overlay.

[1] http://overlays.gentoo.org/proj/sunrise

Anyway, it's not a voip bug, so re-assigning it to maintainer-wanted.
Comment 10 Tony Vroon gentoo-dev 2012-09-11 12:07:59 UTC
Whilst I would like to action this (better late than never), the homepage for Asterisk-PERL on http://asterisk.gnuinter.net/ is not loading at all. The underlying domain name of mrplow.gnuinternet.com has expired and is pending deletion.
I do apologise, but without a new homepage location it does not look like this is going to go anywhere. As such, I am closing this bug now. Please do reopen it if you have a new upstream location to report.
Comment 11 James Cloos 2012-11-01 18:17:50 UTC
asterisk-perl-1.03.tar.gz is available in CPAN at:

  http://search.cpan.org/CPAN/authors/id/J/JA/JAMESGOL/asterisk-perl-1.03.tar.gz

The associated readme still points at http://asterisk.gnuinter.net, but you can always use http://search.cpan.org/~jamesgol/ as the HOMEPAGE.

Please re-open.
Comment 12 Tony Vroon gentoo-dev 2012-11-01 18:31:10 UTC
That is still full of the same dead links I pointed out earlier. No, I will not add abandoned software to the portage tree.
Comment 13 James Cloos 2012-11-01 19:08:55 UTC
If you call that abandoned then you are not reading what I posted.

Just use:

HOMEPAGE="http://search.cpan.org/~jamesgol/"
SRC_URI="http://search.cpan.org/CPAN/authors/id/J/JA/JAMESGOL/${P}.tar.gz"

and be done with it.

It will always be up to date.
Comment 14 Tony Vroon gentoo-dev 2012-11-01 23:11:15 UTC
I read it, followed the link, saw the very same dead upstream domain advertised for author contact & homepage, and decided it was no improvement. Abandoned software will not be packaged.