Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 110299 - EXA support for xf86-video-i810
Summary: EXA support for xf86-video-i810
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2005-10-24 01:15 UTC by Søren Færløv
Modified: 2006-08-20 03:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Søren Færløv 2005-10-24 01:15:18 UTC
There's an experimental/unstable/unsupported/whatever patch that adds EXA
support to the i810 driver for mudular Xorg.

Could this perhaps be added as a USE flag option?

Reproducible: Always
Steps to Reproduce:
1. Emerge xorg-server on a system with an Intel graphics chip
2. Enable EXA
3. Start Xorg
4. Check /var/log/Xorg.log
Actual Results:  
Xorg complains about lacking EXA support in the i810 driver.

Expected Results:  
Run without problems with the EXA extension.

Portage (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r2,
2.6.13-gentoo-r3 i686)
System uname: 2.6.13-gentoo-r3 i686 Intel(R) Pentium(R) M processor 1400MHz
Gentoo Base System version 1.12.0_pre9
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-Os -march=pentium-m -mtune=pentium-m -pipe -fomit-frame-pointer
-fforce-addr -ftracer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium-m -mtune=pentium-m -pipe -fomit-frame-pointer
-fforce-addr -ftracer -fvisibility-inlines-hidden"
FEATURES="autoconfig distlocks fixpackages sandbox sfperms strict"
USE="x86 # 16bit 7.0 For X Xorg a52 aac acl acpi acpi4linux alsa apm avi
bash-completion berkdb bitmap-fonts bluetooth cdr chroot codecs crypt cups curl
directfb dri dv dvd dvdread eds emacs emboss encode esd evo fam fbcon fbdev flac
foomaticdb freetype gb gd gdbm gif gimpprint glitz glut glx gnome gphoto2 gpm
gstreamer gtk gtk2 hal i8x0 imagemagick imlib ipv6 irda irmc jabber java
javascript jp2 jpeg kde kdeenablefinal ladcca libg++ libwww ltsp mad mailbox
maildir mbox mikmod mime mmx motif mozcalendar mozctl mozilla mozsvg mp3 mpeg
mpi mppe-mppc mysql mysqli ncurses nls no-old-linux nocd nptl oav ogg oggvorbis
openal opengl oss pam pcmcia pda pdflib perl png pnp ppds pthreads python qt
quicktime readline real rtc samba sdk sdl slang sms snmp speedo spell sse sse2
ssl svg svga sysvipc tcltk tcpd tiff truetype truetype-fonts trusted type1
type1-fonts udev unicode usb v4l2 videos vorbis wifi xanim xine xinerama xml
xml2 xmms xosd xpm xv xvid xvmc yv12 zlib video_cards_i810
input_devices_keyboard input_devices_mouse userland_GNU kernel_linux elibc_glibc"
Comment 1 Søren Færløv 2005-10-24 01:21:26 UTC
Forgot to add link to the patch, so here it is:

Inspecting the patch it appears that the ebuild for xorg-server will require
changes too.
Comment 2 Joshua Baergen (RETIRED) gentoo-dev 2005-10-24 16:00:45 UTC
I won't add it for two reasons:

1) As a rule, patches are not added until they're in CVS upstream.  This will
not be added till after the 7.0 release.
2) The patch is broken.  The author ignored DRI functionality (he said so) and
it shows.  I tried it today and EXA support caused massive GL baddage.

However, if you're still interested in trying it I have a badly hacked together
ebuild and modified patch.  Let me know and I'll upload it for you.
Comment 3 Søren Færløv 2005-10-24 23:16:11 UTC
Thanks for your time spend researching this feature. :-)

I tried modifying the patch and put together an ebuild myself, but the result
was disastrous (black screen and nothing else...).

I fully understand and respect your decision, given the state of the patch.

I'd love to try out your ebuild, that's what overlays are for, right? ;-)
Comment 4 Joshua Baergen (RETIRED) gentoo-dev 2005-10-25 10:26:50 UTC

Like I said, it's badly put together ;)
Comment 5 Søren Færløv 2005-10-26 01:07:11 UTC
Thanks anyway :-)

As you said OpenGL causes major baddage. In my case it crashed Xorg :-(

Compiling with USE="-dri" failed.

Hopefully the Xorg folks will add this feature soon, as the promised speed
increase would be very welcome.