Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 110190 - app-editors/diakonos ebuild (New Package)
Summary: app-editors/diakonos ebuild (New Package)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 15 votes (vote)
Assignee: Default Assignee for New Packages
URL: http://diakonos.pist0s.ca/
Whiteboard: [sunrise overlay]
Keywords: EBUILD, InOverlay
: 111980 185835 (view as bug list)
Depends on:
Blocks: 185835
  Show dependency tree
 
Reported: 2005-10-22 21:56 UTC by Pistos
Modified: 2013-08-14 08:54 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
diakonos-0.7.7.ebuild (New Package) (diakonos-0.7.7.ebuild,454 bytes, text/plain)
2005-10-22 21:59 UTC, Pistos
Details
ChangeLog for diakonos-0.7.7.ebuild (New Package) (ChangeLog,312 bytes, text/plain)
2005-10-22 22:01 UTC, Pistos
Details
metadata.xml for diakonos-0.7.7.ebuild (New Package) (metadata.xml,695 bytes, text/plain)
2005-10-22 22:01 UTC, Pistos
Details
diakonos-0.7.8.ebuild (New Package) (diakonos-0.7.8.ebuild,454 bytes, text/plain)
2005-11-09 10:12 UTC, Pistos
Details
ChangeLog for diakonos-0.7.8.ebuild (New Package) (ChangeLog,440 bytes, text/plain)
2005-11-09 10:12 UTC, Pistos
Details
metadata.xml for diakonos-0.7.8.ebuild (New Package) (metadata.xml,732 bytes, text/plain)
2005-11-09 10:12 UTC, Pistos
Details
diakonos-0.8.3.ebuild (diakonos-0.8.3.ebuild,396 bytes, text/plain)
2007-02-26 14:43 UTC, Pistos
Details
Ebuild for Diakonos version 0.8.3. (diakonos-0.8.3.ebuild,345 bytes, text/plain)
2007-08-09 19:03 UTC, Pistos
Details
app-editors/diakonos-0.8.6 (diakonos-0.8.6.ebuild,350 bytes, text/plain)
2008-11-15 15:33 UTC, Sergio D. Rodríguez Inclan
Details
app-editors/diakonos-0.8.6 (diakonos-0.8.6.ebuild,300 bytes, text/plain)
2008-11-15 16:07 UTC, Sergio D. Rodríguez Inclan
Details
ebuild for Diakonos 0.8.11 (diakonos-0.8.11.ebuild,487 bytes, text/plain)
2009-07-24 14:29 UTC, Pistos
Details
Ebuild for app-editors/diakonos-0.8.12 (diakonos-0.8.12.ebuild,474 bytes, text/plain)
2010-01-22 23:21 UTC, Andreas K. Hüttel
Details
updated ebuild with the new author's domain. emerges and builds. (diakonos-0.9.1.ebuild,445 bytes, text/plain)
2013-06-28 09:20 UTC, David Turenne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pistos 2005-10-22 21:56:51 UTC
Hello.

Please find a first ebuild for Diakonos at http://purepistos.net/diakonos/
diakonos-0.7.7.ebuild.tar.gz .  It contains the ebuild, the Changelog and the 
metadata.xml files.  These three files are also attached to this bug.

Diakonos is a customizable, usable console-based text editor.  It features 
bookmarking, regular expression searching, parsed ("smart") indentation, macro 
recording and playback, a multi-element clipboard, multi-level undo, a 
customizable status line, completely customizable keyboard mapping, and 
customizable syntax highlighting.

Home page:      http://purepistos.net/diakonos
Freshmeat page: http://freshmeat.net/projects/diakonos/

Pistos
Comment 1 Pistos 2005-10-22 21:59:08 UTC
Created attachment 71239 [details]
diakonos-0.7.7.ebuild (New Package)
Comment 2 Pistos 2005-10-22 22:01:45 UTC
Created attachment 71240 [details]
ChangeLog for diakonos-0.7.7.ebuild (New Package)
Comment 3 Pistos 2005-10-22 22:01:59 UTC
Created attachment 71241 [details]
metadata.xml for diakonos-0.7.7.ebuild (New Package)
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-11-09 10:03:12 UTC
*** Bug 111980 has been marked as a duplicate of this bug. ***
Comment 5 Pistos 2005-11-09 10:10:13 UTC
Sorry, didn't know I had to submit version increases in the same bug...
Comment 6 Pistos 2005-11-09 10:12:03 UTC
Created attachment 72505 [details]
diakonos-0.7.8.ebuild (New Package)
Comment 7 Pistos 2005-11-09 10:12:22 UTC
Created attachment 72506 [details]
ChangeLog for diakonos-0.7.8.ebuild (New Package)
Comment 8 Pistos 2005-11-09 10:12:39 UTC
Created attachment 72507 [details]
metadata.xml for diakonos-0.7.8.ebuild (New Package)
Comment 9 Pistos 2005-12-19 07:54:24 UTC
Diakonos version 0.7.9 released.  The submitted ebuild code should work for this release as well.
Comment 10 Pistos 2006-03-07 07:39:41 UTC
Diakonos version 0.8.0 released.  The submitted ebuild code should work for
this release as well.
Comment 11 Pistos 2006-03-24 08:18:42 UTC
Heidi ho!  Just wondering what privileged pool of carbon-based lifeforms gets to be package maintainers, and what are the membership criterion for said pool?  :)I am the author for this software, and I have been diligest to release a new ebuild for every release of the package, and would be more than happy to maintain this ebuild (which I already seem to be doing, except not in any official capacity).
Comment 12 Pistos 2006-08-14 07:51:18 UTC
0.8.1 and 0.8.2 released.
Comment 13 Pistos 2007-02-26 14:40:55 UTC
0.8.3 released.
Comment 14 Pistos 2007-02-26 14:43:51 UTC
Created attachment 111301 [details]
diakonos-0.8.3.ebuild

This is a new ebuild which works for 0.8.3.  The previous ebuilds will not work for 0.8.3+, and this new ebuild will not work for versions <=0.8.2.
Comment 15 Fabian Groffen gentoo-dev 2007-08-09 16:53:38 UTC
@pistos: please remove the commented out SRC_URI from your ebuild.

@ruby herd: interested in adding this package to the tree?
Comment 16 Pistos 2007-08-09 19:03:42 UTC
Created attachment 127380 [details]
Ebuild for Diakonos version 0.8.3.

Removed commented out SRC_URI.
Comment 17 Sergio D. Rodríguez Inclan 2008-11-15 15:33:33 UTC
Created attachment 171872 [details]
app-editors/diakonos-0.8.6

New version, it works with ruby18 but not with ruby19 yet. Thanks to Pistos.
Comment 18 Pistos 2008-11-15 15:59:21 UTC
(In reply to comment #17)
> New version, it works with ruby18 but not with ruby19 yet. Thanks to Pistos.

FWIW, I have a git branch that seems to function with Ruby 1.9.1.  There are no known problems with that branch on 1.9.

Anyway, thanks for updating this bug thread; I pretty much gave up hope on it, heh.  :)  Happy birthday, bug!  You're more than three years old now!  :)
Comment 19 Sergio D. Rodríguez Inclan 2008-11-15 16:07:20 UTC
Created attachment 171874 [details]
app-editors/diakonos-0.8.6

Removed the URL, using the eclass functionality.
Comment 20 Michael Haubenwallner gentoo-dev 2009-07-06 08:06:58 UTC
*** Bug 185835 has been marked as a duplicate of this bug. ***
Comment 21 Daniel Robbins 2009-07-24 03:01:38 UTC
I've added this ebuild to the funtoo portage tree in this commit:

http://github.com/funtoo/portage/commit/cdcdaf374095e3e665706fef158ffc552261a51f

Only took 3 years, 9 months and 1 day :/
Comment 22 Pistos 2009-07-24 14:29:16 UTC
Created attachment 198983 [details]
ebuild for Diakonos 0.8.11
Comment 23 Pistos 2009-11-04 15:29:00 UTC
Happy birthday, bug 110190!  You are 4 years old now.  I have loved you like my own flesh and blood.  It is my wish that you come to an end before your fifth birthday, but even if that doesn't happen, I will continue to love you.  You make me proud to be a father!  *sniff*
Comment 24 Andreas K. Hüttel gentoo-dev 2010-01-22 23:21:46 UTC
Created attachment 217192 [details]
Ebuild for app-editors/diakonos-0.8.12

Untested version bump (dev-lang/ruby-1.9 is still package.masked).
Comment 25 Andreas K. Hüttel gentoo-dev 2010-04-07 23:27:54 UTC
This is now in the sunrise overlay. You will find it soon at:
http://overlays.gentoo.org/proj/sunrise/browser/reviewed/app-editors/diakonos

Comment 26 Samuli Suominen gentoo-dev 2010-04-08 11:47:17 UTC
I'm fairly certain this should be using the ruby-ng.eclass for depends and install...
Comment 27 Andreas K. Hüttel gentoo-dev 2010-04-08 13:34:25 UTC
(In reply to comment #26)
> I'm fairly certain this should be using the ruby-ng.eclass for depends and
> install...
> 

Me too, and the ebuild in sunrise actually does do just that... :o)
Comment 28 Manuel Rüger gentoo-dev 2012-07-19 19:56:05 UTC
Latest: 0.9.0 (August 6, 2011) 

Changed its homepage to: http://diakonos.pist0s.ca/
Comment 29 David Turenne 2013-06-28 09:20:35 UTC
Created attachment 352146 [details]
updated ebuild with the new author's domain. emerges and builds.

I updated the Ebuild with the new diakonos version, in addition of fixing the url of the tarball.
Comment 30 Manuel Rüger gentoo-dev 2013-08-14 08:54:23 UTC
*diakonos-0.9.1 (14 Aug 2013)

  14 Aug 2013; Manuel Rüger <mrueg@gentoo.org> +diakonos-0.9.1.ebuild,
  +metadata.xml:
  Initial version. Fixes bug #110190


Added to satisfy the huge demand (17 votes)