Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 109120 - Emerge world hangs just before source unpacking
Summary: Emerge world hangs just before source unpacking
Status: VERIFIED NEEDINFO
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: x86 Linux
: Highest critical (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-13 04:58 UTC by Pierre Lejeune
Modified: 2007-01-11 11:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Debug output of emerge -uDNd world (debug_world,906.31 KB, text/plain)
2005-10-13 08:18 UTC, Pierre Lejeune
Details
Compressed output of strace emerge -uDN world (strace_log.bz2,685.68 KB, application/octet-stream)
2005-10-18 01:55 UTC, Pierre Lejeune
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Lejeune 2005-10-13 04:58:02 UTC
When I do an emerge world, emerge hangs just before the source unpacking. I 
can do a normal emerge. I tried to downgrade portage, to reemerge ccache, to 
run python-updater, ... but nothing has helped.

Reproducible: Always
Steps to Reproduce:
1.emerge (-uDavN) world
2.
3.

Actual Results:  
Hanging of emerge world

Expected Results:  
Emerge world succesfull

Portage 2.0.51.22-r3 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 
2.6.13-gentoo-r3 i686)
=================================================================
System uname: 2.6.13-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.12.0_pre9
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium4 -mtune=pentium4 -pipe -falign-functions=4 -
fprefetch-loop-arrays -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/shar
e/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/li
b/mozilla/defaults/pref /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -mtune=pentium4 -pipe -falign-functions=4 -
fprefetch-loop-arrays -fomit-frame-pointer -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks prelink sfperms strict"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ 
http://ftp.gentoo.skynet.be/pub/gentoo/ ftp://mir.zyrianes.net/gentoo/ 
http://mir.zyrianes.net/gentoo/ http://pandemonium.tiscali.de/pub/gentoo/ 
http://distro.ibiblio.org/pub/linux/distributions/gentoo/ 
ftp://ftp.proxad.net/mirrors/ftp.gentoo.org/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/steev-portage /usr/local/steev-gnome-
portage /usr/local/overlays/bmg-main.alternative /usr/local/zugaina-
zsync /usr/local/overlays/bmg-gnome-current.alternative /usr/local/stuart-php-
portage /usr/local/kde-live-portage /usr/local/bmg-portage /usr/local/kde-live-
playground-portage /usr/local/gentoode-portage /usr/local/fluid-
portage /usr/local/gentopia-portage /usr/local/xwing-
portage /usr/local/portage"
SYNC="rsync://rsync.belnet.be/gentoo-portage"
USE="x86 X Xaw3d a52 aac acl acpi alsa ao apache2 arts avi bash-completion 
berkdb bitmap-fonts bzip2 cdparanoia cdr crypt ctype cups curl dba dbus dga 
dvb dvd dvdr dvdread eds emboss encode esd fam fb fbcon ffmpeg firefox flac 
flash foomaticdb fortran ftp gd gdbm gif glut gnome gphoto2 gpm gstreamer gtk 
gtk2 guile hal howl iconv icq imagemagick imlib ipv6 jack java javascript 
joystick jpeg junit kde kdexdeltas lcms ldap libg++ libwww lm_sensors mad 
matroska mikmod mime mmx motif mozilla mp3 mpeg msn mysql ncurses nls nptl 
nsplugin ogg oggvorbis opengl oss pam pcre pdflib perl php pic png ppds python 
qt quicktime readline samba sasl scanner sdl session snmp spell sse ssl svg 
tcltk tcpd tiff truetype truetype-fonts type1-fonts unicode usb v4l videos 
vorbis win32codecs wmf wxwindows xine xml xml2 xmms xpm xprint xsl xv xvid 
yahoo zlib video_cards_i810 linguas_fr userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS
Comment 1 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-10-13 05:13:09 UTC
Mind running with --debug, and posting the output, either in-line or as an 
attachment if the output is large?
Comment 2 Pierre Lejeune 2005-10-13 08:18:31 UTC
Created attachment 70566 [details]
Debug output of emerge -uDNd world
Comment 3 Brian Harring (RETIRED) gentoo-dev 2005-10-13 10:57:06 UTC
Try disabling sandbox, if it continues, strace it please (and attach the log)
Comment 4 Pierre Lejeune 2005-10-13 12:14:22 UTC
(In reply to comment #3)
> Try disabling sandbox, if it continues, strace it please (and attach the log)

Sandbox already disabled. The strace log size is 32 MB so I can't upload it. You
can find it here : http://superheron.no-ip.org/strace_log from (about) 9h to 22h
(Belgian Time).
Comment 5 Zac Medico gentoo-dev 2005-10-17 20:32:23 UTC
(In reply to comment #0)
> The strace log size is 32 MB so I can't upload it.

Can you do "tail -n 1000 strace_log > strace_log_last_1000" and attach the last
1000 lines?  Also, it would be better if you compressed the 32 MB log with bzip2
to make the download smaller (you were offline when I tried to grab it).
Comment 6 Pierre Lejeune 2005-10-18 01:55:39 UTC
Created attachment 70914 [details]
Compressed output of strace emerge -uDN world
Comment 7 Pierre Lejeune 2005-10-18 01:57:07 UTC
Comment on attachment 70914 [details]
Compressed output of strace emerge -uDN world

Here is the compressed strace_log (original size is 32MB)
Comment 8 Pierre Lejeune 2005-11-06 07:08:15 UTC
Upgrade to portage-2.0.53-rc7. Nothing has changed. When emerge have something
to do with the world file (emerge (-uDN) world, emerge --depclean, ... not
fetch), it hangs. Emerging "separately" works.
Comment 9 Jason Stubbs (RETIRED) gentoo-dev 2005-11-06 07:35:52 UTC
Does disabling PORT_LOGDIR help at all? It shouldn't, but might. 
Comment 10 Pierre Lejeune 2005-11-06 08:14:46 UTC
Commenting out PORTLOG_DIR makes portage to work
Comment 11 Marius Mauch (RETIRED) gentoo-dev 2006-02-16 17:47:44 UTC
Is this related to the exec problem?
Comment 12 Zac Medico gentoo-dev 2006-02-16 18:20:35 UTC
(In reply to comment #11)
> Is this related to the exec problem?

Well, bug 104705 should only express itself when portage kills tee at exit time, but in this case it seems that portage does not exit.  Maybe something is wrong with /usr/bin/tee (need to rebuild coreutils)?  Here's a simple test for tee:

echo hello | tee /dev/stdout
hello
hello
Comment 13 Simon Stelling (RETIRED) gentoo-dev 2006-04-16 13:48:01 UTC
Assuming tee's broken here. Pierre, if the bug still exists for you, can you please reopen it with the output of

# echo hello | tee /dev/stdout

please?
Comment 14 Marius Mauch (RETIRED) gentoo-dev 2007-01-11 11:06:40 UTC
Closing due to old age