Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 108512 - cinelerra-cvs-20051005 esd useflag issue
Summary: cinelerra-cvs-20051005 esd useflag issue
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Marc Hildebrand (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-08 10:01 UTC by zolar czakl
Modified: 2006-06-25 16:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
updated ebuild (cinelerra-cvs-20051005.ebuild,1.86 KB, text/plain)
2005-11-12 16:46 UTC, Harm Geerts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zolar czakl 2005-10-08 10:01:18 UTC
Build fails with -esd

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




`use_enable esd` in econf fix the problem
Comment 1 Chris Smith 2005-10-08 12:03:17 UTC
What if you don't use esound and don't have it installed?
Comment 2 zolar czakl 2005-10-10 14:04:40 UTC
That's the problem.I don't use esound.Never installed.
Emerge fails on esound stuff with USE="-esd".

Without 'use_enable esd' the useflag don't work.


First Bug Report. Not really clear.
The second one is the same. :)  Sorry, sorry.
Comment 3 Karl Heiss 2005-10-25 16:57:58 UTC
To paraphrase: `use_enable esd` is missing for the econf. So, by default,
cinelerra is built with esd support and the esd USE flag does nothing because it
is not passed to the econf script. Adding this line in fixes the issue.
Comment 4 Harm Geerts 2005-11-12 16:46:57 UTC
Created attachment 72781 [details]
updated ebuild

ebuild with use esd as it should have been
Comment 5 Marc Hildebrand (RETIRED) gentoo-dev 2006-06-25 16:06:50 UTC
Cinelerra-cvs-20051005 has been removed.
AFAIK, the actual version does not have this problem.
Please check.
Thanks!
Marc.