Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 108356 - alsa does not work in gentoo-sources-2.6.13-r3
Summary: alsa does not work in gentoo-sources-2.6.13-r3
Status: RESOLVED DUPLICATE of bug 106400
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-07 00:20 UTC by Rene Zbinden
Modified: 2005-10-10 09:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config-2.6.13-gentoo-r3 (config-2.6.13-gentoo-r3,32.68 KB, text/plain)
2005-10-07 07:21 UTC, Rene Zbinden
Details
emerge.info (emerge.info,2.31 KB, text/plain)
2005-10-07 07:25 UTC, Rene Zbinden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Zbinden 2005-10-07 00:20:02 UTC
Alsa does not work in this Version with intel8x0 soundcards. The modules cannot
be loaded.
From dmesg:
snd: Unknown parameter `device_mode'
snd_timer: Unknown symbol snd_info_register
snd_timer: Unknown symbol snd_info_create_module_entry
snd_timer: Unknown symbol snd_info_free_entry
snd_timer: Unknown symbol snd_iprintf
snd_timer: Unknown symbol snd_ecards_limit
snd_timer: Unknown symbol snd_oss_info_register
snd_timer: Unknown symbol snd_unregister_device
snd_timer: Unknown symbol snd_device_new
snd_timer: Unknown symbol snd_info_unregister
snd_timer: Unknown symbol snd_register_device
snd_pcm: Unknown symbol snd_info_register
snd_pcm: Unknown symbol snd_info_create_module_entry
snd_pcm: Unknown symbol snd_timer_notify
snd_pcm: Unknown symbol snd_timer_interrupt
snd_pcm: Unknown symbol snd_info_free_entry
snd_pcm: Unknown symbol snd_info_get_str
snd_pcm: Unknown symbol snd_ctl_register_ioctl
snd_pcm: Unknown symbol snd_card_file_add
snd_pcm: Unknown symbol snd_iprintf
snd_pcm: Unknown symbol snd_major
snd_pcm: Unknown symbol snd_unregister_device
snd_pcm: Unknown symbol snd_timer_new
snd_pcm: Unknown symbol snd_device_new
snd_pcm: Unknown symbol snd_ctl_unregister_ioctl
snd_pcm: Unknown symbol snd_info_create_card_entry
snd_pcm: Unknown symbol snd_power_wait
snd_pcm: Unknown symbol snd_device_free
snd_pcm: Unknown symbol snd_card_file_remove
snd_pcm: Unknown symbol snd_info_unregister
snd_pcm: Unknown symbol snd_device_register
snd_pcm: Unknown symbol snd_register_device
snd_pcm: Unknown symbol snd_info_get_line
snd_ac97_codec: Unknown symbol snd_info_register
snd_ac97_codec: Unknown symbol snd_ctl_add
snd_ac97_codec: Unknown symbol snd_info_free_entry
snd_ac97_codec: Unknown symbol snd_interval_refine
snd_ac97_codec: Unknown symbol snd_ctl_find_id
snd_ac97_codec: Unknown symbol snd_ctl_new1
snd_ac97_codec: Unknown symbol snd_ctl_remove_id
snd_ac97_codec: Unknown symbol snd_component_add
snd_ac97_codec: Unknown symbol snd_pcm_hw_rule_add
snd_ac97_codec: Unknown symbol snd_iprintf
snd_ac97_codec: Unknown symbol snd_device_new
snd_ac97_codec: Unknown symbol snd_info_create_card_entry
snd_ac97_codec: Unknown symbol snd_info_unregister
snd_intel8x0: Unknown symbol snd_ac97_pcm_close
snd_intel8x0: Unknown symbol snd_ac97_resume
snd_intel8x0: Unknown symbol snd_pcm_new
snd_intel8x0: Unknown symbol snd_pcm_limit_hw_rates
snd_intel8x0: Unknown symbol snd_card_register
snd_intel8x0: Unknown symbol snd_card_free
snd_intel8x0: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
snd_intel8x0: Unknown symbol snd_card_proc_new
snd_intel8x0: Unknown symbol snd_ac97_pcm_open
snd_intel8x0: Unknown symbol snd_ac97_set_rate
snd_intel8x0: Unknown symbol snd_ac97_update_bits
snd_intel8x0: Unknown symbol snd_ac97_mixer
snd_intel8x0: Unknown symbol snd_card_pci_resume
snd_intel8x0: Unknown symbol snd_ac97_bus
snd_intel8x0: Unknown symbol snd_ac97_pcm_double_rate_rules
snd_intel8x0: Unknown symbol snd_card_new
snd_intel8x0: Unknown symbol snd_ac97_suspend
snd_intel8x0: Unknown symbol snd_iprintf
snd_intel8x0: Unknown symbol snd_pcm_lib_malloc_pages
snd_intel8x0: Unknown symbol snd_pcm_lib_ioctl
snd_intel8x0: Unknown symbol snd_pcm_lib_free_pages
snd_intel8x0: Unknown symbol snd_card_pci_suspend
snd_intel8x0: Unknown symbol snd_pcm_set_ops
snd_intel8x0: Unknown symbol snd_card_set_pm_callback
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_list
snd_intel8x0: Unknown symbol snd_device_new
snd_intel8x0: Unknown symbol snd_ac97_get_short_name
snd_intel8x0: Unknown symbol snd_pcm_suspend_all
snd_intel8x0: Unknown symbol snd_ac97_pcm_assign
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_integer
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_msbits
snd_intel8x0: Unknown symbol snd_pcm_period_elapsed
snd_intel8x0: Unknown symbol snd_ac97_tune_hardware
snd: Unknown parameter `device_mode'
snd_seq_device: Unknown symbol snd_info_register
snd_seq_device: Unknown symbol snd_info_create_module_entry
snd_seq_device: Unknown symbol snd_info_free_entry
snd_seq_device: Unknown symbol snd_seq_root
snd_seq_device: Unknown symbol snd_iprintf
snd_seq_device: Unknown symbol snd_device_new
snd_seq_device: Unknown symbol snd_info_unregister
snd_timer: Unknown symbol snd_info_register
snd_timer: Unknown symbol snd_info_create_module_entry
snd_timer: Unknown symbol snd_info_free_entry
snd_timer: Unknown symbol snd_iprintf
snd_timer: Unknown symbol snd_ecards_limit
snd_timer: Unknown symbol snd_oss_info_register
snd_timer: Unknown symbol snd_unregister_device
snd_timer: Unknown symbol snd_device_new
snd_timer: Unknown symbol snd_info_unregister
snd_timer: Unknown symbol snd_register_device
snd_seq: Unknown symbol snd_timer_stop
snd_seq: Unknown symbol snd_info_register
snd_seq: Unknown symbol snd_info_create_module_entry
snd_seq: Unknown symbol snd_request_card
snd_seq: Unknown symbol snd_seq_autoload_lock
snd_seq: Unknown symbol snd_info_free_entry
snd_seq: Unknown symbol snd_seq_root
snd_seq: Unknown symbol snd_timer_close
snd_seq: Unknown symbol snd_seq_autoload_unlock
snd_seq: Unknown symbol snd_timer_open
snd_seq: Unknown symbol snd_timer_start
snd_seq: Unknown symbol snd_iprintf
snd_seq: Unknown symbol snd_timer_resolution
snd_seq: Unknown symbol snd_timer_pause
snd_seq: Unknown symbol snd_ecards_limit
snd_seq: Unknown symbol snd_unregister_device
snd_seq: Unknown symbol snd_seq_device_load_drivers
snd_seq: Unknown symbol snd_info_unregister
snd_seq: Unknown symbol snd_register_device

Reproducible: Always
Steps to Reproduce:
1.Try to load an alsamodule
2.
3.

Actual Results:  
Unknown symbol errors

Expected Results:  
Module sould load without error.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-07 03:50:33 UTC
Is that with in-kernel alsa or with alsa-driver ? 
Comment 2 Rene Zbinden 2005-10-07 05:19:30 UTC
(In reply to comment #1)
> Is that with in-kernel alsa or with alsa-driver ? 
Of course the the in-kernel alsa. Otherwise I would have opened a bug for alsa.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-07 06:10:44 UTC
Then this is not a sound herd problem. 
Comment 4 Kerin Millar 2005-10-07 06:18:30 UTC
Rene, could you attach your /usr/src/linux/.config file and the output of emerge
--info please?
Comment 5 Rene Zbinden 2005-10-07 07:21:42 UTC
Created attachment 70086 [details]
config-2.6.13-gentoo-r3

The kernel config file.
Comment 6 Rene Zbinden 2005-10-07 07:25:03 UTC
Created attachment 70087 [details]
emerge.info

Output of emerge --info
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2005-10-10 09:01:41 UTC
(In reply to comment #0)
> Alsa does not work in this Version with intel8x0 soundcards. The modules cannot
> be loaded.
> From dmesg:
> snd: Unknown parameter `device_mode'

Fix your /etc/modules.d config to stop using device_mode

*** This bug has been marked as a duplicate of 106400 ***