Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 108324 - ndiswrapper doesn't work with gentoo-sources-2.6.13-r3
Summary: ndiswrapper doesn't work with gentoo-sources-2.6.13-r3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2005-10-06 15:49 UTC by Wiktor Wandachowicz
Modified: 2005-10-08 00:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Wiktor Wandachowicz 2005-10-06 15:49:42 UTC
Just tried to install, compile and use newest testing gentoo-sources-2.6.13-r3.
Alas, I've found that it doesn't play nicely with ndiswrapper.

During bootup, there was a notice on the screen:

* unable to load ndiswrapper

Ok, I thought, it's a kernel module that needs to be recompiled after kernel
upgrade. Typical. It quickly turned out not to be the case...

During remerging the ndiswrapper it displayed a following warning:

*** WARNING: Kernel seems to have 4K size stack option (CONFIG_4KSTACKS)
removed; many Windows drivers will need at least 8K size stacks. You should read
wiki about 4K size stack issue. Don't complain about crashes until you resolve this.

Reproducible: Always
Steps to Reproduce:
1. unmask "sys-kernel/gentoo-sources ~x86" in /etc/portage/package.keywords
2. rm /usr/src/linux
3. emerge -avu gentoo-sources
   (it gave me 2.6.13-r3, and /usr/src/linux -> linux-2.6.13-gentoo-r3)
4. cd /usr/src/linux
5. cat /proc/config.gz | gunzip > .config
6. make oldconfig && make menuconfig
7. compile, install, change /boot/grub/grub.conf
8. reboot
9. emerge ndiswrapper
10. try using wifi card (hint: no luck)
11. reboot
12. try using wifi card (hint: no luck)
13. reboot again, this time with the "old" kernel
14. remerge ndiswrapper
15. use wifi (hint: ok!)

Actual Results:  
As you can see, 2.6.13 kernel doesn't play nicely with ndiswrapper.
My wifi card (ASUS WL-167G) drivers refused to work with it.

It's definitely an issue with forcing 4KB stacks upon Linux users.

Expected Results:  
I'm not sure if it's possible at all to make it work again.
I just wanted to post a warning that something breaks after upgrade.
And I'm unsure if changing/patching ndiswrapper would help here.

If the current policy of dropping features by the kernel developers
continues, we all will be forced to stick to the old kernels...

Just like my current gentoo-sources-2.6.12-r10. All is well - and I still can
use my wifi to report this :)
Comment 1 Albert Holm 2005-10-06 16:05:39 UTC
Is there something that prevents you from changing the option to add a 8K stack 
again? I must have misunderstood the problem.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-10-06 16:30:02 UTC
Hmm, I don't understand either. Recompile your kernel w/ 8K stacks and reopen if
it still does not work then.
Comment 3 Wiktor Wandachowicz 2005-10-07 12:24:39 UTC
Hmm. I did as you've suggested. And in short - it worked.

However, I needed to enable "Kernel Hacking", even though up to the 2.6.12-r10
I never needed that. Maybe there's something wrong with the ndiswrapper ebuild?
But as my wi-fi works again, it's not such a big issue.

And finding the 8K/4K stack option was not so easy...
But anyway, thanks for the motivation!
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-10-08 00:58:52 UTC
Thanks for reporting back, closing.