Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 108022 - www-servers/aolserver-4.0.10 has init script problems and doesn't set up environment properly
Summary: www-servers/aolserver-4.0.10 has init script problems and doesn't set up envi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo TreeCleaner Project
URL:
Whiteboard: Pending removal 8 May 2007
Keywords: PMASKED
Depends on:
Blocks:
 
Reported: 2005-10-03 15:25 UTC by Nathan
Modified: 2007-05-07 18:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan 2005-10-03 15:25:03 UTC
Problems in /etc/init.d/aolserver:
1) '-g web' --> No web group.  I think this should be '-g aolserver' (works for me)
2) I had to add '-b X.X.X.X:80 X.X.X.X:443' (substituting my IP address) or aolserver wouldn't bind to the 
ports
3) After an unsuccessful  '/etc/init.d/aolserver start' (fatal error at startup due to configuration, nsd 
process dies), a subsequent start command reports aolserver is running, though no nsd processes are 
running.
4) After a successful start, '/etc/init.d/aolserver stop' reports "No process in pidfile `/var/run/
aolserver/aolserver.pid' found running; none killed.", yet the pidfile has the correct PID and appears to 
have correct permissions (-rw-r--r--  1 aolserver aolserver 6 Oct  3 15:24 server1.pid)

'start' does work if I make the modifications above.

Environment problems:
1) The ebuild did not create the log file directory as specified in the default config.  "mkdir /var/log/
aolserver && chown root:aolserver /var/log/aolserver && chmod 770 /var/log/aolserver" worked for 
me.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Nathan 2005-10-04 13:47:10 UTC
nsperm files appear to be in the wrong place.  The default location that the ebuild sets up is:
/etc/aolserver/modules/nsperm

However, even when nsperm.so loads successfully, it doesn't find the perms files in the above location.  
I'm not sure exactly where it looks, but when I pulled over this line from my config on an old RH server:

ns_section "ns/server/${servername}/modules/nsperm"

...then I was able (by painful trial-and-error) to get my perms files to be read if I placed them in:

/usr/lib/aolserver/server/server1/modules/nsperm

...which I assume means that aolserver is looking in /usr/lib/aolserver for nsperm, and not in 
/etc/aolserver.
Comment 2 Ian Leitch (RETIRED) gentoo-dev 2005-10-15 12:35:24 UTC
I am currently without a development machine and as such am unable to fix this 
bug. It shouldn't be too long before I'm back in action though.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-05-23 10:57:33 UTC
Re-assign wrt Bug 26349. If you pick this up, remove port001 from metadata.xml.
Comment 4 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2007-01-22 18:53:59 UTC
I tried working on version 4.5.0 and it's a huge POS.

It ships with a tcl-based build system; however none of the build scripts are executable and none have #!/usr/bin/tclsh at the top so they all fail.  Even after fixing that problem the program fails to build for me.  I can't imagine how other 'releases' must work.

I say punt 'er unless someone else has time to look at it.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-01-22 20:39:15 UTC
SIGDIE
Comment 6 Charlie Shepherd (RETIRED) gentoo-dev 2007-01-22 20:53:10 UTC
(In reply to comment #4)
> it's a huge POS.
++ 

Comment 7 Nathan 2007-01-22 21:05:17 UTC
(In reply to comment #4)
> I tried working on version 4.5.0 and it's a huge POS.
> 
> ...

Er, but the bug I filed was for 4.0.10.  It really should be fixed.  The fact that version 4.5.0 is a POS is even more reason to fix the 4.0.10 ebuild.

I wish I never migrated from 3.5x, though.  That was the last truly stable version.
Comment 8 Raúl Porcel (RETIRED) gentoo-dev 2007-03-11 19:24:22 UTC
# Raúl Porcel <armin76@gentoo.org> (8 Mar 2007)
# P.masking for treecleaners, pending removal in 60 days
# That is, 8 May 2007
# www-servers/aolserver and its rdeps -> bug 108022
#	www-misc/nscache
#	www-misc/nsopenssl
#	www-misc/nssha1
#	www-misc/nsxml
# app-emulation/tiger -> bug 110298
# sys-apps/evkeyd -> bug 115407
# media-libs/libuta -> bug 117665
# net-misc/cipe -> bug 137329
# app-text/biblestudy -> bug 164144
www-servers/aolserver
www-misc/nscache
www-misc/nsopenssl
www-misc/nssha1
www-misc/nsxml
app-emulation/tiger
sys-apps/evkeyd
media-libs/libuta
net-misc/cipe
app-text/biblestudy
Comment 9 Raúl Porcel (RETIRED) gentoo-dev 2007-05-07 18:42:02 UTC
Removed