Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 107212 - MILO for Alpha XLT from taviso's home hangs after swapping to PALcode
Summary: MILO for Alpha XLT from taviso's home hangs after swapping to PALcode
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: Alpha Linux
: Low normal (vote)
Assignee: Alpha Porters
Depends on:
Reported: 2005-09-25 14:33 UTC by sander stokman
Modified: 2008-03-15 14:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description sander stokman 2005-09-25 14:33:00 UTC
When I create a MILO boot floppy for an Alpha XL 300 (machine type XLT) per the
instructions from the machine
hangs when it jumps to MILO. The last message is "Swapping to PALcode at 0x80000

Reproducible: Always
Steps to Reproduce:
1. Obtain freshly formatted DOS floppy.
2. Download "linload.exe" and "milo-2.2-18-gentoo-alpha-xlt" from
3. Rename "milo-2.2-18-gentoo-alpha-xlt" to "milo" and copy to the floppy.
4. Copy "linload.exe" to the floppy.
5. Run md5sum on floppy and verify results with CHECKSUMS.md5 from web site to
ensure files were transfered correctly.
6. Insert floppy in Alpha XL 300.
7. Reboot Alpha, press F2 to enter AlphaBIOS.
8. Go to "Utilities" -> "OS Selection Setup..."
9. Create entry with on the "Boot File:" line device "A:" and command "linload.exe."
10. Exit AlphaBIOS setup, this will take you to the Select Operating System screen.
11. On the Select Operating System screen select the entry you just created.

Actual Results:  
linload loads MILO, but it hangs when it jumps to MILO. The last message is
"Swapping to PALcode at 0x80000 ..."

Expected Results:  
The "MILO>" prompt should be displayed.

The machine is an Alpha XL 300 with 144 MByte of RAM. To my knowledge this is an
XLT type machine, not an XL type machine. As far as I know SRM is not an option
for the XL 300.

I was able to find an older XLT MILO that does load, but it refuses to boot the
installation CD from a Promise PDC20267 IDE controller. The XL 300 does not have
an IDE controller on board and I do not have access to a SCSI cdrom drive to
boot the installation CD.

Note: "emerge info" is not available it this point as we are just getting
started with the boot process.
Comment 1 sander stokman 2005-09-25 14:43:43 UTC
Almost forgot. The version string of the working MILO is "Linux/Alpha Miniloader
(MILO) v/aux/KERNELS/MILO/xlt-2.2-18 (Sat Apr 13 17:25:21 EDT 2002)"
Comment 2 Bryan Østergaard (RETIRED) gentoo-dev 2005-09-25 14:45:44 UTC
Have you tried the milo-2.2-18-gentoo-alcor boot file instead? Apparently the
XL300 system comes in two slightly different models, one being the alcor and
another being bret.
Comment 3 sander stokman 2005-09-26 13:54:19 UTC
Tried milo-2.2-18-gentoo-alcor, but same result. System hangs after "Swapping to
PALcode at 0x80000 ..."

I was able to boot the 2.6 kernel from the install CD by copying it onto a SCSI
disk and then using the working MILO to boot from that. When the kernel boots
there is a message "alcor_init_pci: Detected AS500 or XLT motherboard." In
/proc/cpuinfo it says "system type: Alcor", "system variation: Bret".

Googling around I found a message from Jay Estabrook
( that XLT and
Alcor are not the same. XLT has served me well so far, so I am going to presume
I have an XLT on my hands.
Comment 4 Jose Luis Rivero (yoswink) (RETIRED) gentoo-dev 2008-03-15 14:25:55 UTC
Taviso is no longer a dev and the homepage was removed some time ago and we don't have a box with MILO to check problems so I think we can close this.