Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 106855 - sys-boot/aboot does not support reiserfs
Summary: sys-boot/aboot does not support reiserfs
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: Alpha Linux
: High enhancement (vote)
Assignee: Alpha Porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-21 19:39 UTC by ibm
Modified: 2008-12-14 19:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
add reiserfs support to aboot (aboot-reiserfs.diff,41.53 KB, patch)
2005-09-21 19:40 UTC, ibm
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ibm 2005-09-21 19:39:57 UTC
aboot does not support booting from reiserfs. I have created a patch which
allows this to work.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 ibm 2005-09-21 19:40:47 UTC
Created attachment 68983 [details, diff]
add reiserfs support to aboot
Comment 2 Thomas Cort (RETIRED) gentoo-dev 2006-03-03 12:47:02 UTC
Thanks for the patch! I tested the patch and it worked for me. It boots vmlinux-2.4.30.gz from a reiserfs partition.

# mount
/dev/scsi/host0/bus0/target1/lun0/part2 on / type reiserfs (rw,noatime,notail)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
shm on /dev/shm type tmpfs (rw,noexec,nosuid,nodev)

# emerge --info
Portage 2.0.54 (default-linux/alpha/no-nptl/2.4, gcc-3.3.2, glibc-2.3.5-r3, 2.4.30 alpha)
=================================================================
System uname: 2.4.30 alpha EV56
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r4
ACCEPT_KEYWORDS="alpha ~alpha"
AUTOCLEAN="yes"
CBUILD="alpha-unknown-linux-gnu"
CFLAGS="-mieee -pipe -O2 -mcpu=ev56"
CHOST="alpha-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mieee -pipe -O2 -mcpu=ev56"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://adelie.polymtl.ca/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://gentoo.seren.com/gentoo http://gentoo.chem.wisc.edu/gentoo/ http://cudlug.cudenver.edu/gentoo/ http://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo http://gentoo.netnitco.net http://mirror.espri.arizona.edu/gentoo/ http://mirrors.acm.cs.rpi.edu/gentoo/ http://gentoo.arcticnetwork.ca/ http://open-systems.ufl.edu/mirrors/gentoo http://gentoo.llarian.net/ http://gentoo.binarycompass.org http://gentoo.mirrored.ca/ http://mirror.datapipe.net/gentoo http://gentoo.cs.lewisu.edu/gentoo/ http://prometheus.cs.wmich.edu/gentoo http://modzer0.cs.uaf.edu/public/gentoo/ http://mirror.usu.edu/mirrors/gentoo/ http://mirror.phy.olemiss.edu/mirror/gentoo http://mirror.mcs.anl.gov/pub/gentoo/ http://gentoo.mirrors.easynews.com/linux/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ http://mirror.clarkson.edu/pub/distributions/gentoo/ http://cdot.senecac.on.ca/software/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="alpha X aac aalib aim alsa apache2 artworkextra async audacious audiofile bash-completion berkdb binfilter bitmap-fonts bittorrent bl bonjour bzip2 c++ cairo calendar cdinstall cdparanoia cdr cdrom chroot cli config_wizard cracklib crypt cscope csv ctype cups curl curlwrappers cvs cvsgraph dhcp dillo editor eds elf encode epiphany escreen esd ethereal expat extraicons extras ffmpeg fftw figlet firefox flac ftp gdb gdbm gif glep gmp gnutls gpm grammar gsl gstreamer gtalk gtk gtk2 gtkspell gvim gzip html icq id3 imlib ipod jabber javascript jpeg justify ladspa lame libg++ libsexy libwww lite lj logrotate lua mad make-symlinks mapeditor md5sum mikmod motif moznoirc moznomail moznoroaming moznoxft mozsha1 mp3 mpeg mpeg2 mplayer msn msnextras music ncurses net nethack nls offensive ogg oggvorbis opengl openssh openssl oscar oss pam pcre pdflib perl png python quicktime quotes readline real recode reiserfs scp screen sdl sftp skins sndfile sockets sounds sox speech spell ssl subversion symlink syslog tcpd threads truetype truetype-fonts type1-fonts udev userlocales vcd videos vim vim-with-x vorbis wma wma123 xml xml2 xmlreader xmms xv xvid yahoo zip zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 3 James Gilliland 2006-05-16 10:11:05 UTC
This works for me as well. 

nearly identical setup except
Portage 2.0.54 (default-linux/alpha/2006.0, gcc-3.3.2, glibc-2.3.5-r3, 2.6.15.1 alpha)
=================================================================
System uname: 2.6.15.1 alpha EV56
Comment 4 Tobias Klausmann gentoo-dev 2008-12-14 19:44:50 UTC
I doubt anyone is seriously considering using reiserfs as / on an alpha these days. If so, feel free to reopen.