Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 106685 - pgAdmin3 - wxGTK needs unicode
Summary: pgAdmin3 - wxGTK needs unicode
Status: VERIFIED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-20 08:26 UTC by Chuck Wegrzyn
Modified: 2005-09-20 10:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Wegrzyn 2005-09-20 08:26:44 UTC
My USE flags didn't include unicode as an option. When I built pgadmin3, emerge
rightly compiled wxGTK. It wrongly didn't include the USE='unicode' option when
it built wxGTK. When I finally got to building pgadmin3 it complained about
wxGTK not being built with unicode.

Reproducible: Always
Steps to Reproduce:
1.remove unicode from your USE flags.
2.unmerge wxGTK
3.emerge pgadmin3

Actual Results:  
pgadmin3 will fail complaining about wxGTK not built with USE='unicode'

Expected Results:  
To work...

marge ~ # emerge info
Portage 2.0.52-r1 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-r9 i686)
=================================================================
System uname: 2.6.12-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.12.0_pre8
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS=" -O2 -march=pentium4"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS=" -O2 -march=pentium4"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac acl acpi afs aim alsa aotuv apache2 apm arts artswrappersuid
audiofile avi bash-completion bdf berkdb bitmap-fonts bluetooth bootsplash caps
cdparanoia cdr cluster codecs crypt css cups curl dbx dga dio directfb dpms dv
dvb dvd dvdr dvdread eds encode esd ethereal exif fam fame fb fbcon fbdev flac
flatfile foomaticdb fpx freetds ftp gd gdbm gif gpg gpm gstreamer gtk gtk2
imagemagick imlib ipv6 java jpeg junit kde ldap libg++ libwww mad mikmod mime
mjpeg mmx monkey motif mp3 mpeg msn msql mysql ncurses nls odbc ogg oggvorbis
opengl oss pam pdflib perl png postgres python qt quicktime readline samba sdl
snmp spell sse sse2 ssl svga tcltk tcpd tetex tiff truetype truetype-fonts
type1-fonts vorbis xine xinerama xml2 xmms xv yahoo zeroconf zlib userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 08:37:54 UTC
Sorry, pgadmin3 needs wxGTK emerged w/ USE=unicode. This is not a bug.
Comment 2 Chuck Wegrzyn 2005-09-20 09:20:07 UTC
I claim that Jokub is wrong! It isn't that wxGTK doesn't require Unicode. It is
that the ebuild and the emerge system should in fact identify errors such as
this and either stop the build from happening or conditionally ask the user for
permission to override the USE flags.

Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 09:39:07 UTC
(In reply to comment #2)
> It isn't that wxGTK doesn't require Unicode. It is
> that the ebuild and the emerge system should in fact identify errors such as
> this and either stop the build from happening or conditionally ask the user for
> permission to override the USE flags.

That's exactly what I said and what the ebuild in fact does, so don't reopen the
bug because it's pointless. pgadmin3 checks whether wxGTK was built with
USE=unicode and stops if not.

<snip>
pkg_setup() {
        if ! built_with_use '>=x11-libs/wxGTK-2.6.0' unicode ; then
                die "${PN} requires >=x11-libs/wxGTK-2.6.0 emerged with
USE='unicode'"
        fi
}
</snip>
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 09:39:23 UTC
CLOSED
Comment 5 Chuck Wegrzyn 2005-09-20 09:54:57 UTC
Actually it is pgadmin3 doing the check AFTER the build of wxGTK!!!! Do you see
the stupidity in that?

Fix it so the build does the right thing!!! Check for it before hand. I can tell
you that computers can do it....
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 09:57:42 UTC
(In reply to comment #5)
> Actually it is pgadmin3 doing the check AFTER the build of wxGTK!!!! Do you see
> the stupidity in that?

Would you kindly explain how on earth would wxGTK ebuild check for something you
have not done yet and how would it know that you are going to emerge something
that needs unicode?

Please, stop this bugspamming. Thanks.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 09:58:04 UTC
CLOSED
Comment 8 Chuck Wegrzyn 2005-09-20 10:08:02 UTC
et's see...
------------------------------------

Do I need to install wxGTK?
 No - go to step NNNN
 Yes - build wxGTK with USE='unicode'
          build pgadmin3

NNNN:
  Does the USE flag in Make.conf have unicode set?
  No - issue warning to user (or perhaps ask them if they want it rebuilt)
  Yes - issue warning that assuming wxGTK was built with unicode.

----------------------------------

See not to difficult! And I even bet this feature would be appreciated by others
that build pgadmin3! And it makes the system more useful and usable.I bet a
computer and emerge along with the ebuild could be made to do it!
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 10:09:19 UTC
Ebuild *can't* do that now. Period. 

Please, direct all you comments to Bug 2272.

*** This bug has been marked as a duplicate of 2272 ***
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 10:10:38 UTC
Closed - and I mean *really* closed.