Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 106661 - Monodevelop looking for mcs in /usr/libin
Summary: Monodevelop looking for mcs in /usr/libin
Status: VERIFIED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-20 03:04 UTC by Gregorij Ivanov
Modified: 2005-09-24 03:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to monodevelop-0.7 to fix the issue. (monodevelop-0.7-mcs-path-fix.diff,1.87 KB, text/plain)
2005-09-22 21:45 UTC, Peter Johanson (RETIRED)
Details
monodevelop-0.7-r2.ebuild (monodevelop-0.7-r2.ebuild,1.80 KB, text/plain)
2005-09-22 21:47 UTC, Peter Johanson (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gregorij Ivanov 2005-09-20 03:04:16 UTC
Monodevelop looks for mcs in non-existing/not standard paths. It tried to access
mcs at /usr/libin.

As a workaround helps creating a symlink in /usr/libin pointing to real mcs.

Have a nice day

Reproducible: Always
Steps to Reproduce:
1. Check if /usr/libin doesn't exist (it is not created by the ebuild because it
seems to be a typo)
2. Try to compile any c# project
3. See the message about mcs not being found in /usr/libin



Expected Results:  
It should have used standard $PATH or /usr/bin/env mcs

Mono and Monodevelop have been built using ACCEPT_KEYWORDS="~amd64" emerge ...

$ whereis mcs
mcs: /usr/bin/mcs /usr/X11R6/bin/mcs /usr/bin/X11/mcs /usr/share/man/man1/mcs.1.gz

$ monodevelop --version
MonoDevelop  0.7.0.0 - (c) 2004 MonoDevelop Team and Mike Krueger 2000-2003

$ mono --version
Mono JIT compiler version 1.1.9, (C) 2002-2005 Novell, Inc and Contributors.
www.mono-project.com

---
Build system:

Linux gentoo 2.6.12-gentoo-r10 #1 Tue Sep 13 13:36:30 GMT 2005 x86_64 AMD
Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux

Portage 2.0.51.22-r2 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-r10 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r10 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.13
ccache version 2.3 [disabled]
dev-lang/python:     2.3.5-r2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa avi berkdb bitmap-fonts cdr crypt cups dvd eds emboss encode
fam foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipv6 jpeg
libwww lzw lzw-tiff mad mozilla mp3 mpeg ncurses nls ogg opengl pam pdflib perl
png python quicktime readline ruby sdl spell ssl tcpd tetex tiff truetype-fonts
type1-fonts usb userlocales vorbis xml2 xmms xpm xv zlib userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 07:01:41 UTC
http://bugs.gentoo.org/enter_bug.cgi?format=guided

<snip>
Gentoo Linux: The Gentoo Linux Distribution - Ebuilds and System related issues.
If you're unsure where your bugs go, then file them here.
</snip>

Is this really hopeless? Don't file ebuild bugs under Bugzilla product... *sigh*
Comment 2 Gregorij Ivanov 2005-09-20 09:47:21 UTC
(In reply to comment #1)
> http://bugs.gentoo.org/enter_bug.cgi?format=guided
> 
> <snip>
> Gentoo Linux: The Gentoo Linux Distribution - Ebuilds and System related issues.
> If you're unsure where your bugs go, then file them here.
> </snip>
> 
> Is this really hopeless? Don't file ebuild bugs under Bugzilla product... *sigh*

oops, sorry, that was my #1 bugzilla commit ever ;)
Comment 3 Peter Johanson (RETIRED) gentoo-dev 2005-09-22 16:15:20 UTC
Yeah, I see the source of this error in the code, just have to find a proper fix
for it. For completeness, can you report the output of running "cat `which
mcs`"? I'm assuming it will be something like:

peter@stu ~ $ cat `which mcs`
#!/bin/sh
exec /usr/bin/mono /usr/lib64/mono/1.0/mcs.exe "$@"
Comment 4 Peter Johanson (RETIRED) gentoo-dev 2005-09-22 21:45:29 UTC
Created attachment 69046 [details]
patch to monodevelop-0.7 to fix the issue.

Ok, here's a patch for monodevelop that should resolve the issue on multilib
systems using /usr/lib32 or /usr/lib64. Put this file into
/usr/portage/dev-util/monodevelop/files/.

Ebuild that applies the patch to follow.
Comment 5 Peter Johanson (RETIRED) gentoo-dev 2005-09-22 21:47:01 UTC
Created attachment 69047 [details]
monodevelop-0.7-r2.ebuild

Ebuild that applies the patch. Put this in /usr/portage/dev-util/monodevelop/

then do 'ebuild monodevelop-0.7-r2.ebuild digest', and then emerge the new
monodevelop. Please report if this fixes things for you. Thanks.
Comment 6 Gregorij Ivanov 2005-09-23 03:11:27 UTC
Sorry, I was out of town for 2 days (had to leave) and couldn't follow the bug.
That's why I couldn't cat for you.

Today I applied and reemerged monodevelop, removed my custom symlink and
recompiled a relatively big project. It worked flawlessly.

Thank you.
Comment 7 Peter Johanson (RETIRED) gentoo-dev 2005-09-23 08:18:04 UTC
Ok, i've just commited 0.7-r2 to the tree. Thanks for testing. In the future,
*please* don't change the status of bugs after confirming things like this.
marking this resolved will just potentially make the bug sink below my radar.
Anyway, marking CLOSED. Thanks again.
Comment 8 Gregorij Ivanov 2005-09-24 03:47:39 UTC
ok, thank you, next time ill do all properly :)