Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 106656 - Symlinks in /etc/runlevels/boot and /etc/runlevels/default refer to "stage1root"
Summary: Symlinks in /etc/runlevels/boot and /etc/runlevels/default refer to "stage1root"
Status: RESOLVED DUPLICATE of bug 103275
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL: http://mirror.pudas.net/gentoo/releas...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-20 02:19 UTC by Rabbe Fogelholm
Modified: 2005-09-20 06:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rabbe Fogelholm 2005-09-20 02:19:09 UTC
In the stage3 tarball of the above given URL the symbolic links in
/etc/runlevels/boot, /etc/runlevels/default and /etc/runlevels/nonetwork look
weird. For example, in the /etc/runlevels/boot directory there is

checkroot -> /tmp/stage1root//etc/init.d/checkroot

These strange-looking links show up in a freshly installed Gentoo system. Even
though they seem to work they bring some confusion: One would expect that doing
`rc-update del checkroot boot' followed by `rc-update add checkroot boot' should
put the system in the same state as before, but it doesn't since the symlink
target is thereby changed to /etc/init.d/checkroot.
Comment 1 SpanKY gentoo-dev 2005-09-20 06:50:51 UTC

*** This bug has been marked as a duplicate of 103275 ***