Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 106486 - emerge --metadata and emerge --sync causes portage to segfault
Summary: emerge --metadata and emerge --sync causes portage to segfault
Status: RESOLVED DUPLICATE of bug 104151
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2005-09-18 23:22 UTC by Juha Heljoranta
Modified: 2005-09-21 23:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Juha Heljoranta 2005-09-18 23:22:43 UTC
Usually the 'emerge --sync' will segfault before it reaches 100 % while updating
the portage cache.

If the portage seg faulted then it is likely that the 'emerge --metadata' will
segfault also.

Reproducible: Sometimes
Steps to Reproduce:
1. # emerge --sync

If the --sync gave 'Segmentation fault' then it is very likely that the

2. # emerge --metadata

will seg. fault.

Step two can be repeated until it gets to the 100 %.

sync usually gets portage to near 50 %, and the metadata proceeds to the 100 %
but sometimes several attempts (of emerge --metadata) is required to get to the
100 %.

Actual Results:  
>>> Updating Portage cache:   49%Segmentation fault

Expected Results:  
>>> Updating Portage cache:  100%

# emerge -V
Portage (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.6.13-gentoo-r1 x86_64)

# uname -a
Linux sng 2.6.13-gentoo-r1 #1 Sat Sep 17 10:46:08 EEST 2005 x86_64 AMD
Athlon(tm) 64 Processor 3500+ AuthenticAMD GNU/Linux

I ran the memtest+ several times without a sigle failure.

Don't know does this really help but this is what my kernel log has catched:

Sep 19 08:52:43 sng emerge[14747]: segfault at 00000000000000a1 rip
00002aaaaac81608 rsp 00007fffffcce910 error 4
Sep 19 09:01:12 sng emerge[13031] general protection rip:2aaaaac81601
rsp:7fffff855aa0 error:0Sep 16 21:43:56 sng emerge[20429]: segfault at
0000000000000000 rip 00002aaaaac169ab rsp 00007ffffff26d00 error 6
Sep 17 10:10:40 sng emerge[3313]: segfault at 00000000000000a3 rip
00002aaaaac81608 rsp 00007fffffc3d0e0 error 4
Sep  5 18:55:49 sng emerge[26289]: segfault at 0000000000000000 rip
00002aaaaac169ab rsp 00007ffffff5e360 error 6
Sep  6 22:46:33 sng emerge[31687]: segfault at 0000000000000000 rip
00002aaaaac169ab rsp 00007fffffbebd00 error 6
Sep  2 18:12:38 sng emerge[31695] general protection rip:2aaaaac81628
rsp:7fffffb5e260 error:0
Aug 23 19:23:56 sng emerge[13154]: segfault at 00002aaa00000021 rip
00002aaaaac818a3 rsp 00007fffff8cd2a0 error 4
Comment 1 Patrick Lauer gentoo-dev 2005-09-19 02:23:30 UTC
kernel bug? looks similar
Comment 2 Jason Stubbs (RETIRED) gentoo-dev 2005-09-19 02:45:52 UTC
It does look similar. 
Problem Description:  
User space application (mostly gcc, g++, collect, sed and grep) randomly    
segfault and cause protection errors. This goes away when I revert the    
randomisation-top-of-stack-randomization patch or when I run the following    
command: echo 0 > /proc/sys/kernel/randomize_va_space 
Juha, can you try that workaround and see if that does it for you? 
Comment 3 Daniel Drake (RETIRED) gentoo-dev 2005-09-19 05:44:24 UTC

*** This bug has been marked as a duplicate of 104151 ***
Comment 4 Juha Heljoranta 2005-09-21 23:27:09 UTC
I just saw a new segfault.

>>> Updating Portage cache:   64%Segmentation fault

Sep 22 09:00:24 sng emerge[15744]: segfault at 00000000000000a1 rip
00002aaaaac81608 rsp 00007fffffff8ea0 error 4

# cat /proc/sys/kernel/randomize_va_space

Disabling randomization helped alot but it seems that this can still occur.

Should be reopened or should I wait for next kernel update?