Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 106128 - stage1 tarball has very broken symlinks in /etc/runlevels/*
Summary: stage1 tarball has very broken symlinks in /etc/runlevels/*
Status: RESOLVED DUPLICATE of bug 103275
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-15 16:37 UTC by Dean Bailey
Modified: 2005-09-15 16:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Bailey 2005-09-15 16:37:52 UTC
The 2005.1 x86 stage1 tarball has broken symlinks for the runlevels.
All of the symlinks that should be there by default are prefixed with
"/tmp/stage1root/" 

I.E.
/etc/runlevels/default/local -> /tmp/stage1root//etc/init.d/local
when it should be
/etc/runlevels/default/local -> /etc/init.d/local


To fix this by hand you have to either delete and recreate the symlinks by hand,
or use rc-update del & rc-update add for all of the affected services.

This bug causes services that are default but not a dependancy of any other
service to not start properly, which could be a big problem.

As is most of the services are started automagically because of the deps, which
is probably why it did not get caught in Q.A.


Reproducible: Always
Steps to Reproduce:
1. Download stage1-x86-2005.1.tar.bz2
2. Unpack & chroot
3. ls -lasF /etc/runlevels/boot ; ls -lasF /etc/runlevels/default

Actual Results:  
It shows the broken symlinks.

Expected Results:  
Symlinks should not be pointed to destination prefixed with /tmp/stage1root/
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-09-15 16:56:29 UTC

*** This bug has been marked as a duplicate of 103275 ***