Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 106080 - Gnomemeeting fails to load shared libraries.
Summary: Gnomemeeting fails to load shared libraries.
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Stefan Knoblich (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-15 09:02 UTC by jreed
Modified: 2006-07-23 08:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jreed 2005-09-15 09:02:16 UTC
Trying to start a new Gnomemeeting session and I get the following:

gnomemeeting: error while loading shared libraries: libpt_linux_x86_r.so.1.8.7:
cannot open shared object file: No such file or directory

Reproducible: Always
Steps to Reproduce:
1. emerge gnomemeeting (~x86).
2. From console, or icon, start gnomemeeting.
3.

Actual Results:  
jxxxx@jxxxx ~ $ gnomemeeting
gnomemeeting: error while loading shared libraries: libpt_linux_x86_r.so.1.8.7:
cannot open shared object file: No such file or directory



Portage 2.0.52-r1 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.13-gentoo i686)
=================================================================
System uname: 2.6.13-gentoo i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.12.0_pre8
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo
ftp://gentoo.mirrors.tds.net/gentoo
ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://gentoo.netnitco.net"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 X aim alsa avi bash-completion berkdb bitmap-fonts browserplugin bzlib
cdr crypt cups curl dga directfb divx4linux dvd dvdr dvdread eds emboss encode
esd fam foomaticdb fortran ftp gdbm gif gnome gnome2 gnupg gpm gstreamer gtk
gtk2 hal howl icq imagemagick imap imlib ipv6 jabber java jpeg krb4 ldap libg++
libwww mad mikmod mime mmx motif mozilla mp3 mpeg msn ncurses nls ogg oggvorbis
opengl openldap openssh openssl oscar pam pdflib perl php png posix python
quicktime readline ruby sasl sdl spell sse sse2 ssl symlink tcltk tcpd tiff
truetype truetype-fonts type1-fonts unicode usb v4l vorbis wifi win32codecs xine
xml xml2 xmms xpm xscreensaver xv yahoo zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Mr. Borje Holmberg 2005-09-15 12:22:00 UTC
I have the same problem. I solved it by manually emerging
gnomemeeting-1.2.2.ebuild from /usr/portage/net-im
Comment 2 Daniel Gryniewicz (RETIRED) gentoo-dev 2005-09-15 13:54:42 UTC
Try syncing and re-emerging gnomemeeting.  This usually means that the shared
lib was updated, and the dependency in the code was on that specific version. 
Re-emerging the package should cause it to rebuild against the new lib.

(Note that gnomemeeting-1.2.2 is now masked as part of gnome 2.12, so you may
not be able to use it without updated to gnome 2.12)
Comment 3 Mr. Borje Holmberg 2005-09-16 17:51:56 UTC
just can't get it to work any more - gnomemeeting cannot find the missing
libpt_linux_x86_r.so.1.8.7 :(

seems also to need two pwlibs and keeps upgrading and downgrading - just so slow
and tiresome to emerge, especially openh323... any way, hardly anybody uses this
app and it is worthless with windows ppl, unless they use netmeeting. But they
don't use it, they use Messenger.

But it is a pity that it was destroyed with the latest pwlibs and openh323...
Comment 4 Daniel Gryniewicz (RETIRED) gentoo-dev 2005-09-18 17:51:44 UTC
Reassinging to stkn, to (maybe) mask openh323 and company.
Comment 5 Alexandre Hannud Abdo 2005-09-21 21:39:26 UTC
This is weird:

I have both openmcu and gnomemeeting here on ~i386

if I 'emerge -uDN world', it downgrades both openh323 and pwlib to respective
versions 1.15.3 and 1.8.4, and --tree shows them as dependencies of gnomemeeting

if I do that again, it upgrades both to respective versions 1.15.6 and 1.8.7 and
--tree shows them as dependencies of gnomemeeting

and if I keep emerging, it keeps oscillating between this two actions!

now,

the gnomemeeting-1.2.1 ebuild depends on
~dev-libs/pwlib-1.8.4
~net-libs/openh323-1.15.3

the openmcu-2.1.0 ebuild depends on
>=net-libs/openh323-1.15.2

the openh323-1.15.3 ebuild depends on
>=dev-libs/pwlib-1.8.4

(and the openh323-1.15.6 ebuild depends on ~dev-libs/pwlib-1.8.7 but that seems
irrelevant)

so, AFAIK, the result should be having
~dev-libs/pwlib-1.8.4
~net-libs/openh323-1.15.3

and NO OSCILLATION.

Therefore, am I missing something, or could this be a bug in the portage system?

best wishes,
ale
Comment 6 Alexandre Hannud Abdo 2005-09-21 21:42:12 UTC
oops, two typos:

"~i386" should be "~x86"

and
"
if I do that again, it upgrades both to respective versions 1.15.6 and 1.8.7 and
--tree shows them as dependencies of gnomemeeting
"
should be
"
if I do that again, it upgrades both to respective versions 1.15.6 and 1.8.7 and
--tree shows them as dependencies of openmcu
"

ale
Comment 7 manolis 2005-09-28 02:02:09 UTC
related to this problem. 
emerging gnomemeeting installs pwlib-1.8.7 but running gnomemeeting fails asking
for libpt_.....1.8.4 . 
emergeing libpw.1.8.4 gnomemeeting fails asking for 1.8.7

Again if I --update --deep --newuse world ,pwlib goes to 1.8.7 if there is
1.8.4... and again running --update --deep --newuse world , pwlib goes back to
1.8.4 from 1.8.7... this happens continuously...
In the mean time gnomemeeting wants installed the non installed version of pwlib....
Comment 8 Gilles Dartiguelongue gentoo-dev 2006-06-11 04:07:04 UTC
Is this bug still valid, since ekiga is out there and superseedes gnomemeeting ?
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-07-23 08:28:06 UTC
Deprecated and package.masked for removal.

# Stefan Schweizer <genstef@gentoo.org> (18 Jul 2006)
# Masked for removal, please use ekiga now, #136615
net-im/gnomemeeting