Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 105953 - emerge wont recompile certain packages after -gpm is added to USE flags
Summary: emerge wont recompile certain packages after -gpm is added to USE flags
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2005-09-14 04:23 UTC by Xander
Modified: 2009-06-22 19:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Xander 2005-09-14 04:23:37 UTC
I installed the system with gpm. After a while i decided to uninstall gpm and 
add the -gpm flag to my USE flags.

I ran emerge --deep --update --newuse world. It recompiled some packages.

Some days later after a reboot i found out that php mod_php and aspell had to be 
recompiled aswell. (i found this while running revdep-rebuild)

Reproducible: Didn't try
Steps to Reproduce:
Not tried it due to no free system to do it.

1. merge gpm, mod_php, php and aspell (without -gpm in USE flags)
2. add -gpm to USE flags
3. unmerge gpm
4. emerge --deep --update --newuse world
5. restart apache (to see if the php module still works)

run repdev-rebuild

Actual Results:  

Expected Results:  
when running emerge with the --newuse flag the packages php, mod_php and aspell 
should be recompiled aswell

Severity is major because of the fact that apache wont work without php, this 
can be pretty bad for some people, Although i think this bug wont occure verry 
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-09-14 04:26:27 UTC
This is not a bug, emerge --newuse is not designed to fix dependencies caused by
unmerging a library, you need to use revdep-rebuild for that.