Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 105381 - revdep-rebuild has some problems with stat
Summary: revdep-rebuild has some problems with stat
Status: VERIFIED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Paul Varner (RETIRED)
URL:
Whiteboard:
Keywords:
: 107502 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-09-09 06:52 UTC by Olaf Freyer
Modified: 2005-11-12 08:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to fix stat call (revdep-rebuild.105381.patch,330 bytes, patch)
2005-09-09 12:34 UTC, Paul Varner (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Freyer 2005-09-09 06:52:32 UTC
I think it is easiest to show what is happening instead of trying to explain it:

therion aaron # revdep-rebuild
Configuring search environment for revdep-rebuild
stat: kann Dateisysteminformation f
Comment 1 Olaf Freyer 2005-09-09 06:52:32 UTC
I think it is easiest to show what is happening instead of trying to explain it:

therion aaron # revdep-rebuild
Configuring search environment for revdep-rebuild
stat: kann Dateisysteminformation für %m nicht lesen: Datei oder Verzeichnis
nicht gefunden
/usr/bin/revdep-rebuild: line 273: [: too many arguments
stat: kann Dateisysteminformation für %m nicht lesen: Datei oder Verzeichnis
nicht gefunden
/usr/bin/revdep-rebuild: line 273: [: too many arguments
stat: kann Dateisysteminformation für %m nicht lesen: Datei oder Verzeichnis
nicht gefunden
/usr/bin/revdep-rebuild: line 273: [: too many arguments
stat: kann Dateisysteminformation für %m nicht lesen: Datei oder Verzeichnis
nicht gefunden
/usr/bin/revdep-rebuild: line 273: [: too many arguments
stat: kann Dateisysteminformation für %m nicht lesen: Datei oder Verzeichnis
nicht gefunden
/usr/bin/revdep-rebuild: line 273: [: too many arguments
stat: kann Dateisysteminformation für %m nicht lesen: Datei oder Verzeichnis
nicht gefunden
/usr/bin/revdep-rebuild: line 273: [: too many arguments
stat: kann Dateisysteminformation für %m nicht lesen: Datei oder Verzeichnis
nicht gefunden
/usr/bin/revdep-rebuild: line 273: [: too many arguments

versions involved:
app-portage/gentoolkit-0.2.1_pre6
sys-apps/coreutils-5.3.0-r1

I don't have a clue why this is happening, but I am sure I haven't had that
problem in the past.




Reproducible: Always
Steps to Reproduce:

Actual Results:  
revdep-rebuild throwing some strange error messages

Expected Results:  
revdep-rebuild being quite quiet and just doing it's job

therion aaron # emerge info
Portage 2.0.52-r1 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-r8 i686)
=================================================================
System uname: 2.6.12-gentoo-r8 i686 AMD Athlon(tm) XP 2000+
Gentoo Base System version 1.12.0_pre8
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/
http://ftp.easynet.nl/mirror/gentoo/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo"
LANG="de_DE"
LC_ALL="de_DE.utf8"
LINGUAS="de"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 16bit 3dnow 3dnowext X Xaw3d a52 aac aalib acpi alsa apache2 apm arts
audiofile avi bash-completion berkdb bidi bitmap-fonts bmp bzip2 bzlib c++ cdio
cdparanoia cdr cdrom chroot cjk codecs cpudetection crypt css ctype cups curl
dba dga dhcp dio directfb divx4linux dlloader dts dvd dvdr dvdread ecc eds emacs
emboss encode erandom esd exif faac faad fam fb fbcon fbdev ffmpeg flac
font-server foomaticdb fortran freetds freetype gd gdbm gif gphoto2 gpm graphviz
gstreamer gtk gtk2 hal iconv imagemagick imlib ipv6 java javascript jpeg jpeg2k
junit kde kipi libcaca libg++ libwww mad matroska mikmod mime mjpegmpeg mmx
mmxext mng motif mp3 mpeg mpeg4 mplayer mpm-worker mysql ncurses network nls
nptl nptlonly nvidia ogg oggvorbis opengl oscar oss pam pdflib perl php pic pie
png python qt quicktime rar readline real rtc samba sdl slang slq speex spell
sqlite sse ssl stencil-buffer subversion svg svga sysfs tcpd tetex tga theora
threads tidy tiff toolbari truetype truetype-fonts type1 type1-fonts unicode usb
userlocales vidix vim-with-x vorbis win32codecs winbind wxgtk1 wxwindows xine
xml xml2 xmms xprint xsl xslt xv xvid xvmc zlib linguas_de userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, MAKEOPTS, PORTDIR_OVERLAY
Comment 2 Olaf Freyer 2005-09-09 07:48:18 UTC
steps to reproduce:
revdep-rebuild and ctrl-c out of it after a few steps have been done
revdep-rebuild again

so it seems as 'stat'ing it's own progess files is causing the trouble
Comment 3 Paul Varner (RETIRED) gentoo-dev 2005-09-09 12:15:34 UTC
Would someone from the BSD team verify that the following find command is valid
on g/BSD

LIST=~/.revdep-rebuild
find "${LIST%/*}/." ! -name . -prune -name "${LIST##*/}*" -mtime +0

This is to replace the stat call in revdep-rebuild entirely. See bug# #102255
Comment 4 Paul Varner (RETIRED) gentoo-dev 2005-09-09 12:34:05 UTC
Created attachment 68057 [details, diff]
Patch to fix stat call

Attached is a patch that will fix the issue.  It is only guaranteed to work on
Linux.	I am working on a permanent, portable fix.
Comment 5 Paul Varner (RETIRED) gentoo-dev 2005-09-09 13:36:10 UTC
Fix is in subversion
Comment 6 Paul Varner (RETIRED) gentoo-dev 2005-09-12 07:58:10 UTC
gentoolkit-0.2.1_pre7 has been released
Comment 7 Carsten Lohrke (RETIRED) gentoo-dev 2005-09-28 06:21:06 UTC
*** Bug 107502 has been marked as a duplicate of this bug. ***
Comment 8 Paul Varner (RETIRED) gentoo-dev 2005-11-12 08:03:43 UTC
Closing.