Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 105189 - wxGTK-2.6.1 : undefined symbol: pango_x_get_context
Summary: wxGTK-2.6.1 : undefined symbol: pango_x_get_context
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
: 105771 107128 110003 110282 118192 118639 119022 119027 119088 119750 119944 120034 123026 (view as bug list)
Depends on:
Blocks: 107365
  Show dependency tree
 
Reported: 2005-09-07 14:57 UTC by Alexandre Rostovtsev (RETIRED)
Modified: 2006-11-12 12:29 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
wxGTK-2.6.1 ebuild patch (wxGTK-2.6.1-r1.patch,331 bytes, patch)
2005-10-14 09:15 UTC, Sander Sweers
Details | Diff
wxGTK-2.6.1 pango patch (wxGTK-2.6.1-pango_x_get_context-fix.patch,2.24 KB, patch)
2005-10-14 09:17 UTC, Sander Sweers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev (RETIRED) gentoo-dev 2005-09-07 14:57:09 UTC
I emerged the new gtk+-2.8 ebuilds (gtk+-2.8.3-r1, glib-2.8.1, atk-1.10.2,
pango-1.10.0) and then emerged wxGTK-2.6.1. wxGTK compiled correctly; however,
all the wxGTK libraries have "undefined symbol pango_x_get_context" in them, as
can be seen using ldd -r or in gcc errors. Basically, I can't compile any wx
program -- they all fail with "undefined symbol" error at the linking stage.

Furthermore, look at this forum post:
http://forums.gentoo.org/viewtopic-t-372625.html
It looks like even if you had compiled a program with an earlier version of wx
or gtk, it won't run once you upgrade!

Reproducible: Always
Steps to Reproduce:
1. (emerge gtk+-2.8 and related versions of pango, atk etc)
2. emerge wxGTK
3. ldd -r /usr/lib/libwx_gtk2_core-2.6.so

Actual Results:  
undefined symbol: pango_x_get_context   (/usr/lib/libwx_gtk2_core-2.6.so)
        linux-gate.so.1 =>  (0xffffe000)
        libz.so.1 => /lib/libz.so.1 (0xb7caa000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7ca6000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb79b2000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb7932000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb7918000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb7902000)
        libm.so.6 => /lib/tls/libm.so.6 (0xb78de000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb78d7000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb789f000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb7853000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb7827000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb7824000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb781f000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb77ae000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb77ab000)
        libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb77a6000)
        libpng.so.3 => /usr/lib/libpng.so.3 (0xb7772000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb7753000)
        libtiff.so.3 => /usr/lib/libtiff.so.3 (0xb7702000)
        libwx_base-2.6.so.0 => /usr/lib/libwx_base-2.6.so.0 (0xb7606000)
        libstdc++.so.6 => /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/libstdc++.so.6
(0xb7536000)
        libgcc_s.so.1 => /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/libgcc_s.so.1
(0xb752d000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb751a000)
        libc.so.6 => /lib/tls/libc.so.6 (0xb73ff000)
        /lib/ld-linux.so.2 (0x80000000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb7330000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb732c000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0xb7324000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb72f6000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb72ed000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb72e3000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb72d5000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb72d0000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb72ab000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb723e000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb7209000)
        libglitz.so.1 => /usr/lib/libglitz.so.1 (0xb71e4000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0xb71c4000)

Expected Results:  
no undefined symbols

Portage 2.0.51.22-r2 (default-linux/x86/2005.1, gcc-3.4.4-vanilla,
glibc-2.3.5-r1, 2.6.12-gentoo-r9 i686)
=================================================================
System uname: 2.6.12-gentoo-r9 i686 Intel(R) Pentium(R) M processor 1.60GHz
Gentoo Base System version 1.12.0_pre8
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O2 -pipe -frename-registers"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=pentium-m -O2 -pipe -frename-registers"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aac aalib acl acpi alsa apm arts avi bash-completion berkdb
bitmap-fonts bonobo cairo cdparanoia cdr crypt cscope cups curl dbus doc dvd eds
emacs emboss encode esd exif fam flac foomaticdb fortran gd gdbm gif gnome
gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile hal howl ieee1394 imagemagick imlib
ipv6 jack java jpeg kde lcms libg++ libwww mad mikmod mmx mono motif mozilla mp3
mpeg mysql ncurses nls nntp nptl ogg oggvorbis opengl oss pam pcmcia pcre pdflib
perl png postgres python qt quicktime readline ruby samba scanner sdl slang
socks5 speex spell sqlite sse ssl tcltk tcpd tetex theora threads tiff truetype
truetype-fonts type1-fonts unicode usb vorbis win32codecs xemacs xine xinerama
xml xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, LINGUAS
Comment 1 Mart Raudsepp gentoo-dev 2005-09-09 13:03:13 UTC
I had fixed gtk2.8 compatibility some time after the 2.6.1 release.

http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/src/gtk/window.cpp.diff?r1=1.546&r2=1.547
http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/src/gtk/dcclient.cpp.diff?r1=1.203&r2=1.204
http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/include/wx/gtk/window.h.diff?r1=1.126&r2=1.127

Only the first diff is really necessary, other is just related clean-ups.


CVS log entry:

3 weeks, 1 day ago
Wed Aug 17 21:40:44 2005 	MR
Log: [wxGTK2] gtk+-2.8.0 compatibility. Removed the usage of pango_x_get_context
to not depend on a fully deprecated pangox library, which is not pulled in with
gtk+-2.8.0. The pango_x_get_context call was (arguably) making font drawing on
top of a wxDC slightly faster on (especially remote) X11 in case of
non-antialiased fonts (I was unable to find a non-antialiased font that actually
returns true for GetNoAntiAliasing()).


Diff in gtk+ CVS that removed the pangox linking:
http://cvs.gnome.org/viewcvs/gtk%2B/configure.in?r1=1.460&r2=1.461 (look for
"$PKG_CONFIG --exists pangox"

Upstream wxGTK-2.6.2 release that is scheduled (non-fixed) for 18th September
will contain this fix.
Comment 2 INODE64 Sistemas 2005-09-22 13:34:39 UTC
wxGTK-2.6.2 release in 21th September
Comment 3 Jose daLuz 2005-09-27 15:02:22 UTC
2.6.2 is not in portage yet. Is there an update on when it will hit portage?
Comment 4 Zak Peirce 2005-09-30 11:54:52 UTC
Jose daLuz,

I had a silimar issue with another app not running because of this same problem.
 If you want ot try this solution it worked for me.

cd /home/zak
wget http://easynews.dl.sourceforge.net/sourceforge/wxwindows/wxGTK-2.6.2.tar.gz
tar -xfvz wxGTK-2.6.2.tar.gz
cd wxGTK-2.6.2
mkdir unicode
cd unicode
../configure --with-gtk --enable-unicode --enable-opengl --enable-sdl
make
cd lib
cp * /usr/lib/ 
Comment 5 Zak Peirce 2005-09-30 11:57:42 UTC
*** Bug 107128 has been marked as a duplicate of this bug. ***
Comment 6 Jose daLuz 2005-10-08 15:11:54 UTC
@Zak: Thanks for your solution, but as it only affects one application for me,
and not a criticial one at that, I'll wait until 2.6.2 is in portage.
Comment 7 Jose daLuz 2005-10-12 13:31:49 UTC
Now that wxGTK-2.6.2 is in portage (testing) I tried building the two programs I
had problems with.  audacity-1.2.3-r1 depends on wxGTK-2.4* in a separate slot,
so this fix doesn't work for it. Is a backport for other slots on the way?

Secondly, I tried running ipodder, and ran into this error:
ImportError: /usr/lib/python2.4/site-packages/wx-2.6-gtk2-unicode/wx/_misc_.so:
symbol wxDefaultVideoMode, version WXU_2.6 not defined in file
libwx_gtk2u_core-2.6.so.0 with link time reference

I'm assuming this is because the python bindings it depends on, wxpython, is at
2.6.1.0 which wants to downgrade wxGTK to 2.6.1 if I rebuild it. Is
wxpython-2.6.2 on the way, or should I file a bug on this to get it started?
(This last one is not important to me as I'm not overly impressed with ipodder,
but it still needs to be done.)
Comment 8 Mart Raudsepp gentoo-dev 2005-10-12 14:02:46 UTC
A backport should be easy based on my comment #1
Comment 9 Sander Sweers 2005-10-14 09:15:56 UTC
Created attachment 70669 [details, diff]
wxGTK-2.6.1 ebuild patch

ebuild patch
Comment 10 Sander Sweers 2005-10-14 09:17:28 UTC
Created attachment 70670 [details, diff]
wxGTK-2.6.1 pango patch

Attached patch for ebuild and patch against wxWidgets-2.6.1. Can we get this
into portage soon as gnome-2.12 is ~ now?
Comment 11 Radoslaw Szkodzinski 2005-11-16 14:34:43 UTC
As wxPython 2.6.2.0 is not yet ready (and 2.6.1.0 is incompatible with wxGTK
2.6.2), this has to find its way into the tree.
Comment 12 Karol Wojtaszek (RETIRED) gentoo-dev 2005-12-03 03:04:05 UTC
could you test if there is still problem with this bug?
Comment 13 Chris Mayo 2005-12-14 12:05:52 UTC
Compiling pgadmin3-1.4.1 (OK I know it's not in portage - yet) with wxGTK-2.6.1:

x_baseu-2.6  -pthread   -lwx_gtk2u_stc-2.6 -lwx_gtk2u_ogl-2.6 -lwx_baseu-2.6
/usr/lib/libwx_gtk2u_core-2.6.so: undefined reference to `pango_x_get_context'
collect2: ld returned 1 exit status
make[2]: *** [pgadmin3] Error 1
make[2]: Leaving directory `/var/tmp/portage/pgadmin3-1.4.1/work/pgadmin3-1.4.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/var/tmp/portage/pgadmin3-1.4.1/work/pgadmin3-1.4.1'make: *** [all] Error 2


After rebuilding wxGTK with the patches here it compiles fine.


I was also having problems with a wxPython program that did
wxversion.select('2.6-gtk2-ansi') and had to go back to
wxversion.select('2.4-gtk2-ansi') - now they work again using 2.6.

Comment 14 Kyle Hokanson 2005-12-21 04:42:52 UTC
i was having this problem also when trying to emerge boinc. patch fixed it, thanks
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2006-01-07 09:20:11 UTC
*** Bug 118192 has been marked as a duplicate of this bug. ***
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2006-01-11 06:22:25 UTC
*** Bug 118639 has been marked as a duplicate of this bug. ***
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2006-01-14 13:26:44 UTC
*** Bug 119022 has been marked as a duplicate of this bug. ***
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2006-01-14 13:29:21 UTC
*** Bug 110003 has been marked as a duplicate of this bug. ***
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2006-01-15 06:39:45 UTC
*** Bug 119088 has been marked as a duplicate of this bug. ***
Comment 20 RB 2006-01-17 04:28:06 UTC
So...  we're at 2.6.2-r1 in portage, any chance of this making it into at least Gentoo's tree?  I mean, it's not like we don't patch stuff all the time.  I'd really rather not apply a manual patch to a package - too many variables.

Please remember - this breaks quite a few other packages.
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2006-01-20 16:10:23 UTC
*** Bug 119750 has been marked as a duplicate of this bug. ***
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2006-01-22 09:01:16 UTC
*** Bug 119944 has been marked as a duplicate of this bug. ***
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2006-01-23 03:31:47 UTC
*** Bug 120034 has been marked as a duplicate of this bug. ***
Comment 24 Marcelo Goes (RETIRED) gentoo-dev 2006-01-25 17:50:18 UTC
wxWindows Herd, is there anything preventing you from fixing this bug?
Patch comes from upstream - in fact, it's already in 2.6.2.

This bug already has a ton of duplicates.
Any word on this? Would you like help to fix it?
Comment 25 andromede 2006-01-25 22:34:37 UTC
I had same troubles at emerging pgadmin3. Applying attached paches to wxGTK fixed it. Had to md5sum ebuild and patch, edit the Manifest, and then I could emerge.
Would be great that it gets into portage.
Thanks !
Comment 26 Axel Dyks 2006-01-26 08:53:11 UTC
Doesn't "emerge --digest ..." save you from doing the "md5sum" and "Manifest" stuff?

:-) Axel
Comment 27 Marcelo Goes (RETIRED) gentoo-dev 2006-01-26 09:18:53 UTC
wxWindows: I am doing a revbump with the first patch of the list in 24 hours if you don't complain.
Comment 28 Mart Raudsepp gentoo-dev 2006-01-26 10:38:56 UTC
Can I dare to mention that wxPython-2.6.2.1 is out by now, and this isn't really relevant here anymore, assuming wxPython 2.6.2.1 is packaged up, to work together with wxGTK-2.6.2 + patch to bring it up to date to wxPy_2_6_2_1 tag in CVS (which would include the src/common/intl.cpp crasher patch)?

No? Ok, I won't mention it then ;)

I bet a revbump would be much easier at first.
Comment 29 Marcelo Goes (RETIRED) gentoo-dev 2006-01-26 12:39:12 UTC
=wxGTK-2.6.1-r1 has the fix.

alpha, amd64, arm, hppa, ia64, ppc, ppc64, sparc, x86:
please test and stabilize.

Running "ldd -r /usr/lib/libwx_gtk2_core-2.6.so" should be enough to show if the undefined symbol is gone.
Comment 30 Gustavo Zacarias (RETIRED) gentoo-dev 2006-01-26 12:44:53 UTC
sparc stable, wrt bug #120333 too.
Comment 31 Joshua Jackson (RETIRED) gentoo-dev 2006-01-26 21:42:46 UTC
x86 stable
Comment 32 Daniel Black (RETIRED) gentoo-dev 2006-01-27 20:04:36 UTC
*** Bug 110282 has been marked as a duplicate of this bug. ***
Comment 33 Jakub Moc (RETIRED) gentoo-dev 2006-01-28 05:31:02 UTC
*** Bug 105771 has been marked as a duplicate of this bug. ***
Comment 34 Mike Doty (RETIRED) gentoo-dev 2006-01-28 09:15:27 UTC
amd64 stable
Comment 35 Markus Rothe (RETIRED) gentoo-dev 2006-01-28 11:30:01 UTC
stable on ppc64
Comment 36 Tobias Scherbaum (RETIRED) gentoo-dev 2006-01-28 11:45:55 UTC
Already marked ppc stable by hansmi.
Comment 37 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-01-29 23:09:06 UTC
*** Bug 119027 has been marked as a duplicate of this bug. ***
Comment 38 Jose Luis Rivero (yoswink) (RETIRED) gentoo-dev 2006-01-31 03:01:00 UTC
alpha stable wrt bug #120333
Comment 39 Jakub Moc (RETIRED) gentoo-dev 2006-02-16 05:23:35 UTC
*** Bug 123026 has been marked as a duplicate of this bug. ***
Comment 40 Gustavo Zacarias (RETIRED) gentoo-dev 2006-03-22 14:05:13 UTC
hppa stable, we're last, closing.