Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 104408 - new ebuild for x11-plugins/icqnd - a GTK2-gui for Licq
Summary: new ebuild for x11-plugins/icqnd - a GTK2-gui for Licq
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
Keywords: EBUILD
: 110723 (view as bug list)
Depends on:
Reported: 2005-08-31 11:49 UTC by Hanno Zysik (geki)
Modified: 2009-06-24 09:07 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

icqnd- (icqnd-,1.02 KB, text/plain)
2005-08-31 11:51 UTC, Hanno Zysik (geki)
strip newline of messages in chat-window (gentoo.diff,433 bytes, patch)
2005-08-31 11:52 UTC, Hanno Zysik (geki)
Details | Diff
corrected icqnd- ebuild (icqnd-,1.02 KB, text/plain)
2005-08-31 13:31 UTC, Hanno Zysik (geki)
icqnd ebuild (icqnd-,1.01 KB, text/plain)
2005-09-12 10:48 UTC, Hanno Zysik (geki)
x11-themes/icqnd- (icqnd-,931 bytes, text/plain)
2005-09-18 23:58 UTC, Hanno Zysik (geki)
icqnd- (icqnd-,931 bytes, text/plain)
2005-10-06 06:09 UTC, Hanno Zysik (geki)
icqnd (icqnd-,940 bytes, text/plain)
2006-03-04 12:13 UTC, Hanno Zysik (geki)
xinerama hack, tooltip popup top-left corner (xinerama.diff,317 bytes, patch)
2006-03-21 06:00 UTC, Hanno Zysik (geki)
Details | Diff released (icqnd-,686 bytes, text/plain)
2006-07-06 06:22 UTC, Hanno Zysik (geki)
strip newline patch - update (chomp-msg.diff,456 bytes, patch)
2006-07-06 06:23 UTC, Hanno Zysik (geki)
Details | Diff
open link in browser crashfix / workaround (crashfix-open-link-in-browser.diff,424 bytes, patch)
2006-07-07 07:00 UTC, Hanno Zysik (geki)
Details | Diff
[options dialog] set correct status on apply (options-startup-status-fix.diff,691 bytes, patch)
2006-07-07 09:17 UTC, Hanno Zysik (geki)
Details | Diff
version 2 - safer check of i (options-startup-status-fix.diff,729 bytes, patch)
2006-07-07 09:32 UTC, Hanno Zysik (geki)
Details | Diff version 2 (icqnd-,864 bytes, text/plain)
2006-07-07 09:34 UTC, Hanno Zysik (geki)
x86_64-gpointer-fix.diff - handles gpointer correctly for x86_64 (x86_64-gpointer-fix.diff,1.98 KB, patch)
2006-09-07 17:05 UTC, Sebastian Stammler
Details | Diff version 3 (icqnd-,821 bytes, text/plain)
2006-09-08 01:15 UTC, Hanno Zysik (geki)
icqnd (icqnd-,888 bytes, text/plain)
2006-09-20 00:00 UTC, Hanno Zysik (geki)
icqnd- (icqnd-,1.02 KB, text/plain)
2007-02-19 19:18 UTC, Daniel Nilsson
gpgme.m4 (gpgme.m4,10.05 KB, text/plain)
2007-02-19 19:18 UTC, Daniel Nilsson

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Zysik (geki) 2005-08-31 11:49:17 UTC
Reasons for its existance and details about its features and future features are
on the URL given to this bugreport.

I will add an ebuild that merges the plugin which you can then use with 'licq -p
icqnd'. It is in (pre-)alpha stadium but already useable (chat, file-transfers,
etc). I use it without alternatives installed. Since it is (pre-)alpha I set the
CFLAGS/CXXFLAGS to '-O0' to use gdb for debugging if it segfaults. Only one
known segfault right now, update all users, which the developer fixed in his source.

I will also add a diff to kill the newline at the end of messages in chat-window
which causes a variable without g_free'ing. The developer will fix that somewhen.

Reproducible: Always
Steps to Reproduce:
1. emerge icqnd

Actual Results:  
missing up2date gtk2 plugin for licq

Expected Results:  
up2date gtk2 plugin for licq
Comment 1 Hanno Zysik (geki) 2005-08-31 11:51:12 UTC
Created attachment 67360 [details]
Comment 2 Hanno Zysik (geki) 2005-08-31 11:52:16 UTC
Created attachment 67361 [details, diff]
strip newline of messages in chat-window
Comment 3 Hanno Zysik (geki) 2005-08-31 13:31:48 UTC
Created attachment 67367 [details]
corrected icqnd- ebuild
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-09-11 17:28:36 UTC
Please, fix the following problems and reopen then:

2/ (ebuild version)
3/ (~ppc ~sparc ~alpha
5/ (pkg_setup, pkg_postrm)
6/ You inherit flag-o-matic eclass but then just export C[XX]FLAGS.
Comment 5 Hanno Zysik (geki) 2005-09-12 10:47:51 UTC
updated ebuild - i hope i solved some issues
- moved RDEPEND packages to DEPEND, compile-time dependend. added DEPEND in RDEPEND (end)
- that 1.3.1 at the end of the tarball does not belong to the version of icqnd
but however used versionator

talked to the dev to drop that useless 1.3.1 from the tarball name.
Comment 6 Hanno Zysik (geki) 2005-09-12 10:48:43 UTC
Created attachment 68268 [details]
icqnd ebuild
Comment 7 Hanno Zysik (geki) 2005-09-12 15:26:53 UTC
Comment on attachment 68268 [details]
icqnd ebuild


needs to be

Comment 8 Hanno Zysik (geki) 2005-09-16 00:19:50 UTC
inherit flag-o-matic

will drop:
versionator stuff

on src_compile dropped:
    export CFLAGS="-O0 -pipe"
    export CXXFLAGS="-O0 -pipe"

and added instead:
    replace-flags "-O?" "-O0"

up2date ebuild when dev releases new version without that '1.3.1'.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2005-09-16 03:15:06 UTC
eerror is used for displaying error messages. Unless the whole ebuild is an
error :=) you should ewarn instead...
Comment 10 Hanno Zysik (geki) 2005-09-18 23:58:59 UTC
Created attachment 68793 [details]

now, if you got something to complain about send patches. thanks. ;)
strip newline patch still applies.
Comment 11 Hanno Zysik (geki) 2005-09-19 00:12:17 UTC
arg, coffee was not hard enough.
sure it is not x11-themes. lol.

btw, since licq upstream fixed some annoying invisible bugs it would be good to
have a new snapshot of licq. sep, 3rd still got that bugs.
too annoying to fill in new bugreport for that. tell the licq maintainer or
leave it. ;)
Comment 12 Hanno Zysik (geki) 2005-10-06 06:09:35 UTC
Created attachment 69980 [details]

Comment 13 Konstantin Arkhipov (RETIRED) gentoo-dev 2005-11-11 11:19:30 UTC
*** Bug 110723 has been marked as a duplicate of this bug. ***
Comment 14 Hanno Zysik (geki) 2006-03-04 12:13:42 UTC
Created attachment 81336 [details]
Comment 15 Hanno Zysik (geki) 2006-03-21 06:00:50 UTC
Created attachment 82774 [details, diff]
xinerama hack, tooltip popup top-left corner
Comment 16 Hanno Zysik (geki) 2006-07-06 06:21:28 UTC
Comment on attachment 82774 [details, diff]
xinerama hack, tooltip popup top-left corner

ugly hack. better to disable tooltips! ;)
Comment 17 Hanno Zysik (geki) 2006-07-06 06:22:39 UTC
Created attachment 91040 [details] released
Comment 18 Hanno Zysik (geki) 2006-07-06 06:23:22 UTC
Created attachment 91041 [details, diff]
strip newline patch - update
Comment 19 Hanno Zysik (geki) 2006-07-07 07:00:10 UTC
Created attachment 91133 [details, diff]
open link in browser crashfix / workaround

upstream bugreport
Comment 20 Hanno Zysik (geki) 2006-07-07 09:17:00 UTC
Created attachment 91147 [details, diff]
[options dialog] set correct status on apply
Comment 21 Hanno Zysik (geki) 2006-07-07 09:32:37 UTC
Created attachment 91148 [details, diff]
version 2 - safer check of i
Comment 22 Hanno Zysik (geki) 2006-07-07 09:34:08 UTC
Created attachment 91149 [details] version 2
Comment 23 Jiří Vyskočil 2006-07-17 14:50:38 UTC
I have a problem I saved "strip newline patch - update" as files/chomp-msg.diff
"open link in browser crashfix / workaround" as files/crashfix-open-link-in-browser.diff and "version 2 - safer check of i" as files/options-startup-status-fix.diff, but all the patches fail with something like:

***** options-startup-status-fix.diff *****


PATCH COMMAND:  patch -p0 -g0 -E --no-backup-if-mismatch < /usr/local/portage/x11-plugins/icqnd/files/options-startup-status-fix.diff

patching file src/optionswindow.cpp
Hunk #1 FAILED at 3365.
1 out of 1 hunk FAILED -- saving rejects to file src/optionswindow.cpp.rej

....... several 'No file to patch' messages .................

If I comment out all the patches, it won't build:

make  all-recursive
make[1]: Entering directory `/var/tmp/portage/icqnd-'
Making all in src
make[2]: Entering directory `/var/tmp/portage/icqnd-'
if /bin/sh ../libtool --silent --tag=CXX --mode=compile i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/licq -I../include -D_REENTRANT -Wall -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include     -fPIC -DPIC -D_REENTRANT  -O2 -march=pentium4 -fomit-frame-pointer -pipe -Wall -MT contactsselection.lo -MD -MP -MF ".deps/contactsselection.Tpo" -c -o contactsselection.lo contactsselection.cpp; \
        then mv -f ".deps/contactsselection.Tpo" ".deps/contactsselection.Plo"; else rm -f ".deps/contactsselection.Tpo"; exit 1; fi
/usr/include/licq/licq_buffer.h:65: error: extra qualification 'CBuffer::' on member 'PackLNTS'
make[2]: *** [contactsselection.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/icqnd-'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/icqnd-'
make: *** [all] Error 2

did I do something wrong? (other ebuilds from my overlay work, as well as older icqnd ebuilds)
Comment 24 Hanno Zysik (geki) 2006-07-17 16:06:16 UTC
I guess you safed the patches in html  html format or alike.
They apply fine here.

Please do discussion here, thanks!
Comment 25 Jiří Vyskočil 2006-07-18 00:40:04 UTC
Indeed, I must have done something strange with them - I used the precious copy-from-firefox-paste-into-nano procedure, but it somehow screwed those files (i guess some newline abnormalities) right-click on the link + 'save as' worked. Thanks for your help.

The compilation problem is still here, I will continue discussing that on the forum.
Comment 26 Sebastian Stammler 2006-09-07 17:05:37 UTC
Created attachment 96345 [details, diff]
x86_64-gpointer-fix.diff - handles gpointer correctly for x86_64

i created this patch because i couldn't compile on my x86_64 box. the error was:
error: cast from 'void*' to 'guint' loses precision
on amd64 you have to use GPOINTER_TO_INT to compile...
please also add this to the ebuild in the src_unpack() function:

	# compilation fix on x86_64 machines to use GPOINTER_TO_INT macro
	# instead of (guint)
	epatch ${FILESDIR}/x86_64-gpointer-fix.diff

thank you, sebastian
Comment 27 Hanno Zysik (geki) 2006-09-08 01:15:59 UTC
Created attachment 96367 [details] version 3

Thank you, Sebastian!
Comment 28 Hanno Zysik (geki) 2006-09-20 00:00:01 UTC
Created attachment 97513 [details]

also fixes x64 pointer issue
Comment 29 Sebastian Stammler 2006-09-20 08:34:56 UTC
that's great. i sent them my patch on their page. fortunately, as we see, they added this in their new release ^^
Comment 30 Daniel Nilsson 2006-09-29 03:14:40 UTC
Thanks for the ebuilds, I hope it makes it into portage some day...

I have a problem with the latest version though:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-plugins/icqnd- [] USE="-debug -gnome -spell%" 0 kB [1] 
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-gtkspell --build=i686-pc-linux-gnu
checking for GTKSPELL... configure: error: Package requirements (gtk+-2.0 gtkspell-2.0) were not met:

No package 'gtkspell-2.0' found

Looks like it wants gtkspell even when though I have disabled the spell use-flag. Am I doing something wrong? Is it a problem in the ebuild? Is it a bug in upstreams configure logic?
I know nothing of how configure and such stuff works so I am unable to debug it myself. If you wand more info (config.log, emerge --info, etc.) just say so and I will attach it.
Comment 31 Daniel Nilsson 2006-10-15 09:25:57 UTC
There is an upstream bug for the configure problem here:
Just making the ebuild apply the patch from that bug does not fix the issue. The patch is for and it's beyond my knowledge how to change the ebuild so that it regenerates configure from that file.
Comment 32 Daniel Nilsson 2006-10-19 14:03:02 UTC
After a fair bit of research I added
  autoconf || die "autoconf failed!"
to the top of src_compile (I'm not sure if that is the right way to do it, though). This regenerates configure so that goes past the place where it failed before. Now it stops a bit later instead with this error:

configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating share/Makefile
config.status: creating config.h
config.status: executing default-1 commands
cd . && aclocal-1.4
aclocal: 0: macro `AM_PATH_GPGME' not found in library
make: *** [aclocal.m4] Error 1

My small knowledge of autotools and my spare time ran out there. But if no one with better understanding of the problem steps in I might look into it when I gat som free time again. By the way icqnd- works with the new licq after a reemerge!
Comment 33 Daniel Nilsson 2007-02-19 19:16:31 UTC
Well, I had some time to kill so I spent it on this ebuild. Now it emerges correctly with -spell. I found that I had to add the file gpgme.m4 (I found it somewhere on the net) so that aclocal finds it. I put it in ${FILESDIR} and copy it into ${S}/m4 in src_install. The ebuild also needs icqnd-configure-gtkspell.diff from the url in Comment #31.
I'll attach the modified ebuild and the m4-file.
Comment 34 Daniel Nilsson 2007-02-19 19:18:01 UTC
Created attachment 110679 [details]
Comment 35 Daniel Nilsson 2007-02-19 19:18:45 UTC
Created attachment 110681 [details]
Comment 36 Hanno Zysik (geki) 2007-02-24 15:26:27 UTC
icqnd-0.2 (first beta) released!

for ease of use I tar'ed it up for overlay use:

this update mixed up my config a bit. just reconfigure and have fun!
Comment 37 Petr Zima 2008-07-02 11:56:28 UTC
Anyone still interested? I am using an ugly simple ebuild for 0.2beta, which satisfies my needs. Has anyone a more or less proper one (e.g. with spellcheck like 0.1.9 etc.)?
Comment 38 Hanno Zysik (geki) 2009-06-24 09:07:51 UTC
upstream died