Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 102911 - tos-simdriver-1.1.14 for tinyos 1.1.14
Summary: tos-simdriver-1.1.14 for tinyos 1.1.14
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Embedded Team (OBSOLETE)
URL: http://www.tinyos.net
Whiteboard:
Keywords: EBUILD
Depends on: 102630 102627 102629 102634 102910
Blocks: 78908
  Show dependency tree
 
Reported: 2005-08-17 15:12 UTC by Sandro Bonazzola (RETIRED)
Modified: 2010-11-07 19:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tos-simdriver-1.1.14 (tos-simdriver-1.1.14.ebuild,2.76 KB, text/plain)
2005-08-17 15:17 UTC, Sandro Bonazzola (RETIRED)
Details
tinyviz script. (tinyviz,687 bytes, text/plain)
2005-08-17 15:18 UTC, Sandro Bonazzola (RETIRED)
Details
simdriver script. (simdriver,685 bytes, text/plain)
2005-08-17 15:18 UTC, Sandro Bonazzola (RETIRED)
Details
modified simdriver script (simdriver,589 bytes, text/plain)
2005-10-10 06:10 UTC, Wouter Horré
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sandro Bonazzola (RETIRED) gentoo-dev 2005-08-17 15:12:43 UTC
SimDriver for tinyos-1.1.14, the evolution of tinyviz.
an ebuild will follow.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Sandro Bonazzola (RETIRED) gentoo-dev 2005-08-17 15:15:51 UTC
I've tested the ebuild with the libraries provided in tinyos-1.x/tools/java/jars
and some dummy ebuild I've wrote to install them in the right location.
Hopefully this should work with the correct ebuild when the ebuilds will be
available.
Comment 2 Sandro Bonazzola (RETIRED) gentoo-dev 2005-08-17 15:17:28 UTC
Created attachment 66183 [details]
tos-simdriver-1.1.14

need tinyviz and simdriver in files.
Comment 3 Sandro Bonazzola (RETIRED) gentoo-dev 2005-08-17 15:18:03 UTC
Created attachment 66184 [details]
tinyviz script.
Comment 4 Sandro Bonazzola (RETIRED) gentoo-dev 2005-08-17 15:18:35 UTC
Created attachment 66185 [details]
simdriver script.
Comment 5 Wouter Horré 2005-10-10 06:07:54 UTC
The provided simdriver script does not work for me. According to java-maintainer
axxo the -jar option makes java ignore -cp. 
The correct way is: java -cp <ClassPath> <MainClass>.
In this case:
exec ${MY_JAVA} -cp ${MY_CP} ${MY_ARGS} ${MY_MAIN} "${@}"
where MY_MAIN="net.tinyos.sim.SimDriver"
Comment 6 Wouter Horré 2005-10-10 06:10:06 UTC
Created attachment 70289 [details]
modified simdriver script

See comment #5
Comment 7 Sandro Bonazzola (RETIRED) gentoo-dev 2005-10-10 11:26:36 UTC
(In reply to comment #5)
> The provided simdriver script does not work for me. 

mmm can you attach the output? Your solution may be better but since here it
works fine, I'm curios about the error displayed.

Comment 8 Wouter Horré 2005-10-10 11:38:51 UTC
The output with the original simdriver script on my system is:
Starting SimDriver...
Simulation random seed 68261714
Initializing simulator objects...
Exception in thread "main" java.lang.NoClassDefFoundError:
net/tinyos/message/MessageFactory
        at net.tinyos.sim.SimCommands.<clinit>(SimCommands.java:56)
        at net.tinyos.sim.SimDriver.<init>(SimDriver.java:244)
        at net.tinyos.sim.SimDriver.main(SimDriver.java:539)
Comment 9 Aurélien Francillon 2006-01-16 08:13:25 UTC
does not changes in the release of tinyos 1.1.15, no ebuild update required
Comment 10 Aurélien Francillon 2006-01-16 08:16:00 UTC
hum ... actually it depends on tos-tython and tos-packet who are updated in 1.1.15 what should be done ? just a -r1 with updated dependency versions ?
Comment 11 Sandro Bonazzola (RETIRED) gentoo-dev 2006-03-26 03:41:33 UTC
Adding java package freeze as blocker.
Comment 12 Sandro Bonazzola (RETIRED) gentoo-dev 2006-11-06 11:24:55 UTC
On my queue.
Comment 13 Christian Heim (RETIRED) gentoo-dev 2007-08-10 19:45:13 UTC
Sanchan has been retired.
Comment 14 Samuli Suominen gentoo-dev 2010-11-07 19:04:59 UTC
tinyos was removed from tree. closing.