Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 102338 - cannot run python after booting with 2005.1 x86 minimal
Summary: cannot run python after booting with 2005.1 x86 minimal
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-13 01:23 UTC by Paul Malherbe
Modified: 2005-08-15 11:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Malherbe 2005-08-13 01:23:28 UTC
When trying to run python after booting with the 2005.1 x86 minimal cd it
complains that libstdc++.so.5 is missing.

Reproducible: Always
Steps to Reproduce:
1.Boot with 2005.1 x86 minimal cd
2.enter python
3.

Actual Results:  
python: error while loading shared libraries: libstdc++.so.5: cannot open shared
object file: No such file or directory

Expected Results:  
run python
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2005-08-15 06:45:49 UTC
I am aware of this, as python is not designed to be usable on the CD.
Comment 2 Paul Malherbe 2005-08-15 11:44:29 UTC
This seems to be inconsistant as python was available and did work on 2005.0
In fact, based on this, we wrote installation scripts in python which now will
not execute.
Comment 3 Chris Gianelloni (RETIRED) gentoo-dev 2005-08-15 11:53:09 UTC
...OK

I have no intention on making it work on the InstallCD images, as it is not
required for doing a normal Gentoo installation.  The minimal InstallCD is
exactly that.  Python being functional in 2005.0 was probably more of an
accident than anything else.  If you require a complete and working python
environment, then I would suggest using the LiveCD image instead, as it is
designed for this purpose.