Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 101080 - x11-libs/pango 1.8.2 garbled display - anjuta / komodo
Summary: x11-libs/pango 1.8.2 garbled display - anjuta / komodo
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 101829 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-02 04:09 UTC by Glenn L. McGrath
Modified: 2005-08-15 14:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Screenshot showing garbled text (Screenshot.png,149.94 KB, image/png)
2005-08-02 05:34 UTC, Glenn L. McGrath
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Glenn L. McGrath 2005-08-02 04:09:44 UTC
When i open a file in anjuta the contents of the file are scrambled across the
screen, often overlapping other text and sometimes blinking or moving across the
screen. When i move the mouse its gets re-scrambled, its very weird....

I dont know what to look at for more information, looking at the emerge logs, i
have recently upgraded x11-wm/metacity-2.10.3, x11-libs/libwnck-2.10.3,
x11-libs/pango-1.8.2, dev-libs/libxslt-1.1.14-r2

My guess is that it could be pango, will keep looking for clues.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Glenn L. McGrath 2005-08-02 04:35:19 UTC
I create a new user and the anjuta works correctly.

As the buggy user deleting the .anjuta directory makes no difference.

It must be one of the other dot files.
Comment 2 Glenn L. McGrath 2005-08-02 05:00:26 UTC
hmm, scrath my previous idea.

anjuta doesnt display a file correctly even on the newly creeated user.

A simple text file can display correctly, its the highlighting (selecting text)
or special code (eg c keywords) that appears to be driving it crazy.

trying to open ~/.anjuta/user.properties causes anjuta to crash.
Comment 3 Glenn L. McGrath 2005-08-02 05:34:13 UTC
Created attachment 64932 [details]
Screenshot showing garbled text

As you can see from the screenshot the highleghted text isnt correct, its
supposed to be the GPLv2 text from /usr/kde/3.4/share/apps/LICENSES/GPL_V2
Comment 4 Jean Bréfort 2005-08-04 03:28:56 UTC
This also occurs on an x86 box.
This happens only since recently, probably after the update of a library anjuta
depends on, but I do not know which one...
Comment 5 John N. Laliberte (RETIRED) gentoo-dev 2005-08-06 05:07:00 UTC
could you please try with pango-1.8.1 instead of .2 and report back results?

Thanks!
Comment 6 Glenn L. McGrath 2005-08-06 06:09:06 UTC
Yea, downgrading from pango-1.8.2 to 1.8.1 fixed it for me :)
Comment 7 Jean Bréfort 2005-08-06 06:17:55 UTC
The same for me with 1.8.1-r1
Comment 8 John N. Laliberte (RETIRED) gentoo-dev 2005-08-09 06:18:48 UTC
*** Bug 101829 has been marked as a duplicate of this bug. ***
Comment 9 Alexandre Sanches 2005-08-12 20:31:41 UTC
Exactly the same problem occurs with SciTE on my amd64 box : with Pango-1.8.1,
all is correct, with Pango 1.8.2, any text restitution can become randomly
crappy. So the problem is somewhere between Pango-1.8.2 and the Scintilla text
widget... Where ? I don't know ! And my knowledge about both is alas very
poor... In my opinion Pango-1.8.2 should be hard masked.
Comment 10 Leonardo Boshell (RETIRED) gentoo-dev 2005-08-15 13:45:27 UTC
The problems are due to a recent change that is not going to be reverted in
pango.  The specific applications/libraries that relied on the old behaviour
will have to be fixed (I think anjuta already released a new version with a fix
for this problem).

For more information see http://bugzilla.gnome.org/show_bug.cgi?id=312075.
Comment 11 Jean Bréfort 2005-08-15 14:02:32 UTC
anjuta has already been fixed. Just waiting for anjuta-1.2.3.ebuild ;-)