Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 100873 - Ebuild for wavegain wanted.
Summary: Ebuild for wavegain wanted.
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-31 03:05 UTC by Peter
Modified: 2006-07-23 08:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
wavegain-1.2.4.ebuild (wavegain-1.2.4.ebuild,647 bytes, text/plain)
2005-07-31 09:15 UTC, Tony Vroon
Details
wavegain-1.2.4.ebuild (wavegain-1.2.4.ebuild,482 bytes, text/plain)
2005-08-13 09:00 UTC, 4nykey
Details
a diff used in ebuild (nix.diff,3.17 KB, text/plain)
2005-08-13 09:00 UTC, 4nykey
Details
wavegain-1.2.6.ebuild (wavegain-1.2.6.ebuild,614 bytes, text/plain)
2006-07-23 08:07 UTC, Ben de Groot (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2005-07-31 03:05:02 UTC
I'd like to request an ebuild for the minor program, wavegain. The program works
with the same intent as vorbisgain and mp3gain, but by applying physical gain to
wav-files.
http://freshmeat.net/projects/wavegain/
N.B. It would seems it's originally compiled for Win32, and a patch was/is?
needed : http://www.hydrogenaudio.org/forums/index.php?showtopic=3868 and
http://www.hydrogenaudio.org/forums/index.php?showtopic=19426

An unofficial working debian-package should be at:
http://rarewares.org/debian-info-misc.html
http://rarewares.org/debian/packages/unstable/index.php

Regards,
Peter

Reproducible: Always
Steps to Reproduce:
1. Look boggled at source-code
2. Scratch head in bewilderment
3. Search for non-existant programming/coding/debugging skills
4. File a bug report applying big wet pleading puppy-eyes.
Actual Results:  
Nothing much. Well, atleast not in regards to the ebuild. The rest of the world
was probably quite busy and stuff happened elsewhere. 

Expected Results:  
Magically do my bidding and made an ebuild out of thin air?
Comment 1 Tony Vroon gentoo-dev 2005-07-31 09:15:23 UTC
Created attachment 64791 [details]
wavegain-1.2.4.ebuild

Alright, it compiles for me this way. Tell me if it works.
Comment 2 Tony Vroon gentoo-dev 2005-07-31 09:31:51 UTC
chainsaw@adrastea ~ $ wavegain stalker.wav
  -4.34 dB |  32767 |  0.61 |    19881 |  -72  |   -30  | stalker.wav

 Recommended Album Gain:  -3.34 dB      Scale: 0.6808


 WaveGain Processing completed normally
*** glibc detected *** wavegain: free(): invalid next size (fast): 0x08073030 ***
======= Backtrace: =========
/lib/libc.so.6[0xa7e2597a]
/lib/libc.so.6(__libc_free+0x82)[0xa7e263a2]
wavegain[0x804bc28]
/lib/libc.so.6(__libc_start_main+0xe4)[0xa7dd7544]
wavegain[0x8048bb1]
======= Memory map: ========
08048000-08051000 r-xp 00000000 08:03 988690     /usr/bin/wavegain
08051000-08052000 rw-p 00009000 08:03 988690     /usr/bin/wavegain
08052000-08094000 rw-p 08052000 00:00 0          [heap]
a7c00000-a7c21000 rw-p a7c00000 00:00 0
a7c21000-a7d00000 ---p a7c21000 00:00 0
a7db6000-a7dc0000 r-xp 00000000 08:03 1851996   
/usr/lib/gcc/i686-pc-linux-gnu/4.0.1/libgcc_s.so.1
a7dc0000-a7dc1000 rw-p 00009000 08:03 1851996   
/usr/lib/gcc/i686-pc-linux-gnu/4.0.1/libgcc_s.so.1
a7dc1000-a7dc2000 rw-p a7dc1000 00:00 0
a7dc2000-a7ed8000 r-xp 00000000 08:03 1933827    /lib/libc-2.3.90.so
a7ed8000-a7ed9000 r--p 00116000 08:03 1933827    /lib/libc-2.3.90.so
a7ed9000-a7edc000 rw-p 00117000 08:03 1933827    /lib/libc-2.3.90.so
a7edc000-a7edf000 rw-p a7edc000 00:00 0
a7edf000-a7f2d000 r-xp 00000000 08:03 360507     /usr/lib/libsndfile.so.1.0.11
a7f2d000-a7f32000 rw-p 0004e000 08:03 360507     /usr/lib/libsndfile.so.1.0.11
a7f32000-a7f36000 rw-p a7f32000 00:00 0
a7f36000-a7f5b000 r-xp 00000000 08:03 1933834    /lib/libm-2.3.90.so
a7f5b000-a7f5d000 rw-p 00024000 08:03 1933834    /lib/libm-2.3.90.so
a7f74000-a7f75000 rw-p a7f74000 00:00 0
a7f75000-a7f8f000 r-xp 00000000 08:03 1933841    /lib/ld-2.3.90.so
a7f8f000-a7f90000 r--p 00019000 08:03 1933841    /lib/ld-2.3.90.so
a7f90000-a7f91000 rw-p 0001a000 08:03 1933841    /lib/ld-2.3.90.so
afd79000-afd8f000 rw-p afd79000 00:00 0          [stack]
ffffe000-fffff000 ---p 00000000 00:00 0          [vdso]
Aborted

This package is broken, at least under GCC 4. It needs work in order to be
accepted for inclusion.
Comment 3 4nykey 2005-08-13 09:00:01 UTC
Created attachment 65846 [details]
wavegain-1.2.4.ebuild

Hello, I've been using this ebuild, compiled with gcc4, haven't noticed any
troubles.
Not that I use it frquently though.
Comment 4 4nykey 2005-08-13 09:00:44 UTC
Created attachment 65847 [details]
a diff used in ebuild
Comment 5 Ben de Groot (RETIRED) gentoo-dev 2006-07-23 08:07:54 UTC
Created attachment 92554 [details]
wavegain-1.2.6.ebuild

This ebuild for the new version works for me with gcc4.