Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 678642

Summary: =media-gfx/blender-2.79b-r1 stabilization request
Product: Gentoo Linux Reporter: Sergei Trofimovich <slyfox>
Component: StabilizationAssignee: Adrian <agrigo2001>
Status: RESOLVED FIXED    
Severity: normal CC: agrigo2001, dracwyrm, graphics+disabled, proxy-maint
Priority: Normal Keywords: STABLEREQ
Version: unspecifiedFlags: stable-bot: sanity-check+
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=661066
Whiteboard:
Package list:
media-gfx/blender-2.79b-r1
Runtime testing required: ---
Bug Depends on: 680624, 620324, 639804, 639806, 642270, 686456    
Bug Blocks: 678254    

Description Sergei Trofimovich gentoo-dev 2019-02-23 18:44:24 UTC
gcc-8 will go stable soon: bug #678254

Current stable blender fails build as reported in bug #661066. Please consider stabling new version or backport gcc-8 fix.
Comment 1 Sergei Trofimovich gentoo-dev 2019-02-28 07:43:00 UTC
Arches, please stabilize for:
    amd64 x86
Comment 2 Stabilization helper bot gentoo-dev 2019-02-28 08:05:42 UTC
An automated check of this bug failed - repoman reported dependency errors (19 lines truncated): 

> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: DEPEND: x86(default/linux/x86/17.0) ['>=media-libs/openimageio-1.7.0', '>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: RDEPEND: x86(default/linux/x86/17.0) ['>=media-libs/openimageio-1.7.0', '>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: DEPEND: x86(default/linux/x86/17.0/desktop) ['>=media-libs/openimageio-1.7.0', '>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-02-28 14:55:56 UTC
amd64 stable
Comment 4 Stabilization helper bot gentoo-dev 2019-02-28 15:01:10 UTC
An automated check of this bug failed - repoman reported dependency errors (19 lines truncated): 

> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: DEPEND: x86(default/linux/x86/17.0) ['>=media-libs/openimageio-1.7.0', '>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: RDEPEND: x86(default/linux/x86/17.0) ['>=media-libs/openimageio-1.7.0', '>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: DEPEND: x86(default/linux/x86/17.0/desktop) ['>=media-libs/openimageio-1.7.0', '>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
Comment 5 Stabilization helper bot gentoo-dev 2019-03-16 21:00:53 UTC
An automated check of this bug failed - repoman reported dependency errors (19 lines truncated): 

> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: DEPEND: x86(default/linux/x86/17.0) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: RDEPEND: x86(default/linux/x86/17.0) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79b-r1.ebuild: DEPEND: x86(default/linux/x86/17.0/desktop) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-gfx/openvdb[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_7(-),python_single_target_python3_5(+)?,python_single_target_python3_6(+)?,-abi3-compat(-),abi4-compat(+)]', 'media-libs/osl:=']
Comment 6 Sergei Trofimovich gentoo-dev 2019-11-01 23:40:11 UTC
Give that latest stable blender on x86 was removed and nobody complained let's assume there are no 32-bit users of it.

Closing the bug. If someone reports blender working on x86 we can stable it back.