Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 661066 - media-gfx/blender-2.79-r1 with sys-devel/gcc-8.1.0-r3 - /usr/lib/gcc/x86_64-pc-linux-gnu/8.1.0/include/g++-v8/bits/stl_map.h:122:21: error: static assertion failed: std::map must have the same value_type as its allocator
Summary: media-gfx/blender-2.79-r1 with sys-devel/gcc-8.1.0-r3 - /usr/lib/gcc/x86_64-p...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jonathan Scruggs (RETIRED)
URL:
Whiteboard:
Keywords: PATCH
: 662248 (view as bug list)
Depends on: 650592
Blocks: gcc-8
  Show dependency tree
 
Reported: 2018-07-13 11:41 UTC by Dennis Schridde
Modified: 2019-02-23 18:44 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,447.72 KB, text/x-log)
2018-07-13 11:41 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2018-07-13 11:41:47 UTC
Created attachment 539366 [details]
build.log

In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/8.1.0/include/g++-v8/map:61,
                 from /var/tmp/portage/media-gfx/blender-2.79-r1/work/blender-2.79/intern/itasc/kdl/tree.hpp:29,
                 from /var/tmp/portage/media-gfx/blender-2.79-r1/work/blender-2.79/intern/itasc/eigen_types.hpp:13,
                 from /var/tmp/portage/media-gfx/blender-2.79-r1/work/blender-2.79/intern/itasc/ControlledObject.hpp:12,
                 from /var/tmp/portage/media-gfx/blender-2.79-r1/work/blender-2.79/intern/itasc/Armature.hpp:11,
                 from /var/tmp/portage/media-gfx/blender-2.79-r1/work/blender-2.79/intern/itasc/Armature.cpp:11:
/usr/lib/gcc/x86_64-pc-linux-gnu/8.1.0/include/g++-v8/bits/stl_map.h: In instantiation of ‘class std::map<std::__cxx11::basic_string<char>, KDL::TreeElement, std::less<std::__cxx11::basic_string<char> >, Eigen::aligned_allocator<std::pair<std::__cxx11::basic_string<char>, 
KDL::TreeElement> > >’:
/var/tmp/portage/media-gfx/blender-2.79-r1/work/blender-2.79/intern/itasc/kdl/tree.hpp:47:19:   required from here
/usr/lib/gcc/x86_64-pc-linux-gnu/8.1.0/include/g++-v8/bits/stl_map.h:122:21: error: static assertion failed: std::map must have the same value_type as its allocator                                                                                                            
       static_assert(is_same<typename _Alloc::value_type, value_type>::value,
                     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


Portage 2.3.42 (python 2.7.13-final-42, default/linux/amd64/17.1/desktop/plasma/systemd, gcc-8.1.0, glibc-2.27-r5, 4.17.4-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.17.4-gentoo-x86_64-AMD_Ryzen_5_2400G_with_Radeon_Vega_Graphics-with-gentoo-2.6
KiB Mem:    15258792 total,   3436304 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 13 Jul 2018 07:45:01 +0000
Head commit of repository gentoo: a30437c0c5fb08780562baccb5ff3eeb511bb6ad
Head commit of repository flatpak-overlay: 6a63e062f2fbfa88bb1ea1ab33538747b99158f7

Timestamp of repository gnome: Mon, 09 Jul 2018 17:47:18 +0000
Head commit of repository gnome: 64444ec7014ef76b43ab4c95c789d978ca9342f8

Timestamp of repository sage-on-gentoo: Thu, 12 Jul 2018 23:43:47 +0000
Head commit of repository sage-on-gentoo: caab6f822f0ff64bcde94fa6717854086d43f70f

Timestamp of repository science: Mon, 09 Jul 2018 17:47:28 +0000
Head commit of repository science: 53d50db81f1e62a3500ba37cf4d0a433ddd9fa46

Timestamp of repository steam-overlay: Mon, 09 Jul 2018 17:47:28 +0000
Head commit of repository steam-overlay: cab98164abb68064fd9051b4246f7e37a69161a5

Head commit of repository local: 85b89ec5f4d08c867dd6474faa7362de3f70bca4

sh bash 4.4_p23
ld GNU ld (Gentoo 2.30 p3) 2.30.0
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p23::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.5.5-r1::gentoo
dev-util/ccache:          3.3.4-r1::gentoo
dev-util/cmake:           3.11.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r3::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo, 8.1.0-r3::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r5::gentoo
Repositories:

gentoo
    location: /var/cache/portage/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes

flatpak-overlay
    location: /var/db/repos/flatpak-overlay
    sync-type: git
    sync-uri: https://github.com/fosero/flatpak-overlay.git
    masters: gentoo

gnome
    location: /var/db/repos/gnome
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gnome.git
    masters: gentoo

sage-on-gentoo
    location: /var/db/repos/sage-on-gentoo
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/sage-on-gentoo.git
    masters: gentoo science

science
    location: /var/db/repos/science
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/science.git
    masters: gentoo

steam-overlay
    location: /var/db/repos/steam-overlay
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/steam-overlay.git
    masters: gentoo

local
    location: /var/cache/portage/local
    sync-type: git
    sync-uri: https://github.com/devurandom/gentoo-overlay.git
    masters: gentoo gnome
    priority: 1000

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=znver1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/grs/systems.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=znver1"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --nospinner --verbose-conflicts"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg cgroup compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j6 -l4"
PKGDIR="/var/cache/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacplus aacs acl acpi activities aio alsa amd64 appindicator appstream archive audit avahi ayatana bash-completion bdplus berkdb bluetooth bluray branding bs2b btrfs bzip2 cairo caps cdda cddb cdio cdr celt chromaprint cjk clang cli colord colorio conntrack crypt cups cxx d3d9 dbus declarative device-mapper dirac djvu dri drm dts dvb dvd dvdr editorconfig egl elf emboss encode epub exif fam fax fbcon ffmpeg fftw firewalld fish-completion fits flac fontconfig fontforge fortran fribidi gbm gdbm geoclue geolocation gif git glamor gles gmp google googledrive gpg gps graphicsmagick gstreamer gtk gtk3 harfbuzz hdf5 http2 ibus iconv icu idn imlib inotify introspection ipv6 jemalloc jpeg jpeg2k json kde kipi kms kwallet ladspa latex lcms ldap libatomic libidn2 libinput libnotify libproxy libsecret libsoxr libtirpc libvirt lv2 lvm lz4 lzma lzo mad markdown mercurial metis mjpeg mng mobi modemmanager modplug modules mp3 mp4 mpeg mplayer mpris mtp multilib mysql ncurses netlink networkmanager nls nptl office ogg openal opencl opencv openexr opengl openh264 openmax openmp opus pam pango pcap pch pcre pcre2 pdf pgo phonon pixman plasma png policykit postscript ppds prison pulseaudio python qml qt5 raw readline redfish samba sasl scanner schroedinger sctp sdl sdl2 seccomp semantic-desktop share snappy sparse speech speex spell ssl startup-notification steamruntime stemmer svg systemd tbb tcpd teamd telepathy tga theora threads tiff timezone truetype tslib udev udisks unicode unwind upnp upnp-av upower usb utempter v4l v4l2 vaapi vkd3d vorbis vpx vulkan wasm wavpack wayland webchannel webengine webp widgets wmf wps x264 x265 xattr xcb xcomposite xinerama xkb xml xmp xrandr xscreensaver xv xvid xwayland xz yaml zeroconf zeromq zlib zstd" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_EXPERIMENTAL_FEATURES="stage" CALLIGRA_FEATURES="words sheets karbon plan" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" ENLIGHTENMENT_MODULES="*" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="joystick libinput" KERNEL="linux" L10N="de de-DE en en-GB ar fa tr ja ko zh zh-CN zh-TW" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LIRC_DEVICES="devinput" LLVM_TARGETS="AMDGPU BPF" LUA_TARGET="lua5-2" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5 pypy pypy3" QEMU_SOFTMMU_TARGETS="riscv32 riscv64 x86_64" QEMU_USER_TARGETS="riscv32 riscv64" RUBY_TARGETS="ruby23" STEAMGAMES="dirt_rally dont_starve portal source_engine te120 trine2 witcher2" USERLAND="GNU" VIDEO_CARDS="amdgpu virgl" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-devel/gcc-7.3.0-r3::gentoo was built with the following:
USE="cilk cxx fortran go graphite mpx (multilib) nls nptl objc openmp pch pgo (pie) sanitize ssp vtv (-altivec) -debug -doc (-fixed-point) (-hardened) (-jit) (-libssp) -objc++ -objc-gc -regression-test -vanilla" ABI_X86="(64)"


sys-devel/gcc-8.1.0-r3::gentoo was built with the following:
USE="cxx fortran go graphite mpx (multilib) nls nptl objc openmp pch pgo (pie) sanitize ssp vtv (-altivec) -debug -doc (-fixed-point) (-hardened) (-jit) (-libssp) -objc++ -objc-gc -regression-test -systemtap -vanilla" ABI_X86="(64)"
Comment 1 Jonas Stein gentoo-dev 2018-07-27 14:59:02 UTC
*** Bug 662248 has been marked as a duplicate of this bug. ***
Comment 2 Jonas Stein gentoo-dev 2018-07-27 15:00:23 UTC
patch in #662248
Comment 3 Larry the Git Cow gentoo-dev 2018-08-15 20:08:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b0b0f8fb104fdd0867db97591866bc1b5af425d6

commit b0b0f8fb104fdd0867db97591866bc1b5af425d6
Author:     Jonathan Scruggs <j.scruggs@gmail.com>
AuthorDate: 2018-08-15 17:44:26 +0000
Commit:     Jonathan Scruggs <dracwyrm@gentoo.org>
CommitDate: 2018-08-15 20:08:18 +0000

    media-gfx/blender: bump to version 1.79b
    
    Add patch from Mark Wright <gienah@gentoo.org> for GCC 8
    compatibility.
    
    Closes: https://bugs.gentoo.org/650592
    Closes: https://bugs.gentoo.org/661066

 media-gfx/blender/Manifest                        |   1 +
 media-gfx/blender/blender-2.79b.ebuild            | 290 ++++++++++++++++++++++
 media-gfx/blender/files/blender-2.79b-gcc-8.patch |  22 ++
 3 files changed, 313 insertions(+)
Comment 4 Sergei Trofimovich gentoo-dev 2019-02-23 18:38:55 UTC
Sorry, removed too early from blockers. Stable still fails against gcc-8. Will file stablereq for it.